Home Forum

4k M8 OTT TV box help!

Hi all,

I've recently bought this new box and having nothing but problems with it. I'm quite new to this world to be fair and I have no real idea what I'm looking for. The box ix pretty basic so any tips you can give me on how I can get the best outta the box (apps, .apk files, etc...) will be very helpful. I've tried following the youtube vids but these are pretty dated and the links they recommend are pretty much all defunct now?

 

Related:

#1 John Phillips80, Feb 24, 2015
What do you want to do with it the box M8 is a good box
 
#2 startek44, Feb 25, 2015
I can't find any links that have smooth video in HD quality or any non pixilated links for football? Even on mash up? If you can recommend any apps/add ons that I can download that will help but I'm very new to all this and feel a bit in the woods
 
#3 John Phillips80, Feb 25, 2015
Forgive my potential ignorance but how would I check if I'm using the Kodi Helix?
 
#4 John Phillips80, Feb 26, 2015
You go to setting in the android box and scroll down to APPS and find XBMC or Kodi and click on it and see that the version it is you going to have to learn android a little better if you are going to get anything of of that box
 
#5 startek44, Feb 26, 2015
Thank you for your help. Albeit a tad condescending as I've already established that I'm new to this.
 
#6 John Phillips80, Feb 26, 2015
What i mean is that before try to watch video or use xbmc or kodi you need to learn your why around the system first here is a good place to start :http://www.wikihow.com/Use-an-Android-Tablet
 
#7 startek44, Feb 26, 2015
Hi
I have just collected my new 4k ott TV box fully loaded I go on to kodi, then on to genesis click what ever it want to watch comes up with all the streaming links click and it comes up with one or more items failed to play check the log file for details it happens on everything any ideas??
 
#8 Villameakin, Nov 25, 2015
I also have this problem. What do you do?!
 
#9 Demi Thompson, Dec 3, 2015
Also getting error and log message. Coming to conclusion that my ISP -BT fibre- is blocking data the access to media as it may be deemed illegal by them, same message happened with fire stick, which is why I got the M8.
Any comments on this conclusion.
 
#10 MnI, Dec 7, 2015
Someone please explain more.
 
#11 Porschapx, Dec 8, 2015
Hey Guys as someone who has been installing xbmc/kodi for a long time the error you guys are getting is with the addon itself. The error isn't you isp blocking your content it has to do with the addon. I Assume you are using genesis. Genesis will no longer be updated as the addon dev has stopped maintnence on it. I suggest switching to SALTS or Mutts Nuts etc.
 
#12 NASTYSICK, Jan 1, 2016
Help i have just put my box back to factory settings now get nothing please can someone tell me if there is anything i can do
 
#13 matthew donald, Jan 7, 2016
Can anybody help just bought ott tv box today and every time I press remote it scrambles the picture
 
#14 Buntsy, Jan 7, 2016
Hi I've added the build spinztv via ares and when scrolling through menus the box returns to home screen. Anyone got any ideas why this is happening please?
 
#15 BigFella74, Jan 15, 2016
I keep getting check log message but not sure how to check log,,,
 
#16 Psychotat, Jan 20, 2016
I have a Ott M8 tv box and it just stopped working I tried to do a master reset and now I just get the android Bot like it is working but it never stops. I have tried to unplug and replug but it continues to do the same thing. Can I put something to stop it on an sd card or thumb drive?
 
#17 Android401, Jan 23, 2016
This helped! Thanks
 
#18 Lmv1909, Feb 21, 2016
I have a question. Can someone please assist me, I just got an used M8 ott box. I am unablo to type my internet connection password. It doesnot matter how many times I click ok in the password box it continues blinking and never opens the keyboard screen. I can bot use it ethernet as my cable connection is far. Is there something I am missing or is it broken? Thank you for your time.
 
#19 carola, Apr 22, 2016
Hey Nastysick , I think I have this problem. My M8S box was working but now when i try to stream a movie it doesnt show how many sources have the downloads. I Found that the date was incorrect and causing issues. Changed that and now it shows how many downloads a
 
#20 Harts19, Apr 26, 2016
Sorry, downloads available but won't find a file for anything to load. Is it the addon and how do I change this? Thanks
 
#21 Harts19, Apr 27, 2016
Hey did you set up kodi manually or via an installer like configwizard? which addon are you using that's giving you an issue?
 
#22 NASTYSICK, Apr 28, 2016
So a few funky questions:

I have the same device: set it to Auto-Detect 4k and it "out puts" to 4k the same way a Mustang accelerates when you push the peddle down to the floor: Crash.

Eventually managed to get the screen to stop flicking long enough to get me to the resolution settings which allowed me to manually control the output resolution (sort of....) - I can select 1080p without issue, sure, but not 4k. 4k only seems selectable via "Auto-Detect" - any resolution for this?

That aside, Does anyone else have MASSIVE issues with the included remote? The Home button increases the volume and the volume button takes you to the "home" - Granted I know it's made in China but... seriously is there a way to address that?
 
#23 Xiromisho, May 1, 2016
Hi I'm having the same issue. My box one day stopped working. The light just flashes and nothing turns on. I unplugged the box left it for days plugged it in and same thing. Any suggestions??
 
#24 D1ablo, May 5, 2016
i have this one Minix Neo u1. I have never had any problems with it. Link to compare http://www.china-prices.com/tvbox/5912/minix-neo-u1 or http://www.amazon.com/MINIX-U1-64-bit-Quad-Core-Android/dp/B018K36GMY
 
#25 Viktor67, May 22, 2016