Samsung Galaxy S5 Forum

Support 5.0: Weather displaying on lock screen...don't want it there

Updated my Galaxy S5 to Android 5.0 (Lollipop).

Some of the changes I like; others I don't. One thing I really don't like is this:

I have the WeatherBug app on my phone and have always had it "on" to display the temperature in the status bar at the top of my screen, and show the weather when I pulled down my notifications bar from the top.

However, after this update, it is also displaying a rectangular bar with the weather on my lock screen. I do not want that...it takes up too much space and doesn't leave enough space for other important notifications.

However, when I turn off the "status bar weather conditions," it takes away the information (and the temperature) in the status bar when I'm using my phone. But I want it there. I just don't want it on the lock screen.

It wasn't on the lock screen before the update. Now it is and it takes up too much space. I've played through all the menus and have not been able to figure out if it's possible to get rid of it on the lock screen.

Anyone know anything?

 

Related:

#1 MrElculver2424, Feb 13, 2015
Go to Settings-Lockscreen and scroll down to additional information_click on it and uncheck Weather. That should remove it from your lockscreen.
 
#2 jb4kats, Feb 13, 2015
I did that as outlined and it didn't solve the problem.......
Any other suggestions????
 
#3 TSusala, Apr 8, 2015
I am also using weather bug & have the same problem & just like you I only want it in the notification bar not on the lock screen I pretty much tried everything else & couldn't figure it out. I tried other similar apps & they all did the same thing. It must be the lollipop update that's doing it. I could use some help on figuring this out too if possible. o_O
 
#4 jaydub110, Apr 11, 2015
After the update my wife's phone has it and mine doesn't. We both have a Galaxy S5. Bad thing is that I want it there. I want to be able to see the current temp without unlocking the phone.
 
#5 downtown0309, Apr 12, 2015
I figured it out with help from another site. Go to "Settings", then to "Device", then "Sounds and Notifications", then scroll down under "notification", click "While Locked". Check "do not show notifications" if you want the Weatherbug bar gone. Hope this helps, it sure helped me!!
 
#6 downtown0309, Apr 12, 2015
Thank you so much, downtown0309! I have been trying to fix this for so long and I could not do it until now. :)
 
#7 A Semi Luddite, Apr 20, 2015
I had figured out how to get rid of the bar on the lock screen (doing as downtown 0309 did). But I can't see the weather at all anymore on lock screen cuz Verizon now displays their name in status bar instead of the weather bug temp! So if I want to see the temp I have to unlock the screen!?!? I guess I'll have to go back to having that big bar on the lock screen. I much preferred the old way of it just being unobtrusive up in the status bar.
 
#8 chuckann03, Apr 27, 2015
I followed the instructions about turning the notifications off, and while it did work, it also stopped all other notifications such as new texts and missed calls off my lock screen. So I just found a new way if you're interested in having other notifications pop up.
Instead of clicking on the "lock screen" tab, click on the "Apps" tab right underneath the lock screen one. And then scroll down to "Weather Bug" and click on "None"! this way the big bulky tab is off the lock screen but when a text comes or something you can see! Hope I helped
 
#9 kelsie edwards, Apr 29, 2015
If you tap on the weather bar in the lock screen and drag it down you will see three little lines and clear tap this and it removes it thats what i did
 
#10 tee150963, May 9, 2015
You can disable location in default weather app to hide it! Enjoy! ^,^
 
#11 butcher weng, Aug 28, 2015