Motorola Droid Forum

Activate Device Administrator

Just installed the new 2.2 updated from Verizon/Motorola and received a message that my Exchange account needed to Activate Device Administrator with a whole bunch of permissions. Anyone else see this, know what it is?

Baseband C-01.43.01P
Kernel Version android-build@apa26#1


#1 snowquest, Aug 31, 2010
Newer versions of Exchange have additional configuration that allows them to remotely send additional authorization and authentication protocols to your phone and request additional permissions from the user before allowing the user to authenticate to the Exchange server.

basically, what this means is that, if your Exchange administrator has enabled these features and made use of them, then it could do things like force you to use a PIN to unlock your phone every time you want to use (among other things).

You might want to check with your Exchange server admin first before you actually allow this as I understand that it can be a PITA to work once it is enabled.

Of course, you could ignore it, but it may not allow access to your Exchange server at all, in that case, so...

you'll have to basically play around and see.

Definitely, though, talk to your Exchange server admin.
#2 johnlgalt, Aug 31, 2010
Just as johnlgalt said this is enabled because you have a email setup on your phone that is through a MS Exchange server (Usually its a work email). In order for you to have this setup on your phone you have to allow this or exchange will not allow your phone to sync and get/send email on that account. The new update FRG22B enabled these functions finnaly so Android is more available to the corporate world.

If you do allow this .. you will have to setup either a PIN or Password on the phone you cannot setup the pattern lock. Also ANYTIME your screen goes off you will have to put in the PIN/Pass to access the phone. You cannot turn this off unless you remove the exchange account from your phone.
#3 aioka, Aug 31, 2010
Everytime my device restarts i get this message... then I click it and it goes away. I've never had to set a pin or screen lock though... I don't get that.
#4 superdorf, Aug 31, 2010
You only have to set it, like I said, if your Exchange server admin requires you to do so.
#5 johnlgalt, Aug 31, 2010
It was all working fantastic until the update! OK so yes I have to set a PIN or password. Which really slows down my productivity...

By the way you can see Device Administrators (and deactivate or delete them) from Settings/Location & Security Settings/Select device administrators

Thanks for all of your answers...
#6 snowquest, Aug 31, 2010
I am having the same exact issue on several of these phones here at work after the update.

We don't require the password on our setup (I'm the exchange admin)

However it seems like at random and every time the phones are restarted we get the security warning. Sometimes you have to reactivate device administrator and others you just need to click the message and it goes away.

Also at random you will get the email to your phone as soon as it comes in and others you need to refresh on the phone.

This all started occurring after the new update.

I have reached out to our Verizon rep and their support channels. Hopefully they can re-create it in a lab or provide some further insight because this issue is very problematic for us
#7 mklaro, Sep 3, 2010
You are in a good position to get some solid info right from Verizon. Please share with us anything you discover so we can all learn a little something.

Welcome to the board by the way.

#8 muab, Sep 3, 2010
Please keep us updated. I posted earlier about the same issue. Prior to the update, email, calendar and contacts synced perfectly. Now, it wants the PIN to open phone, which is unacceptable.

Email no longer works.

#9 DDG, Sep 3, 2010
@muab I will keep everyone updated as I figure out more and hear from Verizon.

@DDG There are settings on the Exchange Server (ActiveSync Mailbox Policies) that specify if a password is required or not, along with other parameters. If no policy is defined then the default values are applied to your ActiveSync account. The default value for "Password enabled" is "False" meaning that it should not be required.
More information about that is located here:
Understanding Exchange ActiveSync Mailbox Policies: Exchange 2010 SP1 Help
#10 mklaro, Sep 3, 2010
mklaro- were you able to work with Verizon and find a resolution? We just started getting reports about this issue from our Android users.
#11 BillMcC, Sep 8, 2010
@BillMcC I still have not heard from Verizon regarding this, can't say im suprised. I will follow up with another email again to see if I can get some information out of them.
#12 mklaro, Sep 8, 2010
Here is the reply I got from Google.
Status: WorkingAsIntended
Comment #1 on issue 10989 by FRG22D Update Killed Outlook
Issue 10989 - android - FRG22D Update Killed Outlook - Project Hosting on Google Code
I hear ya; but the previous behavior was incorrect - the PIN should always have been enforced.
You received this message because you starred the issue.
You may adjust your notification preferences at:
#13 DDG, Sep 8, 2010
I keep *trying* to get the Exchange admins to lock me out of server access but no go.
I'm probably the only one of this sad bunch not to have push email :)

Ever go to lunch with these guys?
It's three of them, with their Crackberries, completely glued to email, while sitting at the table. If the waitress doesn't show up naked, she's not likely to get their attention.
#14 leftystrat, Sep 8, 2010
Just got an email from my contact at Verizon requesting more information about the exact update number to my phone. She also informed me she has been working with Motorola on the issue. I will post more as I get it.
#15 mklaro, Sep 11, 2010
Did u ever figure your question out? I just set up my school email & it's asking me to do the same thing! I'm scared to do it because it says it can factory reset my phone & all it's data w/ out warning & a bunch of other things!! Can it really do everything it's asking? If so I guess I'll stick to checking my email from the computer. Hope u can answer this thanks!
#16 cmonday, Jan 19, 2013
cmonday, welcome to the site!:) I hope we can help you.

But first, the last post in this thread is over two years old. Also it pertains to the Motorola A855 Droid phone and a version of Android that is not very current.

So in the interest of trying to give you the help you request, are you using the above named phone? If not, which one, and further what version of Android is on it?

#17 teddyearp, Jan 19, 2013

He teddyearp, I have the same question as cmonday. I am using a Droid Razr Maxx HD with jellybean update.

Has this topic been resolved/updated?

#18 jennich, Feb 4, 2013
I didn't want you to loose your question.

Try asking your question in Motorola Droid RAZR HD / MAXX HD where the Razr Maxx HD visitors stop by.

... Thom
#19 Thom, Feb 4, 2013