Samsung Galaxy S4 Forum

Support Alarm clock not working Samsung Galaxy S4

I'm wondering if anyone can help me. I've only had my phone for two months and all of a sudden my alarm clock has stopped working.

It looks like the phone goes into sleep mode. The reason I say so is because once unlock the phone it takes a while for the phone to update the time. For example i set my alarm for 7am. At 7.05am the alarm still has still not gone off and the time on the home screen will read 2.30 (depending on the time the phone goes to sleep). Once i unlock my phone and click on an app such as weather it will update to the current time. Has this happened anyone. I also suspect that the flip case could also be why the phone goes in sleep mode.

Any help will be appreciated.


#1 Chuckb, Feb 6, 2014
I haven't heard of that.

If power saving / cpu power saving mode is turned on, maybe try turning that off?

Maybe you have frozen or disabled a related system app? Long shot ... I know
#2 electricpete, Feb 6, 2014
I have similar problem on my new pad and Googling can't find any reference to it.

Apps which should run in the background are just stopping in sleep mode. Put the screen back on and suddenly the alarm goes off.

I got a new pad out of the box fully charged two days ago. Ran it all day, installed medigong, bodhi timer, insight timer and an alarm clock app. All these worked as expected for the first day, but seller advised a system restore/recharging as the tablet failed to start a couple of times. I then installed the same apps and they only work if I completely disable sleep mode (ie have screen on all the time). Done a couple more restores and charges, changed loads of system settings but still same problem.

Could it be a recent update? My system says it's completely upto date. Or are sleep mode problems common?
#3 mattnotfat, Mar 15, 2014
It sound like something with settings. Are you guys using any kind of Advance Task Killer? If so, uninstall it and see if the problem goes away. Also, make sure the app isn't on the "Turned off" list.
#4 itsallgood, Mar 19, 2014
Do you have blocking mode on?
#5 motoracer1486, Mar 19, 2014
I'm using the alarm that's part of the clock app that comes on the phone. I check it before I go to sleep at night, and it says the alarm is set to go at 6:55am the next morning. I wake up at 7:30, and the alarm hasn't gone off - and when I check it, in the settings it appears to have gone onto Snooze mode (it's yellow with a Zzzz next to it instead of green. Turned off is grey.) I'm about to try recreating it and see if that works tomorrow morning or not. Does anyone else have any hints?
#6 Jenerator, Apr 1, 2014
Yesterday morning I was late for work as the EXACT same thing happened. This morning I was up alarm so I waited and all that happened was my phone screen lit up and the clock icon was in the top bar...when I unlocked my phone the screen was black and not.responding and then came up with the 'clock is not responding' notification. I reset my phone then went into settings>application manager>running and pressed stop on clock and alarm. Did a test alarm and went off as usual so.hopefully fixed. Hope this works for you
#7 parsnips14, Apr 18, 2014
If you're running Kit Kat. You can thank that POS for your problems.
#8 jdCaptivate, Apr 18, 2014
1 Google search should not be your 1 choice for troubleshooting.
Yes googl is cool enough and you can always find somebody writing about something about what you search for thus world wide web.

2 about the alarm problem, alarm will always work if in sleep mode, if in flight mode or if in Blocking mode..

3 Test your alarm set an alarm for like in 3 min check if it rings and be sure you selected the appropiated days for it to ring else it will only ring on those days you selected..

* 1 Clock
* Create Alarm
* Set Clock to ring
below tap days
M T W T F S S they will change to green.
(This option because you can have multiple alarms for diff topic's)

* Alarm Type below days, tap to set type of Alarm
(Melody, Vibration, Both or orientation) Choose Melody for sound music what ever you want as choice

* Alarm tone below Alarm Type, tap to set a specific tone tap one to test it is also really a sound you can actually hear, that it works.
Press SAVE give it a name for the occasion
When an Alarm is active alarm clock icon will be added to the left of the signal type of your carrier.
See example:

Note you can activate deactivate the set alarm in the Alarm menu by tapping to the right of the Alarm Name, Standard (Alarm) active is green / deactivate it turns white + icon notification area upper part of screen disappears..

Yes if any process killer is running check the list, but it shouldn't deactivate the alarm process only if Clock app has been deactivated but then is not visible at all in Programs..

99% out of 100 is a user mistake sorry to say that is not meant bad and I hope my guide can help you to get up on time!!!
#9 SamsungGalaxyN, Oct 13, 2014
No Kit Kat has no problems concerning the Alarm,
only known problems has been a depleting battery...

(Again 99% of all Android problems is user related, sorry to say but that is the real truth)
#10 SamsungGalaxyN, Oct 14, 2014
So with no settings changed why have all my alarms stopped working?
I have tried deleting and re making and yes I know how the settings work.
The alarm tries to sound, the screen momentarily changes to the ringing screen but immediately the alarm self cancels and the screen returns to last screen in use.
This happens with voice control on or off. Snooze on or off. In built tones or mp3.
#11 nick7076, Oct 15, 2014
I have been using my alarm (multiple different alarms for different days) since I got my S4 a year and a half ago. Yesterday, nothing. I was holding the phone in my hand checking something when the alarm shold have gone off, nothing. Today I started checking different posts on forums and tried different things to fix, nothing. At one point I noticed that I would set the time for the alarm for 2 minutes in the future and set the phone down. I'd come back later and when I opened my phone there would be a small banner at the bottom of my screen that said "your alarm is set for two minutes". I can't figure it out. I've changed nothing, added no new apps.
#12 JMW, Dec 17, 2014