Samsung Galaxy S7 Forum

[ANSWERED] Can't flash firmware on SM-G930A

I put my phone in a bootloop in my attempt to remove Knox from the phone. I rebooted the device and now it gets stuck on the AT&T logo. I've been in this situation before, and I knew exactly what I had to do to fix it, but, I faced 2 problems.

1) The flash fails with the error Fail (Auth) in odin
2) I literally can't find a version of Odin that really works with this thing.

I have the 4 file firmware on my computer. plus the pit file for it, and when I first got the phone, I enabled OEM Unlock under the development settings tab (for obvious reasons). Thinking the bootloader was unlocked, I rooted the phone with SuperSU, and nothing was wrong with the root, but like I said, the boot loops happened after I tried to deknox it. I've deknoxed stock roms before, so I knew exactly what I was doing (I deknoxed my older phone without any issues). The error that Odin gave off normally means that you can only flash current firmware, and you cant downgrade. But the firmware i'm trying to flash IS THE CURRENT FIRMWARE (G930AATT2APF2) (Android 6.0.1). Any help is greatly appreciated. Samsung is slowly becoming Apple. SMH.

Another Edit: I haven't been keeping this thread up-to-date, but I found out that APF2 is one of the older versions of MM for my phone, APK1 is the latest version of the MM firmware for my phone, not APF2. This is when I first got my phone, so I didn't have much knowledge of how it worked until later.

I downloaded the firmware and odin from my thread here:


#1 KingOfTheNet, Dec 28, 2016 Last edited: May 27, 2017
PSA: I finally succeeded by flashing the PJ4 firmware. I'll leave a download link to the firmware down below. If the link goes down or doesn't work for any reason, please let me know! Note: I recommend downloading the version of Odin I was successful with to avoid any issues, download link below.

Thread Link:
#2 KingOfTheNet, Dec 28, 2016 Last edited: Jan 19, 2017
I had Sprint with my phones fully paid off got them unlocked move over to att. Flashed the software to att to make everything fully functional. But I need to send my phone in for repair too Samsung tried flashing back too Sprint software But I keep getting sha256 every time I try to flash would greatly appreciate if someone could help me out
#3 Cbrodriguez1989, May 26, 2017 Last edited: May 26, 2017