Home Forum

App to edit .mov files when I'm traveling (No pc access)

I'm looking for something that I can use on my S3 i9305 to remove the unneeded content from HD video footage shot on my SJ4000 action camera (GoPro copy) so that I'm not saving huge files all the time. I'll be traveling through India without a computer and don't want to risk hooking my cards/hdd's up to pc's in internet cafes and run the risk of them picking up viruses.

Unfortunately the camera saves the content in .mov format which means that I can't use the standard GoPro editing apps.

I've not found anything that I've tried so far that will do the job. There was an app that actually registered the .mov files but then the apps forced closed when I tried to use it. Nothing back from the developer either after messaging them. (I can't remember the name of the app, but I'll have a hunt around and see if I can find it and post the name on here)

I guess the last option is to see about the possibility of using someones laptop. But then I'd have to run a virus scan (and possibly download S.A.S. or Malwarebytes onto their computer) and find something that I could download or ideally a portable app (I've got a usb stick with Portable App Suite on it)
 

Related:

#1 woldranger, Jan 4, 2015
.MOV is Apple QuickTime format isn't it? I've only ever had dealings with .MOV via iMovie on a Mac. Not even Windows Movie Maker will touch QuickTime videos, not unless you transcode it into something more appropriate, or you cough up the $$$ for Adobe Premier or something. Maybe the camera makers were expecting you to be using a Mac? iMovie on an iPhone or iPad will edit .MOV no problem.

I guess nothing on Android dare touch editing QuickTime, unless they pay up the patent fees to Apple, else incure the wrath of Apple's lawyers. That's a guess.
 
#2 mikedt, Jan 5, 2015 Last edited: Jan 5, 2015
I already mentioned there being an an Android app that runs it, so thankfully the fact that it's a file type aimed at Apple systems doesn't seem to have put paid to things.
Here's a link to the app that I've found and this time round it seems to be working.
https://play.google.com/store/apps/details?id=com.catflow.andromedia&hl=en_GB
I managed to edit a video directly from my phone (not the micro sd card) though it took well over 10 mins to render a 50 second clip. When I've tried it previously there would be an error and it wouldn't complete the process, also it's not been updated since may 2013 so if this is to be the app I'm going to use I'll just have to hope that it holds up because there's no help from the dev.

This is a start, but if anyone else has any other suggestions.... :)
 
#3 woldranger, Jan 5, 2015