Home Forum

Tips Bluetooth Wiimote Fix!! Stock/Sense

For most here this is probably moot, since most are likely running custom roms that bypass the issue. However, as a new Evo owner, I'm not quite ready to take the plunge just yet. I'm happy with how the phone is stock aside from this one issue (Bluetooth/Wiimote) because I loves my emulators.

Well, on to the fix.

First, download and install Bluez IME. Put a shortcut on your Home screen to make things easier later.

https://play.google.com/store/apps/...=W251bGwsMSwxLDMsImNvbS5oZXhhZC5ibHVlemltZSJd

Second, download and install the HID enabler

Redirecting

Now do the following:

1. Open Bluez IME Settings
2. Activate bluetooth (if its not already running)
3. Hit "Select Device" then "Scan"
4. On your Wiimote, press the "Sync" button inside the battery cover
5. Wait.....
6. You should see something like "Nintendo-RVL-.....". Select it.
7. Hit "Select Device Driver" and select "Wiimote (HID)"
8. Hit "Select IME" then "Configure input methods"
9. Check the box for "Bluez IME" and click "OK"
10. Click back button twice to close.

Now, that parts done and that's the only time you have to do it. The next step just requires a tiny bit of quick action. You have about 10 seconds to do 3 seconds of inputs, so no biggie. The sucky part is you have to do it each time you wanna connect your Wiimote.

1. Go to "Settings" --> "Bluetooth" (turn it on if it's off)
2. Hit the menu button and click "Search for devices"
3. On your Wiimote, press the "Sync" button inside the battery cover
4. As soon as your Wiimote appears (Nintendo-RVL...) Click it.
5. As soon the "Enter PIN" BOX pops up, Quickly press the Home button, then hit the "Bluez IME" shortcut on your home screen and immediately tap "Select IME" and click the "Bluez IME" input method.

You'll see 3 messages at the bottom of your screen. First, will say "connecting to (MAC address of Wiimote)" Then it will say "pairing rejected", which is from the Bluetooth stack.

Finally, it will say, "Connected to (MAC address of Wiimote)"

The lights will flash continuously on the Wiimote, but it works great. I tested it out on ePSXe, Gensoid, Gameboid and SNESoid. They all worked great. If you want to use the Classic controller, just make sure you have it plugged into the Wiimote before you press the "Sync" button.

Hope this helps someone.
 

Related:

#1 Omniscience3, Feb 24, 2013
This worked perfect on harmonia. Thanks
 
#2 rpgrini, Apr 25, 2013
Thanks for this. You wouldn't happen to know how to get a wiimote to work on android 4.2?

By the way you can press the 1 and 2 buttons at the same time instead of opening the wiimote to press the sync button.
 
#3 swerver32, Jun 15, 2013
does this work with ps3 controller?
 
#4 nexgenasian, Jul 30, 2013
Hi thank you sooo much, i have an hp 7 tablet and i bought a aftermarket (cheap) wii classic controller, on wiimote app it would say that up, left, L1, A and select buttons were assigned to 3 other buttons which were already mapped so caused issues, after using this it works perfect on ps4droid, ppsspp, snesoid, md.emu, and nastalgia.nes. analog now works flawlessly too although i had to map down as up and left as right ect on bluez ime setting, thanks again good work :) oh and you mentioned that 4 lights on wiimote would continuously flash well mine dont and i dont have to redo bluetooth setting each time either just select input method sync and play, :) very cool
 
#5 willz, Nov 2, 2013
tried this out on my LG optimus F6, works just fine!! havent gotten to play around with it a lot though. tried it on a gba emulator to play a hacked pokemon rom (i own the original game) with a wii controller and it worked with flying colors. thanks a million for sharing this!!
 
#6 metathirteen, Nov 20, 2014
Should this work on Kitkat? I followed all the steps several times without actually connecting. The messages I get are:
Connecting to mac address
Error:bit socket connect failed (instead of "pairing rejected")
Connecting to mac address
Error:bit socket connect failed

I'm trying this on a Galaxy Tab Pro 12.2 with a rooted stock rom. Using another method with a USB BT dongle I can use my Wiimotes but only until the battery runs out. I can't charge my tablet and use the BT dongle at the same time. Having one port for everything on this tablet sucks.
 
#7 Jerryo100, Feb 13, 2015
Welcome to the forums!

Sorry for the trouble.

I take it you also installed the apk listed above?
 
#8 EarlyMon, Feb 13, 2015
Thanks and np. I've been searching for a way to do this since Google hosed the BT stack. The clunky BT dongle workaround does work until it's time to recharge. I installed Bluez IME from the playstore then downloaded and installed the HID enabler apk and followed the instructions posted above.
 
#9 Jerryo100, Feb 14, 2015
I get the same error as you on a Galaxy Nexus running 4.2.1 but I ultimately wanna get it going on my Galaxy Tab S running 4.4

How do you use your Wiimote using the USB BT dongle method, I don't mind doing that if you have a working way?
 
#10 Hitman_888, Feb 16, 2015
Hello, I have android 4.4 KitKat and tried to use this method and it gave me the message, "Error: read failed, socket might closed or timeout, read ret: -1"
I did everything you said. Is it that my device isn't compatible? Is there any way to connect a controller used for emulators?
 
#11 Acirta Alice, Mar 22, 2015
Can someone tell me of this works with wii u pro controller? Im really intrested.
 
#12 DatPikachu46, Feb 4, 2016
This has not worked on my Galaxy S6...I went through the instructions but at the step where it says to select the wiimote drivers, there were no wiimote drivers to select. I only saw zeemote and a few others that seemed to be for other types of bluetooth controllers
 
#13 xZEEx, Feb 13, 2016
I have this problem also on my Galaxy note 3 N9005
 
#14 giova, Mar 6, 2016
3 years later and this works still. Using an LG Optimus L9. Thank you for the work-around!
 
#15 IlikeMoney, Apr 14, 2016
I have an S7 Edge on Android 6.0.1 and can't get this working. Bluez IME can't find the wiimote in the first scan step, despite Bluetooth settings seeing it. Is there another package I need?
 
#16 AechRK1994, May 3, 2016
I'm on a Galaxy S6, and it all works fine, however I get "Error: bit socket connect failed" and it doesn't connect

Any ideas?
 
#17 charburg, May 8, 2016
Stumbled across this page looking for 3rd party controller support on the cronusMAX console adapter. I just thought I'd add a little piece of information for people struggling to get their controllers to work on Android. With the CronusMAX adapter and an OTG usb cable you can use ANY controller on android. For bluetooth controllers simply connect a $5 bluetooth adapter into the cronusMAX usb port. The software for the device has all the information you need to know to get your controllers set up, -ive tested and used wiimote, pro, xbox one & elite (corded), ps4, and a mouse set to the ps3 analogs for fps games. Yes this fix will set you back $60 and an hour of learning the software but you wont need a rooted phone and works with any android version supporting native controller support.
 
#18 Mr_Jones, May 10, 2016 Last edited: May 10, 2016
Not working for me. It says Connecting to(My mac adress) Forever
 
#19 davneta, Jun 19, 2016
I can't install that second apk.
 
#20 Remi Renault, Jul 21, 2016
i cant find the HID thingy...
 
#21 tonydaderp, Dec 11, 2016
Now i have the HID apk, but it does not show up under "Select device driver". Plz Help! XC
 
#22 tonydaderp, Dec 12, 2016
This worked in the beginning like two or three times but now i can't connect wiimote into my android device anymore. My device is oneplus one.
 
#23 Eikku, Jan 13, 2017
My phone notices the wii remote in the Bluetooth settings, but when ever I try to scan for the wiI remote in Bluepad, it doesnt notice the wii remote. Can someone please explain why?
 
#24 Bumblebot, Jan 15, 2017
Does this method allow multiple connections with more than one Wii remote?
 
#25 brad74, Aug 3, 2017