Nexus 4 Forum

Root Bootloop - No Recovery - No USB Debugging

I'm completely new at this stuff, so please forgive my ignorance,

I was running PA 3.99, on a Nexus 4 and when the KitKat 4.4 aosp came out, I got curious. I downloaded it and tried to flash, it didn't work with TWRP, so I temporarily booted CWM using their playstore app and flashed 4.4, and after it asked me to get rid of the recovery.

I can't remember the exact wording, (it was late). It started to boot with the word "android" flashing in grey, it then booted for 7 hours. I tried to unroot and flash custom recovery using Nexus Root Toolkit 1.7.3, but it said "can't find fastboot device" I tried to reinstall the drivers, but USB debugging wasn't enabled, so I can't.

I then booted into stock recovery and on the advice of another forum I wiped data.

Now it won't get past the google sign.

It's still unlocked and I can get into bootloader mode.

In essentials, these are my problems:

Since I have no recovery, I cannot restore a backup
Since I can't restore, I need to flash stock and unroot
To do that my computer needs to find my phone as a fast boot device, but it can't.
To make it see my phone, I need to install the right drivers
To install the drivers I need USB debugging enabled
To turn on USB Debugging I need to not be in a bootloop

Does anybody see a way around this?

 

Related:

#1 Android Question, Nov 2, 2013
I think you'd best be served by signing-up with us and posting something in the Nexus 4 - All Things Root - Android Forums area where the folks that know you device best can help you out.

Since it is a Nexus device, if you can get the USB driver issue sorted-out (always such a pain, eh?), you'll always be able to flash a factory image and get back to a working version of Android.

Cheers and best of luck!

P.S., if you do sign-up and post back here, let me know if you'd like me to move your thread for you over to the above Nexus 4 all-things-root area.
 
#2 scary alien, Nov 2, 2013
Hi! OP here. I've registered.

I have an update to my situation.
I followed your thread here: http://androidforums.com/verizon-ga...ore-vzw-samsung-galaxy-nexus.html#post3736590
to install SAMSUNG drivers.
My phone connected in fast boot, and when i tried to flash to stock I got EOCD not found, and a whole lot of gibberish.
In trying to recreate it for a screenshot, i discovered it no longer connects. great.
 
#3 megsto, Nov 2, 2013
Ah, cool, megsto! :thumbup:

Welcome to our AndroidForums (but sorry it's under these circumstances) :).

I've moved you over to the Nexus 4 all-things-root area as previously mentioned.

Not totally sure if there are newer USB drivers for adb and fastboot available since I posted that GNex thread, so you might want to take a peek here in the N4 ATR area for what they guys here have posted.

Hopefully the good folks in here will be able to get you going in short order.

Cheers!

edit: there are two root toolkits you might try:


(don't know which one you had previously used; I usually do my stuff manually so I'm not really familiar with the above toolkits other than they automate the manual processes for you).
 
#4 scary alien, Nov 2, 2013
I've been using Wug's.
I downloaded Mskips, but it doesn't support the build I had without a donation. I don't have any of the methods of donation. i.e. PayPal

Thanks so much for your help anyway. :)
 
#5 megsto, Nov 2, 2013
Alright, since your device comes up as as a bootloader interface, we need to test it. Creat a new folder on your desktop for putting files in. Download our mini-sdk from our site, and unzip all the files into that folder your created.

Next we need to download the Nexus factory image from here. Once again extract everything into that folder you created on the desktop. Don't extract the zip file that comes out of the tgz.

Once that is done, we should test your driver. Open that folder and then hold ctrl + shift and then right click. You should see an option to open command prompt here. Once open, type the command:
Let me know what the output says.
 
#6 jhawkkw, Nov 2, 2013
With the factory image, there's nothing to extract as far as I see. SHould I just put the tgz file in my folder?
 
#7 megsto, Nov 2, 2013
the tgz file is a container file that contains a few more files in it. If if you're computer can't do it natively, try using WinRar
 
#8 jhawkkw, Nov 2, 2013
it says:

 
#9 megsto, Nov 2, 2013
Alright, that means that the command wasn't executed within the folder that the fastboot.exe file is located. Make sure you open the command window where you extracted the mini-sdk zip folder's files into. It should either turn up blank or say device with a bunch of numbers after it.
 
#10 jhawkkw, Nov 2, 2013
C:\Users\Maggie\Desktop\ROOT FIX>fastboot
usage: fastboot [ <option> ] <command>

commands:
update <filename> reflash device from update.zip
flashall flash boot + recovery + system
flash <partition> [ <filename> ] write a file to a flash partition
erase <partition> erase a flash partition
format <partition> format a flash partition
getvar <variable> display a bootloader variable
boot <kernel> [ <ramdisk> ] download and boot kernel
flash:raw boot <kernel> [ <ramdisk> ] create bootimage and flash it
devices list all connected devices
continue continue with autoboot
reboot reboot device normally
reboot-bootloader reboot device into bootloader
help show this help message

options:
-w erase userdata and cache (and format
if supported by partition type)
-u do not first erase partition before
formatting
-s <specific device> specify device serial number
or path to device port
-l with "devices", lists device paths
-p <product> specify product name
-c <cmdline> override kernel commandline
-i <vendor id> specify a custom USB vendor id
-b <base_addr> specify a custom kernel base address
-n <page size> specify the nand page size. default:
2048
-S <size>[K|M|G] automatically sparse files greater th
an
size. 0 to disable
 
#11 megsto, Nov 2, 2013
alright, it sees the file, so what does the fastboot devices command return?
 
#12 jhawkkw, Nov 2, 2013
C:\Users\Maggie\Desktop\ROOT FIX>fastboot devices

C:\Users\Maggie\Desktop\ROOT FIX>
 
#13 megsto, Nov 2, 2013
Alright, so the driver is indeed not set up correctly. Try downloading and installing these universal drivers made by one of the best android developers. Once the installation has finished, uninstall the current bootloader driver and make sure you hit delete driver. Then use the Scan for Hardware changes in the Action menu option.
 
#14 jhawkkw, Nov 2, 2013
I've downloaded it, but im having some trouble uninstalling the original driver, it keeps automaticlly reinstalling.
 
#15 megsto, Nov 2, 2013
I have to run some real life errands. If all goes well, I should be back around 5PM EST. If you do manage to get the drivers working, close the command prompt window and then run the flash-all.bat file that was extracted from the factory image .tzg file. That should take you back to stock automatically. If you still have problem, someone else might be able to help you in the meantime or I will once I get back.
 
#16 jhawkkw, Nov 2, 2013
I will, Thank you so much for you time:)
 
#17 megsto, Nov 2, 2013
This is what I got when running flash-all:

sending 'bootloader' (2201 KB)...
OKAY [ 0.076s]
writing 'bootloader'...
OKAY [ 0.304s]
finished. total time: 0.384s
rebooting into bootloader...
OKAY [ 0.003s]
finished. total time: 0.005s
< waiting for device >
sending 'radio' (54321 KB)...
OKAY [ 1.776s]
writing 'radio'...
OKAY [ 3.449s]
finished. total time: 5.227s
rebooting into bootloader...
OKAY [ 0.004s]
finished. total time: 0.006s
< waiting for device >
error: failed to load 'image-occam-jwr66y.zip': No error
Press any key to exit...
 
#18 megsto, Nov 2, 2013
megsto,

Does that image-occam-jwr66y.zip file exist in the same folder/directory as the flash-all script?

The error message above makes me think that it's not there somehow? (it should be present after unzipping the contents of the .tgz factory image).
 
#19 scary alien, Nov 2, 2013
yes, They're in the same folder on my desktop.
 
#20 megsto, Nov 2, 2013
Ah, thanks...maybe it's a bad download?

Do you know how to check the MD5 sum of a download on your PC?

I'm assuming you downloaded the "4.3 (JWR66Y)" (https://dl.google.com/dl/android/aosp/nakasi-jwr66y-factory-1e503532.tgz) file from the factory image page (i.e., for the Nexus 4)?

It lists the MD5 for that file as 6f6db7729bc6b8089683bc5297a09b93...

Here'a few links from this page here at AF:


You should verify that you got the same MD5 checksum as listed from the factory image page to verify that your download was whole and un-corrupted.

edit: I downloaded the above .tgz file and extracted its contents and calculated the MD5 of the image-occam-jwr66y.zip and this is what I get just for that file:

(i.e., versus the MD5 list for the entire .tgz file as listed in the factory image page)
 
#21 scary alien, Nov 2, 2013
I got it to work. What i did was delete the .zip I had, download a new one from Google, same link, I re-extracted the files, opened flash-all, and this time it worked. Took a few minutes to boot up but now it works perfectly.
I don't know what was different.

Thank you guys so much, I was definitely starting to panic.
 
#22 megsto, Nov 2, 2013
[​IMG]

:)
 
#23 scary alien, Nov 2, 2013
Congrats on getting it working again and Thank you SA for helping get our friend here to the finish line. :thumbup::)
 
#24 jhawkkw, Nov 2, 2013
Nice job guys!
 
#25 odojoe, Nov 10, 2013