LG G3 Forum

Root Bricked LG G3

Hello!

I have an LG G3 D855 Eu model and I succeeded to brick it last night. It had Lollipop stock. After rooting it and installing TRWP, I was getting an Error when rebooting into recovery "Secure Boot error". I found a solution at this page: http://forum.xda-developers.com/lg-g3/help/help-secure-boot-error-trying-to-boot-t3054977 and I was trying to replicate. At the Terminal command step "su" worked, the second line didn't, the third line worked and the final one didn't. I know that the third one bricked my phone.

dd if=/dev/zero of=/dev/block/platform/msm_sdcc.1/by-name/aboot (writes “zeroes” to the partition to “wipe” it out)

Since then the phone is almost dead. No way to wake it up, I've tried every combination of buttons and USB plugin. The only signs that is alive are that when I connect it without the battery to USB it shows the with the phone connected and the yellow triangle with a question mark and that is detected as LGE Androidnet USB and modem in the Device Manager. I tried the TOT method and the KDZ method, nothing worked. In Qpst it is detected as Phone in Download Mode and in QPST Configuration as Sahara Memory Dump (Connected Phone: Q/QCP-XXX).

LGNPST detects it as UNKNOWN, only Emergency active, and doesn't do anything when trying to upload the bin file, gives Error: Could not switch to download mode.

Is there anything I can do to unbrick it? Any ideas?
 

Related:

#1 alex_da_fixeru, Mar 24, 2015
Only thing that comes to mind is try and replicate what we've done on the G2 which is to short some capacitors on the motherboard to restore bulk mode. Then the partitions can be written to the phone via Linux. Here's the thread that we G2 users have:

http://forum.xda-developers.com/lg-g2/general/lg-g2-unbrickable-fix-real-hard-brick-t2904404

There was some talk about trying it on the g3 in the last couple pages, but I don't see where anyone reported back. It'd likely be a different combination of pins so you'd be a trail blazer if you figured it out unless there's something like this already out there for the G3 that I'm unaware of.
 
#2 iowabowtech, Mar 25, 2015
I know that thread, but I don't want to open the phone as it is in warranty.
 
#3 alex_da_fixeru, Mar 25, 2015
Yep I totally understand. Its more for the last resort, out of warranty crowd.
 
#4 iowabowtech, Mar 25, 2015
Ha - I did the exact same thing.

I think it's because the line

dd if=/dev/block/platform/msm_sdcc.1/by-name/aboot of=/sdcard/lollipop-aboot.img
attempts to backup the lollipop-aboot.img to /sdcard/, where that path didn't exist on my phone. My SD card was at /storage/external_SD/

But anyhow, did you manage to resolve this? If so, how?
 
#5 David Lgg3, Jun 11, 2015