Home Forum

Support Cannot deactivate a device administration to delete a fake malware app

Hey guys. So while on the internet I was redirected to some page that downloaded to my phone a fake malware app called PhoneBooster. When I tried to uninstall it, the uninstall AND force stop options were blurred out. Everything was blurred out to where I could not touch this app. So then I went into my file manager on my phone and tried to delete it from there but it said it was managed by device administration. I went into there and tried to deactivate the one involving this malware app but it would not even let me. I would click to uncheck the box and it would kick me out of the screen and back into phone settings. I go back into device administrations and the box is still checked. I cannot even disable the device administrations. What can I do to delete this from my phone? Will moving the app totally from my phone's internal storage to my SD card able me to delete the app? Or, since it is one of those apps like the ones you first get built into your phone that you cannot delete, can I just not delete it now? My phone is rooted, in case this information helps. I have a ZTE Awe n800 running 4.1.2. Please help me, this malware is very annoying. Thanks!

 

Related:

#1 KellyDraves, May 30, 2015
Everybody has a ZTE Awe! Press and hold the power button the two and hold on the power off option the press ok the your phone will reboot into safe mode and then you can remove the app.
 
#2 rcunningham, May 30, 2015
Maybe you hear ZTE Awe mentioned a lot because this phone causes the most discussion due to its strict policies and whatnot haha. I love my phone, though. And my phone also does not go into safe mode when I put my phone into recovery mode from holding down the volume, power button and home key. Or am I not understanding what safe mode is, because that could be it, too, haha.
 
#3 KellyDraves, May 30, 2015
Find a guide online for how to put a Android into safe mode. If you can get into recovery flash a new ROM and your all set.
 
#4 rcunningham, May 30, 2015
Okay. simple enough. Thank you for the guidance! I'll post back in here if I am still stuck, which I might be. Not really a techy person, unfortunately.
 
#5 KellyDraves, May 30, 2015
Oh my goodness I found safe mode. I did not even know you could press and hold the "power off" option for further options and I have had this phone for 2 years. My goodness. Okay so as far as getting to this malware app thing, what do I do to delete that now that I am in safe mode? Sorry for all the dumb questions. Do I just continue going about deleting it through the file manager and deactivating the device administrations for it or can I just now uninstall it from the app info options?
 
#6 KellyDraves, May 30, 2015
Deactivate it in the devices administrators then uninstall it like a normal all.
 
#7 rcunningham, May 30, 2015
Got it! Thanks so so much!
 
#8 KellyDraves, May 30, 2015
Your welcome
 
#9 rcunningham, May 30, 2015
Hey! i have the same problem.. i did put my phone on safe mode and when i pressed deactivate button my phone became black and blank and after sometime it displayed the icons but app was not deactivated.. please help.. ill be grateful.. im trying again and again but same thing happens.. the app has accessed almost all features even read and delete data on sd card.. please someone help
 
#10 Quncy, Jan 8, 2016 Last edited: Jan 8, 2016