Sony Ericsson Xperia X10 Mini Pro Forum

Support Cannot sign in to google account after trying EVERYTHING!!

I have recently started to have problems with the market on my xperia x10 mini pro. I tryed everything - clearing cache, uninstalling market updates, rebooting my phone like a million times. Nothing worked so i decided to make a factory reset. Now i can't sing in into my google account. I tryed signing in to youtube, rebooting my phone without the SIM card, i made the 2 step verification on my computer for my google account, it generated the password, still nothing. I have no idea what to do. PLEASE HELP!



#1 selecentered, Nov 27, 2012
First off welcome to the forums!

If you registered your phone number to your Google account it might mess up signing into your account. So try and remove the number from your account and see if that fixes anything.

Hope this helps :)
#2 Digital Controller, Nov 27, 2012
I have exactly the same problem with Android 2.1. I can't connect to my google account (I'm using the 2 steps verification by the way) after a factory reset. Always the same error message: "Can't establish a reliable data connection to the server" I tried it with wifi and 3G and the results were the same.

I look for solutions on various websites, and here is what I found:
-connection to youtube app with google account => it didn't work
-root and delete some file settings => I couldn't make it
-remove the sim card and try to connect to google account without it => it didn't work
-downgrade to Android 1.6 => I want to use apps who couldn't work on that version

That's a real problem, I can't go to the Android Market, Gmail, can't have updates from the market... a pain in the bum!

If somebody has other ideas, that would be awesome

#3 wagnernico, Nov 27, 2012
Two-step verification doesn't play well with android google sync.

Turning off 2-step verification

Visit the Using 2-step verification page under your Google Account settings. Sign in with your username, password, and verification code if prompted.
Click Turn off 2-step verification.
A pop-up window will appear to confirm that you want to turn off 2-step verification. Click OK.

Hope this helps.
#4 Phatninja55, Nov 27, 2012
Thanks for your idea, I tried it but no change...
#5 wagnernico, Nov 27, 2012
Thanks for your help :)

How do i remove phone number from my google account?
#6 selecentered, Nov 28, 2012
I removed the phone number, still nothing :(
#7 selecentered, Nov 28, 2012
When i try to log in via youtube, it says i have no network connection. i'm connected to my wifi at home.
#8 selecentered, Nov 28, 2012
did you find the solution
#9 rajrob, Mar 18, 2013
Hello I have discovered a solution
but you must have root

download root explorer

1go to system folder

2go to etc folder

search for hosts file and delete it

thats all thanks B-)
#10 yazoo0oody9, Jun 17, 2013
the problem still existing in my Motorola Electrify 2 (XT-881) what the hell is going on with my android device, i have also tried all that tricks, but still the problem is not solved yet.

please do help....Thanks and waiting..
#11 whatmubashir, Jun 28, 2014
Had this problem after factory reset. Spent hours trying to find out what to do. Eventually found this thread - turned off 2-step verification, worked like a dream. Thanks - I can now start living again.
#12 Griffinit, Sep 10, 2014
This worked twice on two seperate devices. One the same as OP, the other a samsung galaxy tab 4. Made an account on the forum to say, Thanks!
#13 Dylan1488, Dec 18, 2014
Thanks boo this worked.. Have been all up in Google for hours now you saved me.
#14 Emmzybiz, Jun 2, 2015
Bro *
#15 Emmzybiz, Jun 2, 2015
solved it for you guys
just use the es file explorer and go to system - etc - search for a file named ( hosts ) and just rename it
#16 anwarkh, Jun 4, 2015
Downloaded "es file explorer" to my PC and then copied the file to my Alcatel A564C since my Alcatel can't get to any WiFi sites for downloads. Unfortunately the phone indicates "Install Blocked" then goes on to indicate "For security, your phone is set to block installation of apps obtained from unknown sources." There must be more than one way to rename the file named (hosts)? Or a way to bypass the security setting for this one file (es file explorer)? Or a way to get the "es file explorer" from an Android recognized source?
#17 mrsahe007, Aug 23, 2015

Edit - was very tired when I posted this obviously useless link :oops:
#18 Lordvincent 90, Aug 23, 2015 Last edited: Aug 24, 2015
That ES APP Group es explorer file won't download onto my PC (so that I can transfer the file to my ALCATEL A564C). The download halts because it says I haven't accessed the Google Play Store
Error: You haven't accessed the Google Play Store app on your device with this email account
.....even though the PC started at the Google Play Store. That's my problem to start with on my ALCATEL A564C ....the message when accessing the Google Play Store from the phone is "Can't Establish a reliable connection to the server". According to the phone it is connected to the WiFi with a strong signal.
So we are going in circles: phone can't get to google play store to download the es explorer to fix the google access but the es explorer needs the google store play to download......must be a way to get this file on my PC and drop it into the phone using the patch cord?
#19 mrsahe007, Aug 24, 2015
Go to your security settings and allow installation of apps from unknown sources.

Then when you install apps that you've sideloaded, it'll work.

Deleting or renaming the hosts file is like curing a cold by committing suicide.

If your hosts file is corrupted, you fix it, you don't murder it.

A stock, minimum-required hosts file contains the following -

- comments that don't do anything, made by putting a # as the first character in the line

- blank lines are harmless

- the following line is required: localhost

You can only get to the hosts file if your phone or tablet is rooted.

If you tap the file in ES, open as text with the ES Note Editor, menu, edit, you can remove any corruption.

If the hosts file only contains comments, blank lines, and the localhost definition, it's fine, whatever problem is elsewhere. Don't delete the file anyway just to see what happens.

Never remove the hosts file.

If anyone reading this already has, put it back with the minimum configuration shown above. Don't create the file on Windows and transfer it over, it's not a Windows file type. You can create a new hosts file in ES, edit it from there, and add just the localhost definition.
#20 EarlyMon, Aug 24, 2015
"Go to your security settings and allow installation of apps from unknown sources. "

VERY HELPFUL.....found the security setting and modified it as suggested.
Was then able to copy the es explorer file from my PC to the Alcatel download folder thru the patch cord method.
Using the Alcatel file manager I was able to run the downloaded file and the ES app showed up with the other apps.
Finally the es explorer file opened I have to study how to use it & will get back with how that goes.

Thanks for your suggested first step of modifying a security setting...these are the type of simple steps needed for a first time smart phone user.....I'm relieved to see progress.
#21 mrsahe007, Aug 24, 2015
Ah excellent. :)

You'll have to dig into the ES settings for root access and setting /system to read-write so you can modify the file.

It's at /etc/hosts or /system/etc/hosts - if you see both, it's just one file with a shortcut.

Turn off read-write on /system and root access in ES when done for your protection. There's no need to leave dangerous permissions on.

You can also turn off allowing apps from unknown sources for your protection - and only enable it when you actually need it. Again - many consider that a dangerous permission. You don't want some malware installing things that you don't know about.
#22 EarlyMon, Aug 24, 2015
I am thrilled you are giving all this support!!

system/etc/hosts is a file with just: localhost
(I am using ES Note Editor to see it)

/etc/hosts has the same file text readout

Don't know how I found this one to a location where it had an on/off for root explorer.
It was off and when I tried to turn it on the message read "no can do for this device"
I'll keep looking for where that was ..........

Meanwhile looking for any kind of setting that points to root access and/or setting system.....

Note: my WiFi IP address differs by a lot from the
#23 mrsahe007, Aug 24, 2015 Last edited: Aug 24, 2015
And it should.

The localhost definition is the ip address for internal software processes to connect to one another and not try going to the outside world. 127.anything isn't even allowed in the outside world.

Unless you know what you're doing with networking it's the only entry that goes in that file.

Yours is fine, leave it be.

When you request a network site - say, - the browser sends a request to the Android services to translate that into the matching ip address.

First, it looks in the /etc/hosts file (that's a shortcut to the actual file at /system/etc/hosts).

When it doesn't find it, it looks through the gateway (your router on wifi or a node assigned by your carrier) for the assigned DNS (domain name system) server and gets the required ip address.

Your phone's network ip address is not going to show up in any of the tables used to resolve names - your phone already knows its own address, and you're not hosting network services from your phone so no one else needs to look it up.

If you don't have root access in ES, you don't need it and don't need to keep looking.

Whatever problem you're having isn't in the hosts file.

What problem are you having?
#24 EarlyMon, Aug 24, 2015
Thank you for that high level explanation ......I didn't have those basics and needed them.

"Whatever problem you're having isn't in the hosts file. What problem are you having?"

Alcatel A564C works fine as strictly a functional telephone.

Go to any app that requires use of the internet and the following message occurs: "Couldn't Sign In...Can't Establish A Reliable Connection To The Server....This Could Be A Temporary Problem Or Your Android Device May Not Be Provisioned For Data Services.....If It Continues Call Customer Care."

Google & Gmail are included in the list of Apps that get the unreliable connection to server message.

Telephone displays excellent WiFi signal strength and shows it's connected to my WiFi.
The tracfone plan shows 3.7G of available data(shown on my PC).

My wife's IPhone with Verizon plan works fine with the WiFi for all the apps tried so far.

So based on your explanation the Alcatel "dead end street" lies somewhere between the host file and Wifi connection?

ps: a lot of files have Asian does this side of the world cope with knowing what's going on in those files?

pss: how to get the phone to acknowledge it knows there is 3.7G of data services available?**
** If I go to the with my PC and ask for a balance the Alcatel A564C rings with a message and the balance is shown on the phone......does that mean the phone knows it??
#25 mrsahe007, Aug 25, 2015 Last edited: Aug 25, 2015