Home Forum

Support Can't Apply Update from ADB

Hello guys!

My device is a ZTE Cymbal T (released Nov. 2016), which runs Android 5.1.1 Lollipop (unrooted).

Problem:
I cannot sideload .zip packages via adb sideload mode in my stock Android recovery. Its forum entry is here.

I am trying to sideload SuperSU to my phone. When I enter adb sideload mode, the device is recognizable from adb devices as "12b34 sideload." However, when I try to sideload a .zip, I get an error:closed message, even though the device is clearly there.

I've renamed the .zip to update.zip, flash.zip, all to no avail. My device is very new, and does not have a TWRP port. I have the "Enable OEM Unlock" option in Developer Settings as enabled.

Should I call my carrier (TracFone) or ZTE?
 

Related:

#1 Haruo, Jan 3, 2017
@Haruo, even if you get the sideload syntax / connectivity correct, you'll never be able to flash Chainfire's SuperSU .zip file from a stock recovery.

This is because it is not signed by ZTE and the signature checks would fail.

A stock recovery will ONLY flash/install a .zip file that was signed with the keys from the manufacturer.
 
#2 scary alien, Jan 3, 2017
That makes a lot of sense... Is there any way I could fool the recovery into making it flash, or sign the .zip somehow - I dunno... ZTE hasn't published any update packages for this device, and I doubt they ever will...

It doesn't seem that I even "have" a bootloader menu - I've tried rebooting into it by using adb, but it just does a regular reboot.
 
#3 Haruo, Jan 3, 2017
Yeah, I've heard about the locked bootloader and missing fastboot connectivity on the ZTE ZMAX Pro (big thread I've been following), so your's isn't the only device like that :(.

Without an unlocked bootloader, there's not much chance of fooling the recovery to flash anything other than official .zip packages, I'm afraid...
 
#4 scary alien, Jan 3, 2017
Bah, humbug... Time for that waiting game again lol.

I have to wait for another murky software or kernel bug to arise so I can exploit it and root my phone. I've tried every method/app in the world without success.

Heck, I even tried using the dirtyc0w exploit to gain a root shell, but not even that worked xDD. ZTE is playing hard... Thank you!

Oh, and thanks also for the ZTE ZMAX Pro reference... I'll be keeping up with that thread.
 
#5 Haruo, Jan 3, 2017