Home Forum

Can't send or receive MMS messages

I have an unlocked ATT HTC One M8 for Metro and I'm noticing that I can't send nor receive MMS messages even with 4g lte on. I tried using Metro and T-Mobile's MMSC on the APN but neither worked. Is there something wrong/missing from my APN?

Name: metropcs
APN: fast.t-mobile.com
Proxy: not set
Port: not set
Username: not set
Password: not set
Server: not set
MMSC: http://mms/msg/eng.t-mobile.com/mms/wapenc
MMS proxy: not set
MMS port: not set
MMS protocol: WAP 2.0
MCC: 310
MNC: 260
Authentication type: not set
APN type: default,supl,mms
Bearer: unspecified

 

Related:

#1 zarar, Jan 24, 2015
Under MMSC: Try this

h**p://mms.msg.eng.t-mobile.com/mms/wapenc
 
#2 BRIAN5337, Jan 24, 2015 Last edited: Jan 24, 2015
Tried it but still doesn't work. :(
 
#3 zarar, Jan 24, 2015
This is what my settings are (and it works for me):

Name: MetroPCS LTE
APN: fast.metropcs.com
Proxy: not set
Port: not set
Username: not set
Password: not set
Server: not set
MMSC: http://metropcs.mmsmvno.com/mms/wapenc
MMS proxy: not set
MMS port: not set
MCC: 310
MNC: 260
Authentication type: not set
APN type: default,mms,supl
APN protocol: IPv4
APN roaming protocol: IPv4
Bearer: unspecified
MVNO type: None

Hope this works out for you!
 
#4 puyow18, Jan 25, 2015
Doesn't work still. I tried switching APN and MMSC settings. Tried sending/receiving MMS from both built in messenger and Go Sms Pro too. Is there another setting that might be the problem?
 
#5 zarar, Jan 25, 2015
Try changing the MMSC setting to "not set".
Also,have you tried other messaging apps?
 
#6 KOLIO, Jan 25, 2015
Changing it to "not set" won't work either.

Are there any other messaging apps that you can use your original # with?
 
#7 zarar, Jan 25, 2015
Sorry to hear none of this stuff is working for you; I know it's frustrating. I did some searching and it seems you are not alone; people seem to have issues with the One M8 being unlocked from AT&T and trying to send mms on Tmobile and other carriers. Read this thread. One person offers a possible solution (fourth reply in the thread), but it involves flashing an HTC update for Tmobile which may or may not help you out for Metropcs issues.

Other advice I've read include clearing all APNs besides the Metro one, doing a factory reset, deleting all text messages before doing these steps, etc.

Another idea (if possible) is to try and put your Metro SIM into another unlocked/Metro phone to see if you can get the mms working there. That would tell you if it's a network issue or the phone. Plus if you got the other phone working you could maybe copy those APN settings over to your One.

Last option would be to bring it in to a CORPORATE Metro store and explain your situation, hoping that they've encountered this problem with this phone before and know of a fix.
 
#9 puyow18, Jan 25, 2015
Have you tried Google Hangouts?
 
#10 confed, Jan 25, 2015
Textra didn't work and Hangouts creates a blank screen right after I try to text a photo for some reason. Don't have another phone that fits my SIM card.

Looks like I'll have to use another text app to send MMS. Are there any recommended MMS text apps that won't need my APN to send MMS and others can send me MMS hassle free?

Thanks for all the help everyone!
 
#11 zarar, Jan 26, 2015
Textra is the one I know that meets your criteria; sucks it doesn't work for you.

Maybe try to delete the apn file altogether as perhaps one of the old at&t apns are muddying the water. Make a backup of the apn file first (found here: /system/etc/apns-conf.XML), then reboot the phone. After that, go into your system settings and manually create a new apn with the correct Metro settings.

Not sure if this would/should/could work, but it might be worth a shot. If it doesn't work just restore the apn backup you made.
 
#12 puyow18, Jan 28, 2015
I have an Unlocked HTC Desire 610 from AT&T that i use on MetroPCS (with T-mobile network APN) and it stopped sending/receiving MMS messages. I fixed it and here's how I did it in my APN Settings:
Name: MetroPCS
APN: fast.t-mobile.com
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not Set
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS Proxy: Not set
MMS Port: 80
MMS Protocall: WAP 2.0
MCC: 310
MNC: 260
Authentication Type: Not set
APN Type: default,mms,supl,hipri
Bearer: Unspecified

The only thing i had changed was adding the MMSC of http://mms.msg.eng.t-mobile.com/mms/wapenc and my APN Type was originally set to default,supl,hipri . Adding the mms to the APN type was what fixed it for me. Hope I can help any future inquiries of this question with this post.
 
#13 FishingforBears, Apr 11, 2015
Nicely done, thanks! :)
 
#14 EarlyMon, Apr 11, 2015
Doesn't work for me. :(

Would rooting possibly help me with this problem?
 
#15 zarar, Apr 29, 2015
I don't think so. I could be wrong but I think it's all about your apn
settings
 
#16 FishingforBears, Apr 29, 2015
I created a new APN and copied everything you had posted, but can't send or receive. Maybe it's because we have different phones?
 
#17 zarar, Apr 29, 2015
I did a lot of research and experimented with a few different settings before I found settings that worked for me. APN settings are carrier specific. just remember that Google is your friend. I wish I could help more.
 
#18 FishingforBears, Apr 29, 2015
Thanks for the help anyways! :)
 
#19 zarar, Apr 29, 2015
What about the default messenger?
 
#20 Jeyd02, Apr 29, 2015
You mean the messenger app that's pre installed? Using that doesn't send mms either.
 
#21 zarar, Apr 30, 2015
Thank you,It worked for me.
 
#22 twinkie41, May 12, 2015
What do you do when there is a lock on the apn? It won't let me select the second apn or the alternate that I created.
 
#23 Reek, Dec 7, 2015
What about the apn settings necessary for simple mobile on an HTC desire 610...I've tried everything...
 
#24 LOZxp, Feb 24, 2016
@LOZxp If you set the settings to what I have above then all should work for you.
 
#25 FishingforBears, Feb 24, 2016