HTC Desire Forum

Support "car mode enabled"

Incredibly annoying "car mode enabled" icon keeps flashing up in the top left hand corner of.my screen. It sometimes causes apps to restart. I want rid of this - forever!

Can anyone help? I have froyo running on my HTC.
 

Related:

#1 paulbpmurphy, Aug 29, 2010
I have just started experiencing the exact same issue. Updated to froyo last week. Also when I receive a call it defaults to loud speaker and. can't seem to change it anywhere. Tried several reboots.
 
#2 ddk8, Aug 29, 2010
Managed to hopefully find a solution on another forum. Car mode can be configured as follows: Go to +> shortcuts>Settings>Car Dock and you should see the options, including Auto Launch. I disabled the auto detect and so far so good.
 
#3 ddk8, Aug 30, 2010
I couldn't find that option in mine. Its gone in for repair to HTC and the initial diagnosis is that it needs updating to the latest software. As it was "Froyoed" only a couple of weeks back I wonder what the latest software is.
 
#4 mlines, Sep 1, 2010
My Desire is having the same problem. Can't find anything anywhere that tells me how to get rid of this problem. Can't find Car Mode anywhere (apart from the icon that appeared once, that I switched off, and never been seen since) so I can't deselect it. Phone goes to loudspeaker for every call I receive or make. Tried the app Car Mode but that doesn't help. Anyone found anything yet?
 
#5 rickydoodah, Sep 2, 2010
I've spotted that if I answer the phone when connected via cable to my car radio loudspeaker, all future calls (without the cable connection) go to loudspeaker. When I next connected via bluetooth headset and answered a call, it corrected itself. Not entirely sure why it does this, but there may be a clue here.
 
#6 rickydoodah, Sep 7, 2010
This worked for me. Thanks!
 
#7 tilusnet, Mar 1, 2011
Thought I would join and let you know I tried the solution to get rid of car mode but then my loudspeaker kept coming on so I looked for what had changed lately on my phone memory.using app manager I removed The android market update and also used astro file manager to remove a file hidden in the memory (think in downloads) called android.com after I deleted them the loudspeaker problem and my screen randomly lighting up problem both went away.I found out this was the problem when I noticed that advanced task killer was saying android.com was running but I never downloaded it, only a update from android market.hope this works for you too.
 
#8 phantom848, Apr 4, 2011
Update.
Just chatting to a fella in work here an his is doing the same.
So used the car setting to turn of car mode but his loudspeaker was playing up.
So deleted his market update.....
Used astro file manager to open memory.
Select SDCARD..
Then select android
then select data
Now clear everything out of the three folders
One is called com.android ............ an the other two
Are called com.Google......
These are like a download memory cache files.
Now go back to SDCARD menu
And open the file called download.
In there there was a new file that had appeared
But it wasn't pdf,lpeg etc
It was an unknown format ,deleted that.
That was it, loudspeaker back to normal
And no car mode.so that's twice its worked now
 
#9 phantom848, Apr 4, 2011
+1
 
#10 Mattias, Apr 24, 2011
where is the plus on your phone?
 
#11 benarch, Jul 26, 2011
+ sign is in bottom right hand corner of your screen. Immediately to the side of where it say "phone"
 
#12 he who dares, Jul 26, 2011
Hey,

I've recently had the same problem, phone flips into "Car Mode" randomly and often - causing it to light up and go into "hands free" mode. Drives me crazy! As my phone is only a few months old I sent it in to HTC under warranty. My first problem was, as a Canadian they told me they don't do repairs from Canada and pushed the buck to my service provider - Bell Canada - who in turn pushed the buck back to HTC.

I finally got the phone back after a month with a short note - "phone is water damaged and will not be repaired." So since I haven't damaged the phone with any liquid, whether spilling on or immersion into, you can image how angry I am :mad:!!

Looks like this might work so I will give it a try tonight. Thanks!

longer
 
#13 longer, Sep 23, 2011
Hi i saw someone else put how to get rid of the random car mode that keeps popping up and crashing apps, and i'm just going to explain it a bit better as i think this option is prob on most android phones but its just a case of finding it. I am using a Desire, by the way, and this is how i got rid of it...

Hold anywhere on screen to bring up options
Select 'shortcuts'
Select 'settings'
Select 'car dock' (this will put the car dock icon on desktop)
Select the car dock icon
Turn off auto-launch
Sorted!!

Hope that helps as this was doing my fkin head in too.
 
#14 tinyessence, Oct 17, 2011
I had this exact thing, it was driving me mad and wearing my battery down really quickly. After nothing seemed to work I removed the sd card and it hasn't happened since. Now I will delete everything on there which is annoying but not as annoying as a factory reset would have been.
 
#15 superfran, Nov 6, 2011
I have same problem.
after along time, i find this way to solve this probliem.
When I change battery with charger . it turn on car mode.
just unplugin cable when app showing, it will off this mode. it ok. no auto light my screen, no auto turn on speaker.

It ok for my Desire HD fone
:)
 
#16 nguyenhuutinh, Dec 3, 2011
Solved for me!

I dropped my phone into the toilet. When I had dried it out it had the car mode flashing on and off: it kept starting the screen up and the speaker would come on in mid call.

I saw a reply on another forum which said that it might be water in the USB port. Drying the port out with Isopropyl alcohol sorted it straight away. Another forum user had got a bit of lint in his USB port.

Apparently it makes the phone think it is stuck into a car dock.

HTH
 
#17 Caddi, Apr 18, 2012
Yes, the car dock's microUSB socket pins 4&5 are bridged with a resistance :)

Harry
 
#18 Harry2, Apr 18, 2012
I have an HTC Desire - Clockwork Mod
1) To enable / disable Cardock go to an empty screen where you can add
icons/shortcuts
2) Press the bottom "Menu" key
3) Choose + (Add to Home)
4) Choose "shortcut"
5) Choose "settings"
6) Choose "car dock"
7) Press car dock
8) check or uncheck car dock as you please
Cheers
Marty
 
#19 mrrdaniels, Apr 22, 2013
Hi Marty, and welcome to AF :)

That's a slightly different thing from what the OP was asking, which was to prevent it ever appearing.

A rooted user can achieve that by removing the application completely ;). But as others have said, the cause is probably a short.
 
#20 Hadron, Apr 23, 2013