Home Forum

Chromecast Trouble!

I have had my Chromecast since mid-September. It connected BEAUTIFULLY and easily the first time. It worked until about 3 days ago. For some reason it just stopped working. Nothing has changed. Not my network. Not my internet provider. NOTHING. It just stopped showing the cast button in apps and on my laptop.

Tonight I had the time to try a few things to troubleshoot it. I unplugged it from the HDMI and plugged it back in. I unplugged it from the power source and plugged it back in. I tried a soft reset (which is unplugging it from the tv and power source) and it still didn't work. I tried a reset (holding down the button for 20+ seconds). It will NOT re-connect to my network.

I called Google Support twice. Each time, my silly Droid Maxx disconnected me about mid-help. Both times they had me go through the steps above. They even took me to the manual set-up url. No dice. Nothing. It won't work. Now the tech support person said that my device is not defective because it shows a solid white light.

All I know is it worked, now it doesn't. It connected, now it doesn't. Anyone else had this problem?

I've tried setting it up from my Maxx. As it searches to connect the Chromecast to my home wifi, it shuts off my wifi on my Maxx and my 4G will connect, then my wifi will come back on, then my 4G will come back on, then it will say cannot connect to the network.

I'm at a loss. Looks like I may be at a $35 loss from Google since I'm out of options and my Chromecast does not work. :mad:
 

Related:

#1 Old Member, Oct 2, 2013
After the reset, did you see the onscreen message showing the pairing code (or whatever they call it)?

Have you reset your router, using the router reset button, not just on-off-on sequence?

Try that, and look at your router device list afterwards to see if it's registering on your network.
 
#2 EarlyMon, Oct 3, 2013
Also, if you're plugging it into a sound system that manages your HDMI connections, try plugging it directly into the TV. (if you haven't already). When I had my defective unit it would work more often directly in the TV then in the sound system. However, everytime mine didn't work the light was red, not white.
 
#3 Mr. Link, Oct 3, 2013
I have reset my router. Yes the codes matched. It goes through everything just fine up until it needs to connect to the internet, then it gets stuck.

It is plugged directly into my television.
 
#4 Old Member, Oct 4, 2013
Sounds like your router is no longer passing UPnP.

Maybe check your router settings for that and other settings, listed in the sticky.

It doesn't sound like a bad Chromecast, it sounds exactly like what I had before getting my router right.

I know it worked before and you didn't change anything - but - freaking routers, OK. :p
 
#5 EarlyMon, Oct 4, 2013
Fixed . . . And just as magically as it stopped working it magically started working again. No explanation, nothing different. Just BAM! One day it stopped working and BAM! about 10 days later it began working again.

Do me a favor, and try not to say abracadabra around my television, no telling what might happen next.
 
#6 Old Member, Oct 11, 2013