Samsung Galaxy S3 Forum

General connect my S3 to PC via usb nothing happens

I connected my S3 to my PC via USB. It shows it is charging but the PC does not detect it. nothing happens.

I want to copy my pics off the phone to PC. Is there a setting on the phone I have to set and if so can someone please give me the path to set it..

I think maybe something like "Mass Storage Device" setting but I have looked in settings with no luck.

I just installed the premium suite update. I am on Verizon (SCH-I535)

Thanks

 

Related:

#1 Drunder40, Jun 1, 2013
Im not very good with PCs tbh but i think when you plug the phone in, you can pull down the notification panel and choose a mode. "Mass storage" doesnt exist now but theres some other mode that lets you move files.
Make sure you have s3 drivers installed on the pc btw :thumbup:
 
#2 funkylogik, Jun 1, 2013
Here is a link to the Samsung website to redownload the drivers if you need them:
Support - Verizon Wireless Cell Phones SCH-I535 | Samsung Cell Phones

I know that link is for the Verizon variant, but the drivers are the same. :)

And as funky stated, there is no "USB Mass Storage Mode", only PTP and MTP I believe, accessed, like he said, with the pulldown notification bar when the device is plugged in.

Also be sure you are using the OE cord and not plugged into a USB 3.0 port on the computer. Use the USB 2.0 port.

Perhaps try a different cord.

One more thing as a last resort, save what you need to save off of the sd card such as pix, videos etc, and save contacts to your google account , then factory reset.

If you factory reset, you will lose everything but alot of times a factory reset is recommended after a firmware upgrade to clean the device of any "ghost" data that make the device glitchy.
 
#3 Mikestony, Jun 1, 2013
Appreciate the replies but still no luck. I swapped the USB cord and no change.
Both cords have a black tag taking about vcast (First one) and the second one has a black tag on it that says "backup assistant plus". Both cords charge my phone.

For the notifications pull down, I have no PTP or MTP option on the pull down. What I do have is:

Bluetooth(off), GPS(on), Sound(on), Mobile Data(On), Screen Rotation(on), Airplane mode, Power saving, Driving Mode, Multi-Window(on) and Sync(on).

I followed Mikestony's link and installed the USB drivers (it said they were already installed but I installed them over the initial version anyway.

The reason I wanted to connect to my PC was to save off pics before a factory reset.

Just cant get my PC to recognize my I535 via usb. Kies does not see my phone. I ran the diagnose wizard for USB and still nothing.

There must be a setting in the phone. I can't think of anything else..

Any other suggestions

Thanks again
 
#4 Drunder40, Jun 1, 2013
Try turning the phone off, remove and reinstall your SIM card, and turn phone back on. That fixed mine when I had the same issue.
 
#5 ninja636rider, Jun 1, 2013
Thanks Ninja, that did it.. worked like a charm..

Again, appreciate all the replies folks.. love this forum!!:D
 
#6 Drunder40, Jun 1, 2013
Awesome! Glad to be able to help. :)
 
#7 ninja636rider, Jun 1, 2013
I have a similar problem...with a twist! I have (2) T-Mobile Galaxy S3 phones. One is running OS 4.1.1 and the other is running OS 4.1.2. The 4.1.1 phone connects to my laptop as a "media device" and I am able to move/load files, etc. as expected. The 4.1.2 phone is not recognized by the laptop at all. No icon on the phone, not showing up in Windows 7 (64bit) explorer, not in KIES, nothing. Yet the other phone shows up normally in all of those condition. Same factory USB cable. Installed newest Samsung drivers. Both phones are in "USB debugging" setting.
Since 4.1.1 works, I am assuming the cable and software are fine.
What could be causing the 4.1.2 phone not to hookup with Windows and KIES? I CAN see it in KIES wifi, but I want to root and install a custom rom and I can't do that via wifi. And I have factory reset and wiped the 4.1.2 phone several times to be sure there is no corrupt data.
Any ideas? I sure would appreciate some help. Thanks.
 
#8 Tony1945, Jun 24, 2013
I have tried removing the battery, SIM, turning phone off/on. No change. 4.1.2 is still undetected. Uninstalled KIES and installed Samsung drivers reinstalled KIES several times. Still undetected. And the 4.1.1 phone continues to be detected.
 
#9 Tony1945, Jun 24, 2013
I have the same problem. It used to work fine but now nothing happens. It just charges it and no USB icon appears in the status bar. I have also tried download mode but Odin doesn't even recognise it. I have tried 2 different cables. I think it must be a hardware problem with the phone.
 
#10 vpwrf, Jun 24, 2013
I also cannot get this to work. Tried power cycling as well :(
 
#11 elementalwindx, Aug 8, 2013
Not sure if this will work for you, but when mine did the same I powered down, removed battery and SIM card, then put it back together and it worked like normal.
 
#12 ninja636rider, Aug 8, 2013
Y'all know that the S3 has to be in Camera Mode to connect to the computer via USB don't ya?
 
#13 nailzer, Aug 9, 2013
What do you mean by Camera Mode? I've never had to change anything, just plug in and it works without changing any settings.
 
#14 ninja636rider, Aug 9, 2013
Ninja, the only thing I can say is THANK YOU THANK YOU THANK YOU!!!! Shut down, remove and reinstall SIM card did the trick.
 
#15 tbase27, Feb 22, 2014
Thanks so much! Was having the same issue, I first tried restarting the phone but didn't help. So powered off, removed battery and SIM card, reinstalled all and powered on, USB connection is back. Not sure why exactly that worked or which of the three (power cycle, battery, SIM card) actually did the trick, but I'm very happy it did, so thank you for posting that suggestion!
 
#16 sir_magneto, Aug 21, 2014
wow Many thanks to you ninja!
I've literally tried everything including factory reset, but couldn't get my phone connect to computer...
and this simple task solved problem!!
Thank you so much <3
 
#17 Yuri Stella, Jan 15, 2015
wtf!!! thank you bro!!
 
#18 inteladidas, Mar 23, 2015
None of this is working for me. As of recently... my phone will also only charge with the white Samsung charging cable that it came with.

I have factory reset. I am at 4.3. Someone previously mentioned debugging and I could not for the life of me find that so I Googled it. I found information on how to find the hidden debugging/Developer options here: http://www.techverse.net/enable-usb-debugging-android-4-3-phones-tablets/

My original phone was dropped and had to be replaced. I got a new phone from the insurance but have a feeling it was not BRAND NEW. I don't remember if I have connected the newer phone to my pc since getting it. (side note... paying insurance is pretty much USELESS after 9 months especially if the phone version you get is at the end of the NEW on the market year or older! You pay WAY more than its worth and then still have to pay over $100 for a replacement phone. Expensive lesson learned!)
 
#19 Jaimie, Mar 25, 2015
I had the same problem with my Samsung S3 GT-I9300. After trying all of the above suggestions with no success, I simply disconnected my USB hub and plugged the phone directly into a USB port and Voila! For some reason the phone must have been in conflict with another device plugged into the hub. I just switched a few things around keeping the phone plugged directly into a USB port and everybody is now happy again.
 
#20 loufro, Jul 9, 2015



i have the same prob .. explain to me more plz
 
#21 hqmdouch, Sep 17, 2015
Try to explain how can i repair my phone plz
 
#22 hqmdouch, Sep 18, 2015
I have a Sprint version (sph-l710) and there is no sim card. I have no USB PC Connection icon in the top group. I did at one time as I have connected but a while ago, so I know that it is now missing that icon.
 
#23 bluarcher, Nov 8, 2015
OK; I tried the above SIM card removal suggestion.

ALSO, when the phone beeps upon USB connection, saying it is seeing a charger, I tried the pulldown options, and sure enough there I see the two USB mode options:

Media Device (MTP)
Camera (PTP)

So I selected Camera but WinXP (which by now was saying USB device not recognised) still doesn't see anything.

However I feel I am getting closer because the camera mode ought to be more compatible AND finally I have discovered the means of changing the USB mode. Idiotically, Samsung didn't put it under Settings!

I cannot see what removing and reinserting the SIM card while the phone is OFF can do. The phone is not talking to the card when OFF!
 
#24 peterh337, Nov 9, 2015
Your PC should have installed the drivers the first time you plugged in. Find device drivers and delete all Samsung and Android drivers. Then plug your phone in, in mtp mode. Let it install drivers.
 
#25 Madbat, Nov 13, 2015