Home Forum

Contacts in Phone only in stock Android

Hello everybody.
I searched in the forums and I didn't find a solution.
I would like to buy a phone with stock Android (any Nexus or the Xiaomi Mi A1) but I want to use a phone contacts. I don't want to see nor synchronized the contacts with any Gmail, Outlook or whatever application.
In stock Android (or at least, the Google Play Edition of my HTC One M8) you can't find a Show only telephone contacts or something like that. The other day I tried the Xiaomi Mi A1 and I wasn't able to find a Telephone contacts only.
Somebody has a solution. Is there a 3rd party application that can do this?
Regards.
Maligno.
 

Related:

#1 Maligno, Nov 30, 2017
I synchronise my phone with my desktop PC. I have all my contacts/calendar stored in Outlook 2010 on my desktop (that's the PC client Outlook - part of Microsoft Office - NOT the online web portal) and sync them directly with my phone, over wifi (though I could use Bluetooth or usb also), using MyPhoneExplorer (... https://play.google.com/store/apps/details?id=com.fjsoft.myphoneexplorer.client&hl=en_GB ... on the Play Store for your phone + ... http://www.fjsoft.at/en/ ... for the PC client). On the phone I actually use the google contacts/calendar storage BUT I turn off google sync with their cloud before I sync for the first time (you could also set up a local only account for this).


Works for me.
 
#2 dvhttn, Dec 2, 2017
Did you try looking in contacts settings under 'contacts to display'? I would be surprised if such a setting doesn't exist.

Otherwise you can just simply not sync your contacts, as suggested above by @dvhttn
 
#3 A bochur, Dec 2, 2017
The question becomes how are you going to get your contacts on your phone? If you already have your contacts saved as a csv file you can import them to your phone as phone contacts. You should also co to settings>accounts and turn of all contact sync for any listed accounts.
 
#4 lunatic59, Dec 2, 2017
Hello everybody.

First of all, thanks for your help.

@dvhttn I synchronize the my contacts through MyPhoneExplorer (excellent app).

@A bochur I use 'Search to display'. Look at the images. The first one is a HTC One (M8). It's in Spanish language but that doesn't matter.

[​IMG]

In this image I can select which contacts I want to show. I have two gmail accounts, a Telegram account, the telephone account, and the SIM. As you can see, the only one marked is the telephone account that is the only one I choose to synchronize with MyPhoneExplorer @dvhttn .

This second image is from a Nexus 5 with PureNexus (suppposedly almost stock Android). Here you can see there is no telephone account. You can only use a Telegram, WhatsApp or Google account.
[​IMG]

This is what trying to solve. In a telephone that has no telephone contacts available.

@lunatic59 The contacts can be introduced by me or synchronized with my Outlook contacts throught MyPhoneExplorer.

Cheers.
 
#5 Maligno, Dec 3, 2017 Last edited: Dec 3, 2017
I think your problem is that on Google devices Google have removed the option of local contacts. My Pixel contacts app also does not have that option.

So, what are the workarounds? It's conceivable that there's a third-party contacts app that would provide this option (e.g. create its own "account" contacts could be stored to but which isn't synced). I can't tell you whether such an app exists though. An alternative would be to just disable syncing of contacts (you can turn contact syncing off separately from other Google syncs). Or if you need some contacts synced and some not then create a second account for the unsynced ones and turn off sync for that before adding any contacts.

As for deleting a message, use the report button (in "tools") and ask one of the moderators to do it.
 
#6 Hadron, Dec 3, 2017
I see what your problem is now. Try the app 'MyLocalAccount' from the same developer from the Play Store at .... https://play.google.com/store/apps/details?id=com.fjsoft.mylocalaccount ...... This has worked for me on previous phones but I have not used a 'Google' phone so don't know if they have 'locked it down' somehow.
 
#7 dvhttn, Dec 4, 2017
@dvhttn You're right. I tried it and it works. :D
[​IMG]
 
#8 Maligno, Dec 8, 2017 at 5:47 AM Last edited: Dec 8, 2017 at 2:18 PM