Samsung Galaxy Core Prime Forum

Support Custom Binary block by FRP lock

Hi, got the core prime. Was locked to a network so paid to have it unlocked (standard stuff) when we got the phone back we logged into the google account and the pone shut down. When turned back on it said in red writing in the top corner "Custom Binary blocked by FRP Lock then shuts off. We took it to the shop and restored it but once again when we logged back into google the phone shut down again and said the same message. I am stumped what to do next. Just bought the phone and I don't want to have wasted the money :( :( :( Can someone please help me?



#1 DRWJS2015, Dec 8, 2015
is your phone still locked with this?
#2 Gxzn, Dec 9, 2015
Download the files i have attached and link.
1. Open Odin as Administrator and extract ZIP
2. Select the PDA checkbox in Odin
3. Click PDA and find the file you have extracted
4. Put your phone in download mode (VOL Down, Home Button & Power button at the same time till it shows a blue screen)
4. See the options and make sure you continue (Should be volume up)
5. Press start in Odin
#3 Gxzn, Dec 9, 2015
After you do what Gxzn said to do(which I can confirm works), be sure to enable Developer Options in your Settings by going to "About Device", look for "Build Number", and press it seven times. Then, look for "OEM Unlocking". Check the box. This SHOULD disable the FRP lock as well.
#4 JCFinsCanes, Dec 18, 2015
To fix this problem first u have to download SMART SWITCH then install it
Then click emergency software recovery and don't plug your phone to your computer yet then enter your phone model and s/n after it will explains the rest
This work for Samsung grand prime
And I think it should work for other phones
#5 Misorawhitale, Dec 21, 2015
Hi, i have exactly the same problem on my sons new phone. I have got to step 3 but cannot find the file i have extracted..all that was extracted was something saying odin 3 that would only open with a notepad and sort of settings cog on the icon when i click pda i cant find the file i need ..i dont know if it is something to do with my laptop not having the correct programme to open the pda file or not as i am not very good with stuff like this. Very frustrating as i have just bought him the phone for christmas. Any help would be great thank you
#6 geordie1983, Dec 30, 2015
wait does that work for Samsung galaxy grand prime becoz my grand prime says custom binary blocked by frp how do I fix it can u give me links
#7 Aphrodit, Jan 6, 2016
Are you using winrar to extract?
#8 Gxzn, Jan 26, 2016
I have tried the suggestions here, but apparently am doing something wrong. Can Someone please walk me through exact step by step instructions on what I need to do. I downloaded Odin, but not really sure what to do with it now, or what it means to open it as administrator, when do I plug my phone into my computer? I am just totally lost. My son is so upset, he is 10 years old and just got this phone last night and can't use it, please someone... HELP!!!
#9 shaylajb, Jan 29, 2016
Same here, I have problem recently. I downloaded Odin and I downloaded SM-G530T1 and SM-G386T1 for Grand Prime, they both are not working on odin. FRP Lock: On

So I bought it 2 days ago.
#10 Jupiterus, Jan 29, 2016 Last edited: Jan 29, 2016
gonna test and see if this method works i hope it does FRP Lock enabled after i installed Xposed and Busybox and went to restart.....
#11 Lividjava, Jan 29, 2016
Is there any reason why the AFH download is so slow?
#12 Lividjava, Jan 29, 2016
Only for
#13 Gxzn, Jan 30, 2016
It Worked on my MetroPCS G360T but im not using it to call anyone .-. so carrier functions may be broken
#14 Lividjava, Jan 31, 2016
I have tried Gxzn method but is still doesnt work
#15 Nasario75sylvester, Feb 2, 2016
Thank you . it works.
#16 deserve, Feb 7, 2016
Hello Gxzn,

Please tell me if your procedure works on Samsung Galaxy A8 phone.

Many thanks in advance

Best regards,
#17 LePrinceCeleste, Feb 29, 2016
does anyone have it for metro?
#18 creativ3live, Mar 16, 2016
Hi my sons phone is displaying same message, I'm not sure what he downloaded but what can I did to get past this screen, tried everything no luck.
#19 mekeisha2882, Mar 17, 2016
I am trying this on my rooted samsung galaxy core prime, hope it works... will let you know if it does
#20 keith russell, Mar 17, 2016
Thank you I hope it does for you
#21 mekeisha2882, Mar 17, 2016
Use SMARTSWITCH as explained above by Misorawhitale works...

I was having the dame issue in Samsung handset and it is working fine now...........
#22 mstpin, Mar 22, 2016
yes it works, my frp lock is gone. now i have a problem with the google account, i do not know how to sort it me
#23 ranchosa, Mar 29, 2016
Hi, i've the same error on my new samsung galaxy S7. May I use the same solution? Thank you :)
#24 crissem72, Apr 1, 2016
I am also having this same problem, I am not sure if i am doing this correctly. I downloaded Odin and the file and followed the steps and now the phone just says downloading do not turn off but it looks like nothing is happening on the computer
#25 smartphone2143, Apr 5, 2016