Home Forum

Support Disable Lock Screen

OK, I was playing around and set up the lock screen on my TP. While this could potentially be a nice feature, I decided it was more cumbersome than helpful.

Despite going through the security menu and seeing the settings for disabling the lock screen, which are grayed out, I simply can't find a way to disable it.

Am I just missing something?

Dan
 

Related:

#1 lwb250, Mar 26, 2012
Can you change screen lock to none? The top option?
 
#2 Atma, Mar 26, 2012
It's greyed out for some reason.

Dan
 
#3 lwb250, Mar 26, 2012
What build are you using and was it greyed out on previous builds? Running any ROM's that may cause that?
 
#4 Atma, Mar 26, 2012
CM9 tenderloin nightly 03262012. Other than that, nothing else I can think of that would affect it.

Any other suggestions? I'm all ears...

Thanks!

Dan
 
#5 lwb250, Mar 26, 2012
As I look at this with a little more clarity, I think I may have some information that could give some direction on how I might be able to sort this out:

In the area next to "None" in the Settings Lock Screen menu, it says, "Disabled by administrator, encryption policy, or credential storage."

I am running the following applications that I suspect may be the culprit:

System Tuner
Super user

I have gone through both looking for a setting or other information that might reveal what has disabled this setting, but nothing jumps out at me.

Again, any suggestions?

I did restore from a backup made prior to invoking this setting, along with wiping the Dalvik cache. No joy. I am wondering if I should do a complete restore to factory defaults and then restore my backup.

Dan
 
#6 lwb250, Mar 27, 2012
I'm at work right now so I can't look at my TP, but check settings > Location and Security > Device Administration > Select device administrators.

See if a program has admin rights and if so uncheck it.

I'm looking at this in my GB phone so it may be a little different in CM9.
 
#7 Atma, Mar 27, 2012
I looked at that previously and it is greyed out and shows no device administrators. When I saw this I attempted to add one but it wouldn't allow me to.

I would add that I am a net admin with a working knowledge of permissions and rights relative to a Windows environment, so this is not unfamiliar territory for me. I'm just not familiar with Android....

Thanks!

Dan
 
#8 lwb250, Mar 27, 2012
Figured it out.

I went into "Profiles" and looked at the settings. In the profile settings at the bottom is an entry for "System settings -Lock screen mode". You can choose several settings, one of which is disable.

Once I applied it, no more lock screen!

Again, thank to those who made suggestions!

Dan
 
#9 lwb250, Mar 27, 2012
You're way ahead of me then. :D

Glad you got it fixed.
 
#10 Atma, Mar 27, 2012
I was just getting ready to power mine up.... :D
 
#11 colchiro, Mar 27, 2012
Where is the "Profile" setting? I cant found mine.. My ROM was default 2.3.4..
 
#12 kolonelpeteruk, May 30, 2012
Everything is in settings. Look for security and lock screen. (sorry, from memory).
 
#13 colchiro, May 30, 2012
Message originally posted
 
#14 admit, Jun 3, 2012
Hi Dan,

I'm stuck with exactly the same problem. Where is this "Profiles" that you've used to solve it? I've looked for it on my phone but I can't find it.

Thx
 
#15 Nagareboshi, Jul 5, 2012
I was able to clear it by going to "Security" then "clear credentials".
 
#16 bbarend, Jul 5, 2012
Thanks, this did help :)
 
#17 Nagareboshi, Jul 5, 2012
I had this exact problem, which turned out to be the result of a VPN profile I had set up (though I was never actively using it). Deleting all VPN profiles made all the screen lock choices visible again.
 
#18 CharlesR24, Aug 29, 2012
Dear Charles,
I deleted all VPN profiles. This is a very useful for me.
Thanks.. Thanks.. Thanks
 
#19 endroad, Aug 30, 2012
A lot of business email wifi accounts will do this, too. Anything that has an encryption certificate that permanently resides in your phone will cause the problem.

You can delete the VPN accounts or email accounts, but that only works if you don't need the VPN or email account. If you need those things, you have to fix it some other way.

If you are rooted, I found this tutorial to bypass it:
[TUT][ICS] bypass Credential Storage phone lock / install certificates
 
#20 binary visions, Sep 3, 2012
Good to know!
 
#21 Jeffery, Sep 3, 2012
Thank you so much. Yesterday I wanted to remove the pattern lock to swipe on my Galaxy S2. But the first three options (none,swipe & facelock) were greyed. (saying its disabled by device administrator.) Never happend that before.

Luckily i found your post. Deleted the vpn profiles I'd created a few days ago. And voila!... All the options are available now.

Thank you so much. :)

regards,
buntoo
 
#22 buntoo, Oct 4, 2012
I had this all buggered up with a m.google.com exchange set up with the the sammy email app checking my google apps email account. Fortunately, I am the google apps admin for my company so I could change the settings in google apps.

But, then after much trouble playing with screenlock setting, I discovered that I must decrypt the SD card to release the credentials...
So, if all else fails check the SD card and see if its encrypted. Worked for me.
 
#23 vankaye, Oct 31, 2012
I've said it before and I'll say it again.... I've never seen android encryption mentioned without someone being unhappy. :D
 
#24 colchiro, Oct 31, 2012
I've said this before and I'll say it again, make a freakin' backup and when things go wrong, just restore the backup and all is well again.:D

It should be a no brainer.:thinking:
 
#25 Nevertells, Nov 1, 2012