Samsung Galaxy S3 Forum

Support Disable Nearby Devices showing up?

Anybody know how to achieve this?

Since i have so many shared folders on my router and pcs sharing folders, when I open up gallery the thumbnails take forever to show up, if they do at all.

Anybody know how to stop them from showing up?
 

Related:

#1 gabquintero09, Jul 8, 2012
If you go into Settings, and then to Motion, is "Shake to update" enabled? If so, turn it off.
 
#2 jerofld, Jul 8, 2012
I think I may have express myself incorrectly..

What I am trying to achieve is this folders below to show up..

[​IMG]

See, how the folders shared on other pcs on my network are showed in my gallery?

One of the laptops has about 800 pictures, so when the phone opens up gallery since it is reading all the pictures in that particular folder, it will not load up thumbnails for my local folders..

Is there a way to disable them showing up?

So far I had to go to each computer and block the phone from accessing the computer, but that's a hastle..
 
#3 gabquintero09, Jul 8, 2012
Gab, I have no idea but I can suggest something for you to try:

Go to your PC and create an empty text file in Notepad. Nothing. Just an empty file and name it

.nomedia

Copy and paste that into each of the offending folders on the PC. If my theory is correct, the phone will scan the folder, see that file and skip it, thinking there is nothing there for it to display. If it's not correct, well... it was worth a try.

I don't THINK the file will affect your ability to see the pictures locally on the PC, as this is an Android thing as far as I know. If it does, simply delete those .nomedia files.

Try and and let us know what happens.
 
#4 The_Chief, Jul 8, 2012
Dunno if others have helped or if i understand your question but I'll try. Try going into Settings > More settings > Nearby Devices and see if File Sharing (the first option) and in the off position. If it's not, turn it off and see if that helps.

Edit: There's also a Wi-Fi Direct slider under the more setting tab that seems like turning it off that, I assume, connects to anything else on the same Wi-Fi.
 
#5 91Firebirder, Jul 9, 2012
The_Chief

Thanks for the suggestion, tried it but the folder still shows up. Thanks for the suggestion, I really appreciate it. I think that even if there is nothing to show the folders still appear, which is really annoying :|

91Firebirder

Dammit, the option is off and I even unchecked pictures, but the empty folders still appear!!

Haha, this is so frustrating, I even went on live chat with Samsung, they told me that at this moment they didn't know of a way to make those folders not appear.

Thanks guys, it's always better to log on to some advice, than to an empty thread :)
 
#6 gabquintero09, Jul 9, 2012
Oh well... it's not the first theory of mine that went down in flames :rolleyes:

Worth a try anyway, now we know what DOESN'T work...
 
#7 The_Chief, Jul 9, 2012
If you freeze the 'Nearby Devices' service in Titanium Backup that should prevent your phone finding folders on your computer or any other computer, you need to be rooted though.

Not sure if you can disable it through the normal application menu in the phone itself but it's worth a try.
 
#8 giftedgiggsy11, Jul 9, 2012
I'm guessing that rooting a phone would void warranty with the retailer?

I don't think rooting my phone would be something I'd wana do, or not sure I haven't really gotten into reading the whole pros and cons of it.
 
#9 gabquintero09, Jul 9, 2012
I wish there was a way to turn that off as well. I found this forum looking for a solution. My gallery always shows one of our computers and there's nothing in the folder.
Hopefully they add a way to remove them soon. It's annoying
 
#10 Ulatek, Jul 19, 2012
Fixed!

You have to disable media sharing in Windows.

From Control Panel, go to:
--> Network and Sharing Settings
--> Advanced sharing settings
--> Scroll down to Media Streaming.

It might say Media Sharing is on, even though if you click the link, it asks you to turn it on first. Essentially, you have to turn it on to enable it, and then block everything from sharing and seeing your device. That turns it off by default. Yes, it's weird, but hey, it's Windows.

It worked for me!
 
#11 gandalf19, Jul 19, 2012
That doesn't work if you don't have access to the computer that is showing up.
 
#12 speedfan, Jul 19, 2012
Right. So in the case where you're on a public network and seeing other people's computers, you're SOL. It comes from the computer, not the phone. Most people are unaware of the setting I described above, including me before I did some hardcore Googling. But, when you're home, it solves it there at least.
 
#13 gandalf19, Jul 19, 2012
This is the most useless feature. I don't get why Samsung would not have created a way to turn this off. What if you want one device to be able to access it, but not other devices. I don't want to have to go into the PC and change settings everytime I buy a new device. They should have made this an option on the phone.

My previous android phones did not have this feature so it's not all from the computer. It is the phone.
 
#14 speedfan, Jul 19, 2012
very frustrating, most of the year i'm living at university campus halls of res... with hundreds of students all running laptops and other devices, its hell when i open the gallery app, at least 10 folders at a time...

everyone seems to be complaining about their desktops/laptops being discoverable by the S3... others dammmit!
 
#16 cductv, Sep 12, 2012