Galaxy Nexus Forum

Support Disabling Google Voice Search

This feature has been driving me nuts.

Everytime the phone receives some sort of impact, from a slight shake to a 1ft+ drop, the google voice search activates, each time interrupting whatever it is that I'm doing. I can be biking with the phone in my pocket whilst listening to music, and the voice search will trigger from the vibrations. I stood at a bus station last week and 5 18-wheelers rolled on by and apparently the sound of the engines alone made it impossible for me to use my phone for an entire minute as everytime I would press back, voice search would be triggered again.

I have tried disabling google search, I have tried scrolling at the bottom of the apps list and disabling voice search, I have tried unchecking google voice typing, I have tried disabling hotword detection. I factory reset my phone this morning hoping it would solve the problem, to no avail.

I have an otterbox case if that matters.

How do I get rid of this?
 

Related:

#1 BentoBox, Nov 5, 2012
I've never ever ever had google voice search open up accidentally. Unless I swipe up to start google now, or press the shortcut for search it just doesn't happen.
Have you tried it without the case. Aside from that it could be a physical defect where the screen is registering touches that don't exist.
 
#2 Tim K, Nov 5, 2012
I am also having same issue. When I connect the headphones with mic voice search starts automatically. We are not living in a perfect world where there won't be any sounds. How can I disable or change the setting so that it starts only when I wanted. This happens only when I connect the headphones with mic otherwise working perfectly.
 
#3 thsrik, Mar 26, 2013

does it do it with different headsets? I haven't had mine do that.

that said in settings for google voice is a setting that says. "hotword detection" you can try turning that off..
 
#4 Crashumbc, Mar 28, 2013
I dont get either of these problems.....OP, i would also suggest not using the case and seeing if that does anything. not sure why it would, but worth a shot. actaully sounds like a defect of some sort.

as for the headphone trigger, i use the stock headphones that came with my nexus and i dont have that issue. i haven't tried any other heaphones, but those dont give me any issues.
 
#5 Turdbogls, Mar 28, 2013
Hello!
I have a similar issue. I want to use multilanguage voice search, so I installed google keyboard that supports it, but several apps have mic icon without option to select a language to speak, so I would like to disable it from appearing on the screen. Anyway to do it? I use android 4.2.2
 
#6 nkaretnikov, Feb 12, 2014
I have exactly this problem and it randomly started today. I plugged it in to the aux cord in my car. The shake required to trigger the voice search seems much more sensitive than normal, as if it were less a setting than a bug.
 
#7 Xx_Swaglord_xX, May 28, 2016