HTC Droid Incredible Forum

Root Error 155 using HTC Rom Utility

First time trying to Root since the last blue tooth upgrade killed my contacts in my 06 750 i. All went well last night, unlocking boot loader but now I'm stuck on the RUU step.

I'm stuck on this step and have tried all the options in the troublshooting doc., disabled lock screen, shut off anti virus, ect. but when I try to root my adr6300 from current 4.08.605.15 to 4.08.605.2 which is the RUU from HTC I get the error 155.

I believe I have the wrong RUU but I'm not sure which one to look for? Any suggestions?



#1 fratan, Aug 4, 2012
What RUU are you using? Are you following the tutorial from this site?

You will need to get s-off before attempting to run an older RUU.
#2 sdrawkcab25, Aug 4, 2012
Yeah, I'm stuck on this step. Went to the HTCdev website and downloaded the RUU open as administrator, ect. and as it started writing it completed half way through and then I got the error 155 leaving me to believe that I have the wrong RUU.
I also tried unrevoked 3 but couldn't root with that program either. I was able to unlock the phone so the next step is to flah the RUU.

2)unlock using htcdev
-go to HTCdev - Unlock Bootloader and sign in to your account. chose "htc droid incredible" from the "select your device bar" and click the green "begin unlock bootloader" button underneath. note the "*" wich means you will need to update your hboot in order to unlock.
-click yes to procede,then read the warnings before checking the boxes and clicking yes to continue,as they are basically explaining that your warranty is now void,and any repairs that your phone needs that may have been a result of unlocking your bootloader and messing with your phones operating system may no longer be covered under mfgr warranty
-download the RUU for the new hboot. right click it,and run as administrator. plug in your phone when prompted to. it will ugrade your .92 hboot to the htcdev unlock 1.02.0000 hboot.
-steps 1-4 are describing how to get your phone into bootloader mode and connect it to your PC,wich we have done above. ignore these steps and simply type in your cmd window:
#3 fratan, Aug 4, 2012
As long as you chose the htc incredible on the htc dev site, you have the correct RUU.

You can try this though:

You may want to try from another computer also.
#4 sdrawkcab25, Aug 4, 2012
I downloaded that pb3120000_Incredible_C_hboot_1.02.0000_4.08.605.2.exe and the error is thrown updating signatures.
I was thinking of removing HTC sync from my computer and trying the unrevoked 3 method but maybe someone knows the issue with the error 155.
#5 fratan, Aug 4, 2012
One of these error messages will appear when you use the incorrect RUU to update and the image file size is larger than the Flash ROM size. In this case, download the correct RUU version and try again.
#6 fratan, Aug 4, 2012

The unrevoked method won't work with your current software/firmware. htc dev unlock is your only possible method.

I'd try with another computer if possible.

Out of curiosity what does your hboot screen say?
#7 sdrawkcab25, Aug 4, 2012
incred. xd ship s-on
touch panel-atmelc03-16ac
apr 24, 2012 22:58:40
update fail?

The flash fails at updating signatures then error 155
#8 fratan, Aug 4, 2012
Oh okay, you don't need to flash the RUU then, you already have the unlockable bootloader.

You can just install clockwork recovery and superuser.

Skip to step 2 here:
#9 sdrawkcab25, Aug 4, 2012
I was close to coming to that conclusion, had to have my 9 year old read the hboot and when I read s-on I saw a thread about getting it to off.
Thanks for saving me a few hours of reading.
#10 fratan, Aug 4, 2012
Thanks sdrawkab25, I have the clockwork mod on and I'm backing up right now.
I'm not sure how to get the super user onto the root of my sd card from the computer.
Also, I was thinking of running rom manager now and putting cyanogen on, thoughts?
#11 fratan, Aug 4, 2012

When in recovery there is mounts section where you can mount the SD card to the PC via USB. Or you can plug the phone in via USB when booted and mount as a disk drive. Just make sure you are copying to the SD card and not the internal storage. (The internal storage should be about 6.6 GB)

You won't be able to have a stable version of cyanogen until you have s-off(the correct kernel won't install). So you'd have to finish the instructions on the thread I linked or would have to flash the kernel in fastboot.
#12 sdrawkcab25, Aug 4, 2012
ii tried a few differnt ways, i found the mounts but there is no way of getting the file over in the current phones state. Should I do a factory reset and them put the file on?
#13 fratan, Aug 4, 2012

You should 100% be able to get the file over there if it boots up or can get into clockwork(recovery). When in recovery, you have to press the trackball down to choose options.

Just have to choose to mount it as a storage device with the USB cord plugged into a computer.

Or if the phone boots up, you can install the app "airdroid" and do it wirelessly.
#14 sdrawkcab25, Aug 4, 2012
I'm in Clockwork and I'm in mounts and storage but I'm unable to mount either the sd card or the usb storage. My phone will only work in clockwork mode so I'm stuck.
Should I restore to factory settings?
#15 fratan, Aug 4, 2012

What are you seeing when you try mount the USB mass storage ? Any error messages?

What happens when you plug the phone in while it is booted up? Are you getting prompted on the phone as to what connection type you want?
#16 sdrawkcab25, Aug 5, 2012
im about to read thru this again,and see if i can figure out whats going on(i just skimmed it right now) but you can also get things on and off your sd with a card reader.
#17 scotty85, Aug 5, 2012
basically,this is "main version older" and is saying that you cannot install the older RUU. since you have hboot 1.07,your s-on phone wont let you install 1.02,wich,as sdraw said is OK :)

i will add something to the OP so other folks dont get tripped up in that also,now that we are seeing 1.07 with more frequency.

definately let us know the answer to this. im thinking we maybe have a misunderstanding on how to manipulate/select in clockwork.

as s draw said,there isnt any reason you cant connect to your pc with the phone in recovery,and there also isnt any reaosn it shouldnt reboot.

as i said above,you can power your phone off and use a card reader,or another cell phone,to get the superuser files onto the sd so you can flash them.

you very definately want to continue the whole process and achieve s-off. it may seem a lil overwhelming,but just go slow and ask questions,and well get you thru it. its well worth the effort. :)
#18 scotty85, Aug 5, 2012
When I boot the phone now after installing Clockwork 5 on it, I get Droid and then HTC, and then Droid, and the HTC screens going back and forth, sometimes voice and sometimes not. So I can't use any app's to go to next step.

When I boot up in Clockwork after taking out battery, It appears to be working fine. I can go to recovery and get to mounts and storage. I noticed that cache will stay mounted and when I select mount usb storage it goes to the next screen and says USB Mass Storage device leaving this menu unmount your SD card from your PC. I select unmount and it brings me back to the previous screen and all the fields are mount except unmount/ cache. When I select unmount cache/ and then select it seems to be ok. I then go to mount usb storage and hit select, it brings me that screen again that I just descibed. I plug my usb into the phone and I hear the bbeep from my pc that it connected and nothing else happens. When go back to the previous screen it says mount usb storage even though I selected mount in the previous screen.
I trying to find out if I should back track and do factory reset.
Any suggestions would be greatly appreciated. I need to revert back today if I can't move forward because I need the phone in the AM.
#19 fratan, Aug 5, 2012
try wiping cache and dalvik cache in clockwork. if that doesnt allow the phone to boot,you might try a data/factory reset and wipe the caches again.
#20 scotty85, Aug 5, 2012
Wipe the caches.....nothing......Factory reset and wipe caches again and the phone is booting up. Go to the the unlock screen and then HTC, its working, I have the phone back. I'm going to load airdroid and download the app for superuser unless you think there is an easier way to go.
#21 fratan, Aug 5, 2012
I was able to pull superuser from my pc to my internal sd card. Should I unzip the file from there or did I put it in the wrong place. I use drive h, maybe g is where it is suppose to be? I installed it from the sd card to the droid and got install complete. is there a way to remove the zip from internal sd or should i just leave it.
moving on to next step. we're getting close to a donation.
#22 fratan, Aug 5, 2012

if the phone is booting,you are good to go. as far as g vs h,its impossible to say.. it depends on what other drives you have attached to the PC. you need to figure out wich of the drives is the actual sd card,as that where you need to place superuser in order to flash it.

if you are leery to continue the guide today because you have need for the phone tomoro,you can flash superuser and leave it at that,or you could just leave the phone as is.

i would not reccomend to flash any roms at this time,as sdraw said,you may experience issues from the inadequacy of htcdev that leave the phone unfuctional. wait untill youve achived s-off,to falsh roms.

you should have plenty of time to get the guide finished,or recovery if somethnig else goes awry,so if you want to finish it up,carry on :)
#23 scotty85, Aug 5, 2012
Step 4 I'm stuck here. File not found. I match the numbers and everything was good. I'm getting file not found. I tried typing it several different ways.
cd /data/local
chmod 0755 /data/local/flash_image

I think I got thru it.
chmod 0755/data/local/flash_image

cd /data/local
./flash_image misc /sdcard/mtd0.img

I'm stuck here. permission denied got thru this. I'm downloading froyo onto phone.......nice
#24 fratan, Aug 5, 2012
awsome! youre almost there :smokingsomb:
#25 scotty85, Aug 5, 2012