Samsung Galaxy Note 2 Forum

Support Exchange problems: I can see emails but not Calendar entries!

Hi

My emails are syncing fine, but my Calendar wont sync at all!

My setup:
I am using MS Exchange (2007) and Android JellyBean (4.1.2) on Galaxy Note 2.
I am using Outlook2010 on Win7 x64 on my PCs.

EMAILS SYNC FINE
Emails I send on Outlook(v2010 on Win7 x64) appear on my phone.
Emails I send on my phone appear in Outlook.
All good. :)


BUT CALENDAR IS NOT SYNCING
Calendar entries in Outlook are NOT appearing on my Galaxy note.
Calendar entries on my phone using S Planner (or the Week Calendar app) are not appearing on my Outlook. :mad: :mad: :mad:

I have various "calendars" visible on S Planner including:
"My Calendar"
"My Exchange [my emails address]"
"My Gmail account"

But no matter which calendar I select, the entries are NOT going back to Exchange and are not visible through Outlook (on my PCs).

How come I can see emails but not Outlook Calendar entries?
Do I need to set up a special VPN or something?

I am getting desperate!

J

 

Related:

#1 ship69, Apr 1, 2014
That may be part of the problem. Outlook 2010 doesn't play well with Android. I hope you can find the solution but in my experience, it's been a headache
 
#2 tube517, Apr 1, 2014
In your Exchange account setting on your Note II, you checked to sync Calendar right?
 
#3 lcneed, Apr 1, 2014
Er not sure where to find that...
Settings ==> Accounts ==> Microsoft Exchange ActiveSync
then er "Sync All" ? Yes tried that.

OR
Settings ==> Accounts ==> Microsoft Exchange ActiveSync
then Accounts ==> [my email address] ==> make sure Sync Calendar is ticked, then click "Sync now"? Yes tried that.

OR
Settings ==> Accounts ==> Microsoft Exchange ActiveSync
then (Common Settings) ==> Settings ==> Added accounts ==> [my email address] ==> Exchange ActiveSync settings ==> Period to sync calendar ==> 6 months ? Yes tried that.

OR
Settings ==> Accounts ==> Microsoft Exchange ActiveSync
then (Common Settings) ==> Settings ==> Added accounts [my email address] ==> server settings ==> sync Calendar set to ticked? Yes tried that.

Any other suggestions? :thinking:
 
#4 ship69, Apr 2, 2014
Is Outlook2010 the problem or is the MS Exchange?

Either way it's bl***y ridiculous - this is industry standard software!
My boss has been mocking me for several weeks now. He just popped the details into his iPad ONCE and not a single problem with either calendar or emails.

To be honest it might even be a deal breaker. I *MUST* get this stuff to work or much though I hate Apple with a passion, I might be forced to defect too... :afraid:

P.S. Out of interest, is Outlook2013 or ms Exchange Server 2010 or Exchange Server 2013 any better? (supposing our small company could even begin to afford them...)
 
#5 ship69, Apr 2, 2014
Have you gone to your IT dept and gone over what the settings should be? I can't say 100% for sure that is the issue but I've seen it in other forums.
 
#6 tube517, Apr 2, 2014
This is copied from the link provided at the bottom...


The following steps may result in the loss of any unsynced data. Any event information that can’t be viewed on Google Calendar on the web will be lost, such as device-specific features like notes and photos.
We recommend proceeding with these steps only if the above steps don't resolve the issue.

Open your device’s Settings.
Select Applications, then All.
Select Calendar Storage.
Select Clear data. Answer OK when prompted.
Turn Calendar sync off and on in Settings > Accounts > Google > [your affected account], or from within the app using Menu > Refresh on newer devices. If you receive an error message upon opening the Calendar app, close and re-open it to re-activate sync.

https://support.google.com/calendar/troubleshooter/2819319?hl=en#ts=2819328,2819409
 
#7 scanman, Apr 2, 2014
Hi Ship,

Did you get your settings checked? I'm using Outlook 2010 and it works fine. let us know if you need more help. Lastly, tell your boss to stuff it up his jumbo!

Matt
 
#8 onemat, Apr 8, 2014
Yes the settings come from the IT dept.
 
#9 ship69, Apr 10, 2014
 
#10 ship69, Apr 10, 2014
Hi

My calendar sync issues were solved by installing Google Calendar from playstore And configuring it to display my calendars. I don't use Google calendar but since doing that syncing works. Not sure why but is perhaps worth trying...I suspect some code is now included in the app.

Roger
 
#11 girolez, Apr 10, 2014
I just made this account here to say THANK YOU SO MUCH. I'm pretty tech savvy, but I switched from a 4.4.4 Galaxy S4 to 4.4.4 Note4 and could not figure out why the hell my work calendar would sync when the exchange server settings were 100% indentical. Tried almost everything and this solved it immediately. Thanks!
 
#12 dr0be, Nov 28, 2014
Roger or anyone out there:
I have a similar problem to Roger where my Outlook calendar stops syncing. I have fixed it many times by clearing the data from Calendar Storage but this has become impractical as now I have come to rely on this process on a daily basis. I have installed Google Calendar (second attempt with this app) to see if it can fix the problem. I have learned that by solely installing this app won't resolve anything. Roger mentions that he got it to work by configuring the app to display his calendars. The app help menu explains how to do just that but I do not see the options on the actual app menu as described. Any help will be greatly appreciated.
William
 
#13 William O, Jan 8, 2015 Last edited: Jan 8, 2015
I forgot to mention that Google events entered on my PC browser synchronize fine with my Samsung Galaxy S4 Active. The problem happens with my Outlook events (my primary calendar) not syncing with the device.
William
 
#14 William O, Jan 8, 2015
Update: After a few days without having synchronization problems I believe it is safe to assume that my problem has been fixed. I changed the syncing settings to only sync the last 6 months. I had it set to sync the whole 3 years+ worth of calendar entries. I am guessing that the Calendar Storage App on the Android phone can't handle that much data. In any case, I am happy I can again rely on my phone to back up my new entries into the cloud. If I ever need to go back to check on an old event I can open the browser or use Outlook on my home computer. (Hotmail Syncing problems fixed on Android phone after changing Sync settings to only handle last six months).
Update: The phone still stops syncing calendar data although it seems to take longer for the problem to reappear. This is unacceptable but since there is nothing I can do, I just keep checking the last calendar syncing date and compare that to the last syncing of tasks and contacts. Only the native email client give me an accurate reading of this info.
 
#15 William O, Jan 15, 2015 Last edited: Feb 2, 2015
It that will help someone, I fixed my issue by choosing to sync ENTIRE calendar. Maybe for some people it will work if you extend the time to sync to a month, 6 months or more but I did not care much about how many events are sync'ed, so it worked.
 
#16 Evolnity Inc, Mar 23, 2015
This finally solved my problem. Just today my Calendar was all blank and showed no existing events. It did synch on new events, but refused to show already existing ones that it had shown fine yesterday. Email worked just fine. Clearing the data on the two Calendar apps in the way described, and restarting the phone, fixed this. It also changed the colors for my accounts, but I can live with that...

EDIT A week later... I now struggle with Exchange battery drain issue. It drains my battery in like 3 hours, and it does not seem to matter what settings I use. *sigh*
 
#17 OppfinnarJocke, May 6, 2015 Last edited: May 11, 2015
I found a fix:

1) Go into the Calendar app on your smartphone
2) Tap the + icon to add a new calendar entry.
3) Make sure the calendar is set to use your preferred e-mail address.
 
#18 TerminatorDude, May 7, 2015
TERMINATOR DUDE! YOU ARE THE KING!!! So frickin' simple. How the hell did I miss this. DUH.

BOOM.

Thank you. *bows down*
 
#19 legalbeagle05, Jul 29, 2015

You really safe my day TerminatorDude.. Thanks x10000000000.....
 
#20 songwk, Sep 4, 2015
Only just created an account on here.

You, sir, are a god.

ALL HAIL TERMINATORDUDE
 
#21 Zane Wederell, Sep 9, 2015
My calender and contacts would sync with my exchange account on my nexus 4 running 6.0. This was caused by the exchange service app not having the needed permissions. Settings -> Apps -> Exchange -> Permissions *activate everything*
 
#22 FJN4, Nov 23, 2015
After trying literally everything else on this list, FJN4's answer finally got my client's outlook calendar syncing on his android device. Thank you!
 
#23 Jezze, Jun 20, 2016
Thank you FJN4!!!! I having been searching all night for a solution to this! That's quite the bug that you can add an exchange account and Android doesn't prompt for the permissions it needs. It's also a bit confusing because it's actually the Gmail app that does the syncing and needs the permission, not just the calendar app.
 
#24 Jeremiah Pierucci, Sep 7, 2016
Hi Everone! I also have huge problem with Exchange (Active Sync) on S6 android 6.0.1. I have the account connected, it synchronizes everything (mail, contacts and apparently calendar entries as it shows) but I can't find the exchange calendar anywhere! Neither in Calendar app (have only google clendar and local one) nor in Business Calendar (same). it seems like the calendar is not available. I tried everything... does anyone know what can be wrong?
 
#25 Foxx102, Jan 4, 2017