Samsung Galaxy S2 Skyrocket Forum

Support Exchange services taking too much battery

Hello everyone!

My phone has been replaced twice for draining battery and overheating in the camera area.
when it happened again after I got a new phone (Rogers, SGH-I727R), I decided to look further into it.
at first I thought it was the 4.1.2 version that's doing it and I was looking into downgrading the version but I'm still under warranty (until October) and don't want to go with anything not formal.

and then I checked the batter consumption and found it was the Exchange services (for work. my other email is pop3 and not issues. I'm not using gmail at all). I'm using push, and email, contacts and calendar services sync.
when I first got the phone it was running fine with Exchange. no heating or battery issues.
but lately it has become unbearable. battery is draining super fast and overheating.
after I removed my exchange account from the phone, it went back to normal.

but in order to work, I need to fix this.
Does this sound familiar to any of you?

thanks!!
S.
 

Related:

#1 swan14, Aug 18, 2013
no answer, ah?
well, the only thing that seems to help for now is to sync every 5 minutes instead of using push.
I will let it run like that for a while and see if it comes back.

according to this google case Issue 37437 - android - Exchange Service High CPU Usage, Battery Drain since Jelly Bean 4.1.1 Upgrade - Android Open Source Project - Issue Tracker - Google Project Hosting , this is happening to lots of people on many different android devices with Exchange.
not every solution solves it to everyone.
I tried factory reset and replaced my phone twice. I removed and readded the account many times.

Please let me know if you have any insights...
 
#2 swan14, Aug 20, 2013
I had the same issue.

It was working fine for a week since I bought the phone. Then suddenly yesterday it started acting up and Exchange Services took up >60% of my batter usage. It's set up with my work email.

Here was my solution:

1. Go into Settings
2. Scroll down to Accounts and click "Corporate"
3. You will see the green sync icon. For me it was going haywire and was syncing non-stop.
4. Click into it. and you should see 3 options: Calendar, Contacts, and Email.
5. I tried ticking each one of them off 1 at a time to see which one was giving me trouble. Turns out for me that it was my contacts. So i switched Contact sync off. Now it works perfectly fine.

By the way, I am on Automatic (Push) sync. Now the exchange service does't even show up in my battery usage menu.

However, I wont have my contacts constantly synced. But this isnt a huge issue for me since it's not like you are adding a corporate contact every minute of the day. I will just come back and sync my corporate contacts whenever I need to.

I know that some other user switched to 3rd party email apps to fix this problem. So if my solution doesn't work out for you, that may be another option to consider.

Hope this helps!
 
#3 xinger, Nov 13, 2013
While I didn't have the associated battery drain, I was getting the same "constant sync" in my Exchange account on my Nexus 7 with Kitkat 4.4. When doing this, no email or calendar items were syncing. NOTE: I was NOT syncing contacts on my device (had that option unchecked) but still was having the issue.

Mine seems to be related to changing Wifi points. When I leave work or home, the sync issue crops up.

I have found a work-around, but it only lasts until the next time I change wifi.

  1. Go to Settings, then select "Corporate" under accounts.
  2. Select "Account settings (sync frequency, notifications, etc" - this opens the email app account settings.
  3. Select the account - user.name@company.com
  4. Scroll to the bottom of the settings list and select "Incoming settings (Username, password, and other incoming server settings)"
  5. On the server settings page, select "Done" - don't change anything, just press the "Done" button.
  6. A popup will show stating "Validating server settings..." - As soon as I've done this, my email and calendar will start to sync again properly and the "constant sync" problem goes away.

Again, I have to redo this every time I change wifi spots, but it does address the issue for me.
 
#4 youngheart80, Dec 3, 2013
Okay...here's what worked for me after a 2 hour forum review. I have exchange server, getting rid of it was not an option. It's how I work. BUT, I removed the account completely from the phone. Then I learned from another forum. (some guy called the Samsung 1-800 number, who knew that might work? :) )
First: push power button and power phone off.
Next:
At the same time...push the "VOLUME UP, the Home Button, and the power button on... this will do a "Reboot Reset" BUT you will not lose any precious information. (you know random azz text from lovers past, pics of kids, etc.) Once the phone is back on...just do the "reboot" request. Then give it a minute...just to breathe and get itself back together, phones have feelings too! lol
Once I did this, I re-added my exchange account and so far so good. The battery is back to normal.
 
#5 firesigninc, Dec 19, 2013
The problem is not the phone. It is exchange.

Log into OWA.
Go to mobile devices. (On my account every phone I ever had connected to exhange was listed.)
Delete all of them. (Including the one you have now.)
On your phone 1. Force stop 2. Clear data and cache 3. Delete account. 4. Restart 5. Re-add exchange services.

Give it about a day. The exchange drain will drop way down the list. (On mine went from 60% to 5%)

I also changed from push to every 15min, but I had tried this prior to finding the OWA solution with no change.

Hope this helps. If already posted ... consider this confirmation.
 
#6 johnhunt625, Jan 7, 2015
Follow the directions above, just do not do what i just did... instead of hitting the red x for delete. I wiped my phone.... wtf why is that even an option in my mail settings. Didnt really process what i clicked until it was too late and i couldnt reverse the wipe. RED X!!! NOT WIPE PHONE!
 
#7 Virile, Jan 9, 2015
I almost did the same thing. I probably should have cautioned against. Hope it didn't mess you up too much, and that the rest of the solution works for you.
 
#8 johnhunt625, Jan 10, 2015
Where and what is OWA? How do I get to it?
 
#9 carpenter17, Mar 18, 2015
Make sure any changes in passwords are updated on your phone. I recently went through this and until I updated my passwords with the cell phone, the exchange was continually burning up the battery trying to sync with the server. Lots of good answers in the forum.
 
#10 Regggie, Oct 1, 2015
Here is the fix that worked for me.

It is very simple.

Go into Exchange and delete all your email accounts.
I have an msn, as well as a hotmail email.

Then go to playstore and search for and install "Outlook"

The icon is a blue square with a white letter "O" and a picture of a closed envelope behind it to the right.

You can add all mail accounts whatever your provider, from the drop down menu when you hit the add account key.

I added my two Exchange accounts.....msn and hotmail, and also my third email account provided by gmail.

My smart phone no longer has the problem of Exchange using up battery like mad.

I gave Outlook access to all and anything it wanted to have access to. Still no problem.

I haven't even needed to disable Exchange, as long as all accounts are deleted, it cant do any harm.

Hope it works for all you guys and girls.

Steve.
 
#11 Cadwalader, Nov 21, 2015
Regggie's advice was right for me - I was getting the problem with the constant repeated sync and the battery drain, and it turns out that it's because the phone-to-Exchange authentication was failing because I had changed my AD/email password a few days before.

When the sync fails (e.g. because the phone still has the old password), it doesn't back off before a re-try, it just tries again immediately, repeatedly.

After updating the Exchange sync password on the phone, the sync succeeded and the battery drain stopped, happy days!
 
#12 enbe, May 4, 2016
I had the same problem - hot phone, battery dead in 3 hours. Verizon store guys were NO help. After they tried to sell me a new phone, they told me i needed a new battery. The Samsung battery I bought from Amazon is counterfeit, so beware! I searched through the forums for answers. Going with the simplest first, I changed my email password on my laptop then matched it on my phone email exchange. Shazamm! Problem fixed immediately. What Reggie and enbe said above is dead on. Thanks guys!!!
 
#13 Susan999, Aug 17, 2016