Motorola Droid RAZR Forum

Tips Facebook Contacts NOT syncing...


All of a sudden the Facebook sync on my phone has stopped working any suggestions in how I can get it to work again...

Thank you :)


#1 izzabellekoala, May 16, 2012
Having the same exact problem. I think it quit when the last facebook app update came out.
#2 ljprevo, May 16, 2012
I think I have found a solution I downloaded Facebook Contact Sync from Play Googleand it has seemed to have worked... Then clicked off it in Contacts and then it syned them all again.

Kind Regards
#3 izzabellekoala, May 16, 2012
I had the same problem, and was able to fix it by uninstalling and reinstalling Facebook. It has worked fine ever since.
#4 emmzone22, May 16, 2012
I just found this thread. Thanks for this. In my case, Facebook Contact syncing was working, then I realized that I had two Facebook listings in My Accounts and I deleted one, which apparently was Facebook Contact Sync. Oops!
#5 JOSHSKORN, Jun 1, 2012
Apparently it is not an issue with Facebook or Google - Google did not like the changes to Facebooks privacy policies so they have removed support for syncing between the two in the new versions of Android. You can download a couple apps though that will do it for you, but the native support for syncing for Facebook has been removed from the Android OS completely.

You can download HaxSync or Friendcaster to fix the issue.
#6 CptSternn, Sep 15, 2012
No, AFAIK Google had a custom interface just for Facebook but they scrapped it and wanted Facebook to integrate into the contacts like everyone else. The Facebook app's native integration is currently broken on CM and some other ROMs but it works on many official ROMs.
#7 KurianOfBorg, Feb 8, 2013
Please a step by step way to get back my fb contacts
#8 cmv, Feb 2, 2015
I am not sure if this will help anyone but I had issues also with facebook not importing contacts and syncing pictures. I uninstalled the facebook app and reinstalled it. But where I went wrong was when I logged back into the facebook app I used my email address instead of my telephone number as the user name. This caused it to not import any contacts. Upon logging out and logging back in with my telephone number as my username it imported all my contacts and synced pictures again. Issued fixed for me. Hope this might help someone else having a similar problem. I did have to go into Settings>Accounts & Sync>Facebook and force sync for it to update.
#9 Sikeamike, Oct 28, 2015
I downloaded an old facebook version from amazon and it gave me the choice to sync my contacts and it worked. I was on the phone with tmobile for an hour and samsung for 1 hour an a half and they don't know how to fix the problem because facebook has changed the feature in the updated version.
#10 akingarn, Oct 31, 2015
you have to download an old version of facebook from amazon and delete the new version and all the updates from your phone. I had been trying to get this fixed for two weeks and this worked.
#11 akingarn, Oct 31, 2015
How do you find an old version of facebook? Having the same issue and have tried all of the above fixes to the problem
#12 ddierolf, Nov 11, 2015
I tried everything and this finally worked for my S6.

1) Settings - Go into accounts. Delete Facebook account. (Someone in this forum said delete the app, but you can't bc it came with the phone and won't let you.)
2) Settings - Go to Applications. Then Application Manager. All Apps. Click Facebook. Uninstall updates. Clear Facebook data. Clear cache.
3) Settings. Go to Accounts. Add new account. Choose Facebook. Login with your phone number NOT your email.
4) If you get a phone notification that says Samsung would like to access your Facebook account say yes.
5) Settings. Go to Accounts. Click Facebook. Click on sync with your device. Move the toggle bar to active.

Then it should start synching. I'm wondering if it will stop when my phone automatically updates the app to the newest version. We will see. Unfortunately there is not a "update this app automatically" check box to uncheck on the facebook app in the play store.
#13 Ebfly21, Dec 13, 2015