Home Forum

Support Fake GPS use - Gmaps keep switching between real & fake location

Yeah that is not the experience I had. All I can think is that our phones operate differently or you didn't disable the correct service.
 

Related:

#26 Cody1234, Jul 18, 2016
This is screenshoot from my disableservice apps
 
#27 Masehitam, Jul 18, 2016
Click on fused location and unselecte it. Then restart your phone and see if it works.
 
#28 Cody1234, Jul 18, 2016
Hi guys. I'm on galaxy note 4. I disable fused locations reset phone and enabled mock location using the same app. I also have the fake gps installed to system app.
But I have the fake gps location set and it saying it can't detect my location at all ?
 
#29 cycalo, Jul 18, 2016
Yeah I did that, and rarely it back to real location, but sometimes I can hit pokestop or cacth mons
 
#30 Masehitam, Jul 18, 2016
I think POGO detect mock location settings
So if you want use fake location apps install it as sistem apps through lucky patcher
 
#31 Masehitam, Jul 18, 2016
yeah i don't know what the issue is. I would go back to someones guide and follow it step by step and see if you missed something.
 
#32 Cody1234, Jul 18, 2016
Yeah that's my problem. I already have fake gps install to system apps but when I disable fused location my actual phone act detect any location even when I have fake gps activated ?
EDIT and I reset my phone
 
#33 cycalo, Jul 18, 2016
Fake GPS also requires that expert mode be turned on (this requires the paid version of the app) in order to work properly.
 
#34 chaoswreaker, Jul 19, 2016
hello

i managed to get pokemon go with fake location working the following way:

galaxy s5 rooted, set fake gps pro as system app via lucky patcher ( doesn't matter which fake gps app you use, lockito works too ), xposed installer with hide mock location and also mock mock location.

so i enabled mock locations via developer options -> opened xposed -> enabled one of the 2 mock location hiders ( hide mock or mock mock ) it doesnt matter which, but only have 1 active. -> restart s5 -> open fake gps pro and set expert mode ( other setting doesnt matter it works all ) -> set your fake location via fake gps pro and...
tadaaa, its working, pokemon go doesn't detect your enabled mock location in developer options due to the active xposed module (hide mock OR mock mock locations).

but thats it? would be too easy.
its only working smoothly for a limited period of time. for me its 5-10 mins, sometimes 30 mins and sometimes only 1 min.
then the location starts to jump between fake and your actual location.
why? my mock location setting under developer options gets resetted back to disabled.
it automatically unchecks this options for any reason i havent figured yet.
my guess is that the pokemon go app disables it via any of its implemented security services.

you can get your fake location without jumping back through restarting your smartphone and enable mock locations in developer options again, also you can try different settings with your fake gps apps and these 2 different xposed modules.

my question to you guys:
is there any possibility to leave mock locations enabled in dev options? like forcing it to stay active forever / or prevent other apps from unchecking it?
 
#35 bube92, Jul 19, 2016
One way I found to prevent the jumping around:
1. Download DisableService from The Play Store.
2. Install it and search for Fused Locations.
3. Untick this box (grant/allow root access) and reboot your phone.

After this you can easily set you GPS coords without it jumping you around from your fake and current location. To give fair warning: you will need to re-enable the Fused Locations service and reboot again if you wish to use your GPS for anything other than spoofing in POGO.
 
#36 chaoswreaker, Jul 19, 2016
nah,i already disabled all the location services + even the fusedproviderservice, forgot to mention:rolleyes:
thanks tho:p
for me its all about the mock location in dev options that automatically sets itself inactive after some minutes.

the unchecked mock location from developer options is the only thing that causes jumping locations.
because this system native service, if enabled, simply doesnt allow jumps.

ofc there are other reason for jumping but thats only the case if people dont use xposed:p

if anyone knows a hardcorenerd that knows how to force mock locations being enabled forever, please let me know;)

edit: or maybe because i disabled all googleservices with the name location and fused, i now bugged my mock location service -_-
ill figure it out
 
#37 bube92, Jul 19, 2016 Last edited: Jul 19, 2016
Well that can't be good lol

EDIT: I seem to have run into the same issue as you and resolved it by disabling the Fake GPS system app and rebooting. I guess the Expert Mode option prevents access to the Allow Mock Locations setting.
 
#38 chaoswreaker, Jul 19, 2016 Last edited: Jul 19, 2016
Hi All, [Samsung Galaxy S6 Edge on Android 6.0.X]

After rooting, installing the proper Xposed framework and mock mock module, disabling all of the wifi/gps/bluetooth scanning services, installing the FakeGPS app as a system aplication with Lucky Patcher, and using the DisableService app to disable Fused Location, I was still getting the issue with bouncing back and forth between mock and actual location. Here is what I did to solve my issue:

1) It turns out there are two Fused Location options, one as a stand alone in system services, and another in Google Play Services so you should disable both. (note when not using GPS spoofing you should restore your settings to ensure your phone functionality remains optimal). [ Each time you disable services you should reboot your phone ]

2) I'm not sure if this is necessary so test it out after trying the first step above and if your problem persists you can disable the following services within Google Play Services using the DisableService app:

a) Location Sharing Setting Injector Service
b)Log Message Service
c)Work Account Authenticator Service
d)Crash Report Service
e)GCM Intent Service
f)In Call Service ImpI
g) Tp Hce Service
h) and obviously the Fused Location Service.

[ Each time you disable services you should reboot your phone ]

Also note:

1)I have disabled all 25 services under Maps, again, not sure if this is necessary so only do it if steps one and two have failed;

2)There is a step required where you enable developer options, i believe you need to go to about phone and tap build number repeatedly until you see a message that says you are now a developer.

Finally, a warning, every time you turn your GPS on and off, the "Locating Method" under Location setting keeps defaulting to GPS, Wi-Fi and mobile networks. Be sure that you manually set it to use GPS only each time you turn on your GPS.

I hope this helps, it was a pain in the ass getting banned and bouncing around :)
 
#39 Gagstr, Jul 20, 2016 Last edited: Jul 20, 2016
Wow.. That feels nuclear lol
 
#40 chaoswreaker, Jul 20, 2016
If you are referring to my ordeals, it was.... big time lol, trying to save everyone the trouble :)
 
#41 Gagstr, Jul 20, 2016
I have no idea why some of you are having success with this "trick." The service FusedLocationService has nothing to do with GPS. It's to manage apps that store data on both the internal memory and SD card (whether you have a removable one or a built in one doesn't matter.)

FusedLocationService simplifies the process of reading data from two separate drives by acting as if they're one. It "fuses" the location. Of data. Not GPS signal.
 
#42 Pappydapimp, Jul 20, 2016
If you're using xposed why not just download the Pokémon Controls module?

It blocks mock location itself, allows you to set your start point and provides you movable WASD style controls on the screen. No other apps necessary.

And since it uses mock location there's no rubber band effect from the real gps signal. It's absolutely flawless!
 
#43 Pappydapimp, Jul 20, 2016
It happened with me as well.If you're using the special root feature in fake GPS spoofer,disable it and it will work.
 
#44 bloodalvin, Jul 24, 2016
The fake gps app sends data via the internet so you need to have a stable internet connection, whenever I have a faster internet, this problem does not happen with me. It only happens if you have an unstable or slow internet
 
#45 Abdul Muqtadir, Jul 25, 2016
Hi guys, thank you for your help, now it's working fine, but i'm afraid to use it for looking pokemons in another country ;i'm from Colombia and want to look for pokemons in USA or Australia, is that possible ?or will I get the soft ban?
 
#46 fabio suta, Jul 26, 2016
I cant get it to work that fuses location is disabled. it keeps saying "failed to gain root acces!". Do you know how to fix this?
 
#47 Rik Verhoeven, Jul 29, 2016
The Android Phone I own is a Doogee X5 Pro.
It is running Android 5.1 Lolipop
The issue I am having is that I can make my user run around using the GPS with FakeGPS and I have disabled many services (This is from the tutorial that the person states earlier about all of the services to remove) and I can't use Xposed Framework because it won't work on the device. I have my Android rooted but I bounce back and forth quite often. If I go for enough away from my original location then it will Soft ban me but there is a way around Soft bans.

I have tried everything that everyone on this post has suggested. Still seems to happen. I am not entirely sure why
My location setting is set to Device Only so it only uses the GPS to get the location. My setting for Fake GPS (Full version): Update Interval : 1 (I have tried changing this around a lot and it doesn't seem to make any difference)
GPS Accuracy : 1 (I have also tried messing around with this and it makes no difference)
I can't use the walk around location because every time I try to use it.. it doesn't take me to the area I have chosen, instead, it will walk around my original location and teleport me to the location I have chosen every now and again... Very annoying.
The root I am using is KingRoot (Did this because its easy and I have no real reason to root my phone as I don't use it for many things) I went into my KingRoot app and looked at the root authed apps and FakeGPS is not there. For some reason. there is no method of adding an app to the root auth unless the app asks for it. So this may be my problem. I think that my FakeGPS app is not running in full root when in expert mode. As it requires it that may be the problem but what I can't understand is.. that would stop the app working correctly in the first place. The app works just bounces me back and forth. Any help would be nice. I kind of want to get this fixed because I can get passed soft bans and gathering a few new Pokemon would be fun (I live in a rural area where there are 2 gyms and about 5 pokestops.
 
#48 Old Greg, Jul 30, 2016
Worked perfectly -- thanks a million.
 
#49 Anynameyouwish, Aug 4, 2016
Hello!

I have a problem with DisableService -app. I cant find "Fused Locations" options in my System tab. What could be the problem? I have Samsung S4 Lollipop 5.0.1 and rooted with KingRoot and Fake GPS app is moved to system app with Lucky Patcher.

I would be thankful if somebody knows why Fused locations doesn't appear! :)
 
#50 barnaydonk, Aug 11, 2016