Samsung Galaxy S2 Forum

Flashing ROMS to Boost sph-d710bst

Just checking if anyone has any pointers on flashing ROMS, I have the boost mobile, sph-d710bst, GC01 with SXTP agat gc01 kernal/recovery and I was trying to flash the touched by S4 GB27 rom last night, but got stuck in a boot loop, and had to do nandroid restore to get my phone working again,, I do spend a lot of time researching the formus on how to properly flash a ROM, and have successfully flashed my previous phone to many different ROMS, I read a lot of useful information on XDA, about the SII, and i have a good understanding on how to flash, but there are a few things, I was wanting to get some advice on,, I found a big thread to make sure you have a JB modem, then they also mentioned that flashing with agat has caused some issues so they recommended flashing fl26 w cwm recovery first then doing a 2x wipe which wipes cache data system preload, then flash the rom,, they did mention boot loops happen I tried to pull the battery , boot into recovery, wipe cache , and dalvik then reflash, but i still ended up with the boot loop, also when I flashed the fl26 recovery the recovery loaded but I couldn't select anything and had to flash the agat recovery back on to restore my phone. is there a better cwm recovery that would work on my phone to flash the rom?, are there still issue's with the sdcard getting corrupted unusable? I should be able to flash sprint roms/kernals to my phone correct? any advise is appreciated, I tried a few different ways to flash this rom but was unsuccessful,, the GC01 modem should work with the GB27 rom is what I was understanding on the thread,, but maybe i need to flash a GB27 modem first. Any suggestions is appreciated.
 

Related:

#1 kshow215, Jun 11, 2013
The modem will only affect DATA it won't cause boot loop, You could flash the GB27 modem if you want as GB27 is the Sprint labeled version of the same ROM. This should give you more info on TW JB ROM flashing.

http://forum.xda-developers.com/showpost.php?p=35539014&postcount=4
 
#2 Codegerm, Jun 11, 2013
I could leave the GC01 modem on the phone right even if I flash a GB27 ROM?
 
#3 kshow215, Jun 11, 2013
I read in XDA and some other sites, that it's advisable to use a safe recovery to flash roms to avoid the emmc brick bug,, looks like it's limited to ICS recoverys, but they recommend to flash fl26 then use cwm to flash the rom,, however I flash that recovery, and I can't select the options in recovery,, is there a better recovery to use to flash the ROM with?
 
#4 kshow215, Jun 11, 2013
That would be EL26 or EL29 direct boot. GC01 is a JB modem just like GB27.


That link I posted has links to the stuff you will need.
 
#5 Codegerm, Jun 11, 2013
Ya I typed that wrong I tried the EL26 with CWM, the recovery loaded, but I couldn't select anything, I had to flash with odin to get back to a working recovery,, I'll try the direct boot next time and see if flashing the rom that way will work,, I ended up using one of agats recovery's and I did my research before hand, I have been to a lot of XDA links, and have read everything,, they even mentioned the boot loops,, after flashing, and to try and wipe cache and dalvik then reflash, but it still boot looped I made sure it was a clean install and everything,, I did a 2x wipe of System , cache , data, preload, then flashed the ROM, but got stuck in the rom rebooting back into recovery on its own
 
#6 kshow215, Jun 11, 2013
You couldn't select anything because you needed to press vol+ vol- vol+ for the power button to work as select in those older versions of CWM
 
#7 Gendo420, Jun 12, 2013
Moved to the All Things Root forum. :)
 
#8 Atma, Jun 12, 2013
Thanks for the responses,, I did find that out last night, I was trying the power button to select, and I needed to use the home key to make selections,, I'm used to the power button working on all the recoverys I have used to this point,, so I was able to try to flash touched by s4 with both the EL26, and the EL 29 direct boot, however I still ended up with a boot loop, I have read every XDA link about flashing this ROM, they even mention having boot loop issues, I tried EL26, then ran the 2x wipe zip that formats cache, system, data, preload, twice, before flashing the ROM I even wiped dalvik, and it didn't work I'll have to try a few things,, I was able to flash AGATS GB27 kernal on GC01 and it booted up, and I was able to overclock/ so I may stick with this for the time being, I was interested in getting the touched by s4 rom working though,, thats the fun with attempting to customize!
 
#9 kshow215, Jun 12, 2013
Update I ended up having to download the rom again, I could have sworn the md5 matched but i checked it again and it was mismatched, I ended up having to download several times to get a good download
 
#10 kshow215, Jun 29, 2013
Cool man glad you got it worked out........:D
 
#11 Doc, Jun 29, 2013
I've had the exact same issue... I feel your pain
 
#12 tnsmileychick, Feb 17, 2014