Nexus 5X Forum

Support Gmail notification... Not

About a week ago all was well. Then the phone stopped all Gmail notifications. The light. The icon in the status bar, sound nothing. Nothing new added to phone. No changes. Phone and text are working.
I looked at settings and they look the same, no changes. I could be wrong...
Any ideas appreciated.
 

Related:

#1 nvmichael, Jan 7, 2016
Which mail app are you using? The stock email app or the Gmail app? A third-party app?
A common first thing to try is go into your Settings >> Application manager, find your mail app, click on its 'Force stop' button, click on its 'Clear cache' button, then restart the app.
 
#2 svim, Jan 7, 2016
Have you tried simply rebooting the phone? Sometimes services lock up and it takes a reboot to flush them out.
 
#3 lunatic59, Jan 7, 2016
Thanks for the fast replys.
Gmail is the only mail app on the phone. I do not see a 'Clear cache' button.
How do I restart an app?
I have turned the phone off and restarted many times.
Thanks
 
#4 nvmichael, Jan 7, 2016
Go to menu>settings>sound & notification>app notifications and then tap the bar at the top that says "all apps" and select "blocked". If gmail is listed then somehow you blocked it. Tap on it and you can un-block it.
 
#6 lunatic59, Jan 7, 2016
Thanks. Not blocked.
I cleared cache.
I'll let you know if it works.
 
#7 nvmichael, Jan 7, 2016
I sent an email to myself from a Ipad. It took 6 minutes for the phone to notify me. I got an email this morning and nothing happened until I turned the phone on (with imprint).
So I guess its kinda working? All else is instant.
Thanks again for your help.
 
#8 nvmichael, Jan 8, 2016
I haven't used the Gmail app in a while but check the Settings menu for a sync frequency option. And keep in mind if you have your phone polling Google's servers for new messages too frequently, your mail app is just working all the time using up background resources.
Another option is to switch to a different mail client app. A lot of people here on the Forum are big Aqua Mail fans. I prefer K-9 Mail, an Open Source project that's been around since Google bought up Android itself. Most third-party mail apps have more extensive settings options that will give you granular control of your email.

https://play.google.com/store/apps/details?id=org.kman.AquaMail

https://play.google.com/store/apps/details?id=com.fsck.k9&hl=en
 
#9 svim, Jan 8, 2016
Is this your gmail email or have you set up a different account using the gmail app?

You might also want to make sure you aren't turning off all network connections when the phone sleeps.
 
#10 lunatic59, Jan 8, 2016
I don't think you get notifications when the phone hibernates
 
#11 bencarlsen, Jan 8, 2016
You can set it either way, but if you allow notifications you have to make sure data remains enabled during sleep which will use more battery. It's a trade off.
 
#12 lunatic59, Jan 8, 2016
I have an issue but the other way, it keeps notifying me and i some how can't turn it off, but as i have both gmail app and inbox app installed it actually said the other day; you have notifications from both apps, would you just like it from inbox?
(or something along those lines) i clicked yes and the notifications has decreased but still get loads as i have multiple emails in my gmail account...

Does anyone know how to control the amount of times the notification gets showed when the phone is looked? (so it lights up and you see you have a new message / mail ) from the beginning im almost sure i just saw it once, now i think i see it about three times per message..
 
#13 Mrohrn, Jan 14, 2016
If you're using inbox, you might have it set to remind you about messages rather than archiving or dismissing them.
 
#14 lunatic59, Jan 14, 2016
1.31 update. I updated the gmail app yesterday. This morning I received 3 emails plus I sent myself a test email annnd ta da all seems to be back to normal. I got the sound, the light and the icon. The test email was sent from my computer and the phone notified me within 3 seconds. Just like old times. I'm hoping the update was the fix. Lovin the 5X (again.)
 
#15 nvmichael, Jan 31, 2016
yeah maybe it is just some setting issue... but i can't find a setting that says "notification" or the amount of them.. but then again it is not only the email apps that does it but all messaging apps, Fb SnapC and whatsapp.. yes it is annoying but more i think it disturbs the phone from going into doze mode.. maybe i am wrong?
 
#16 Mrohrn, Feb 3, 2016