LG Volt Forum

Support Google Play Services consumes all memory

My wife has been having a problem with her LS-740 LG Volt for a couple of weeks now. Every day she gets a warning notification that the phone is out of memory and when we sort the apps by storage used, Google Play Services is consuming 2-3g of memory - 10x that of any other app. I have the identical phone, identical ROM version, and identical Google Play Services version and dont run into the problem. On my phone Google Play Services is typically consuming about 150M and never goes much above that.

The only way to fix it is to go to Apps, Google Play Services, Manage Space, and tap "clear all data". That works for about 12-24 hours before it gradually grows and consumes all space again.

What would cause it to go out of control and consume all memory? Could dropping the phone have caused it? She's dropped it a few times and even though it has gorilla glass, a 2 ft fall onto a tile floor cracked the screen pretty badly.

ROM version = LS740SV6
Google Play Services version = 9.2.56 (034-124593566)

We've tried doing a factory reset and reinstalling apps but it did not fix the problem. I've googled for the problem but come up empty.
 

Related:

#1 chuckh1958, Jul 11, 2016
I saw this happen once on another device. Put the phone into airplane mode, clear data for both the play store and play services, and uninstall updates to both. Reboot, and then disable airplane mode. I'd recommend going to WiFi, it'll update play store and services again.
 
#2 spock1104, Jul 11, 2016
Thanks. I'll give that a try tonight and post the results here tomorrow.
 
#3 chuckh1958, Jul 11, 2016
It worked! Thanks again.
 
#4 chuckh1958, Jul 12, 2016
I spoke too soon. Problem has returned.
 
#5 chuckh1958, Jul 12, 2016
My husband and I are having this same issue with our Volts. His started doing it last week, and I was researching how to resolve his issue ... with no luck. So, just to be redundant, I suppose, my Volt started doing it as well, yesterday. It also drains the battery whilst eating all available internal storage. Yesterday my Volt was reporting there was more space used than actually available (3.98G used of 3.93G total) ...and just about nothing can be moved to the SD. The SD is practically unused, it's reporting 58.91G available of 59.46 total.

I'm going to try yet another reset and disable everything google that I can. Hopefully I don't break it ;)
 
#6 Alexxann, Jul 13, 2016
Sounds exactly like my wife's issue. We've also noticed the battery drains very fast now too. I thought it was just that the battery needed to be replaced too but now I'm not sure. Looking in settings at whats consuming the batter doesnt yield any hint as to what may be going on.
 
#7 chuckh1958, Jul 13, 2016
Settings only tells you some of what is going on. The issue is with play services.
 
#8 spock1104, Jul 13, 2016
Have you tried clearing data in the download manager app? Package installer?
 
#9 Bg260, Jul 13, 2016
Could this be somehow tied to your user account? Have you tried logging into a different account after clearing data?

Also, one more thing. Perhaps it is syncing this data. Do you use chrome browser, Google Drive, Google Photos, Picassa, or Moments? Picassa is a problem for me. You can find answers in the Google settings app.

Let me know if you need more help.
 
#10 Bg260, Jul 13, 2016 Last edited: Jul 13, 2016
We use Drive and Chrome but none of the others. None of our Drive files are set to store locally either. We have separate google accounts but we both have each others accounts on our respective phones. We only sync things for our own accounts though on our own phones. The other is only there so we can easily log onto a shared youtube account for casting.
 
#11 chuckh1958, Jul 13, 2016
The first time I tried to fix it I did a factory reset. That should have cleared everything. The problem came back a few hours after the reset.
 
#12 chuckh1958, Jul 13, 2016
Ok. It was a thought. Try installing this app from the Play Store. Maybe we can find out exactly where this data is being stored.

https://play.google.com/store/apps/details?id=com.google.android.diskusage
 
#13 Bg260, Jul 13, 2016
That's what made me think it was syncing. Although, contrary to popular belief, a factory reset does not wipe the system partition. Only flashing the factory firmware can do that. Right now I'm having a lot of trouble tracking down the firmware. Not a good sign.
 
#14 Bg260, Jul 13, 2016
Maybe you've looked here already:

https://myaccount.google.com/
 
#15 Bg260, Jul 13, 2016
Yep, it's absolutely Play Services and a lot of people have been having this problem for a few weeks. https://productforums.google.com/fo...rce=footer#!msg/play/zdz-98balwI/G5PWDWQ5CAAJ
 
#16 Alexxann, Jul 13, 2016
Except that post refers to battery drain issues, which is not the OP's problem. They might be related though.
 
#17 Bg260, Jul 13, 2016 Last edited: Jul 13, 2016
chuck did mention the noticing the battery drain as well, not in the original post.
 
#18 Alexxann, Jul 13, 2016
Yes, they may be related. Basically says you have to downgrade Google Services, turn off automatic updates in the Playstore and wait for a patch??? Just sounds like, something that is risky as well.
 
#19 Bg260, Jul 13, 2016
Question is how do you know which version of GPS you had before so you know which one to download?

Also how can two identical phones with the same ROM version and GPS version behave differently? My wife's phone is losing all RAM and battery in a few hours while mine is working fine. Only difference is I'm rooted and she isn't. That shouldn't affect GPS.
 
#20 chuckh1958, Jul 14, 2016
;)

I may have taken a little creative license there.
 
#21 Bg260, Jul 14, 2016
I'm having this exact same problem. A full restore did not fix it. It seems that the latest Google Play Services has a bug on the LG Volt.
 
#22 ntowl24, Jul 15, 2016
And many other older devices too :(
 
#23 chuckh1958, Jul 15, 2016
I suppose being rooted could make a difference but not sure how. All that does is install the su command which allowed me to modify some settings to enable free tethering.

I was ready to upgrade anyway. Wanted to get a device officially supported by Cyanogenmod like a G3. I just bought one on eBay and will give my wife the rooted Volt. Problem solved (for us anyway).
 
#24 chuckh1958, Jul 15, 2016
This is really making me wary of buying another android device. Now, along with myself and my husband having trouble with our Volts, one of my sons is having the issue with his Samsung Galaxy Prevail. The other son (also using the Prevail) is not. Not yet, at least. I have told him what to watch for.

So very glad I didn't alter my kindle to use google.
 
#25 Alexxann, Jul 15, 2016