Nexus 5 Forum

General Google search bar not working.

My phone is Nexus 5,this morning when I wanted to search up something on google search bar as usual, it didn't work. I can type in it but when I click search nothing happens, then I tried to long press the home button to see if the search function even works, it did not. so I went to the app management in setting and went to the All section to see if I've disabled it, but I did not disable it. can somebody help me with this please?

Thx.
 

Related:

#1 SamLS, Feb 13, 2015
Clear cache/data for the Chrome app.
 
#2 AMOCO, Feb 13, 2015
how does that have to do with google search bar? I'm talking about the search bar on home screen not in chrome
 
#3 SamLS, Feb 13, 2015
When you try and searched something did the app acted like it was offline even though you were connected to WIFI/data?
 
#4 Incakola, Feb 13, 2015
no. it just.. i mean.. there was nth happened after i press search. chrome is perfectly fine. However the google bar on home screen and long pressing home button doesnt do anything.
 
#5 SamLS, Feb 13, 2015
At one point when you first boot up a ROM for the first time and you do that long press and highlight the circle it would ask you what action do you want to assign to it. If you selected "do nothing" (always) then that's exactly what its gonna do. You may want to look into apps in system app and force close google and clear it's data and cache to get it running first. You may also want to clear all defaults "reset app preferences" on top right menu dots.
 
#6 Incakola, Feb 13, 2015
eh...... how do i do that? o_O
 
#7 SamLS, Feb 13, 2015
First does long pressing the home button show the white circle (lollipop) or magnifying glass (KitKat)
 
#8 Incakola, Feb 13, 2015
like i said, when i long press the home button the circle that used to show up doesnt anymore
 
#9 SamLS, Feb 13, 2015
Are you completely on stock? Like you never softmod it with stuff like using other ROMs? You may need to clear cache if resetting app prefs doesn't work.

First open the "system" app.
Scroll down to "apps"
Open menu button top-right of screen
Select "reset app pref"
Try if the button long presses.
 
#10 Incakola, Feb 13, 2015
wow I'm sorry for being dumb not everyone is good at technology dude. if I was I probably wouldn't be asking question here anyway...

I did that and the circle came back now but the google bar still isn't working what do I do?
 
#11 SamLS, Feb 13, 2015
It's alright guy. At one point I was clueless when I first got a tablet, then I started softmodding it and learn as went.

You'll need to clear the google app's data/cache

1) Go back to the "applications" from system app
2) Side swip to "All" subcategory
3) Look for "Google app" and nothing else
4) select it and select force close and then manage data, select the option at the bottom on the next prompt
5) clear cache and open app manually in app drawer and reconfigured it the way you had it before
6) try if the widget in homescreen works now
 
#12 Incakola, Feb 13, 2015 Last edited: Feb 13, 2015
yes it works now thank you very much.... but now I have to reorganise my home screen now...... it takes so much time...... T^T
 
#13 SamLS, Feb 13, 2015
Like this one? Mine is doing it too. Help! Please!
 
#14 Darcyjwcc, Mar 21, 2015
Try main settings, Apps, All, Google Search and clear data and cache.

If it works remember to go back and reset your preferences.
 
#15 EarlyMon, Mar 21, 2015
Fixed! Thanks!
 
#16 Darcyjwcc, Mar 24, 2015
This happens to me sometimes too. A data and cache reset in the google app always solves it for me.
 
#17 GuitarG20, Mar 24, 2015
My phone is a Samsung Note 4. Thanks for your help. After going to the Google App in "Application Manager" I selected, "Manage storage." I then cleared both the Google Search data and "all data." Now mine works as well. Thanks again.
 
#18 TechnoBob99, Mar 26, 2015