Samsung Galaxy S5 Forum

Support Group messaging problems?

I just got the gs5 today. I love the phone. But there's one thing...group messaging! Its not working for me. I keep getting everyone's messages separately and if i send a group message out, they just get an sms text from me, without the group. Please help
i was able to do this simply on my gs3. At first i thought it was the 4.4 kitkate, but my buddy has a nexus 5 with 4.4 and he can do group messages without a problem.

 

Related:

#1 adrianh90, Apr 11, 2014
The manual says from MESSAGES, select MENU, then SETTINGS.... you can enable "group conversation" in the Multimedia Messages section (right above "auto retrieve")


I haven't gotten my S5 yet but my S3 doesn't have that "group conversation" checkmark.. But.... When composing group messages, you can trick the phone because it treats them like an MMS msg.

So enter your multiple recipients, click on add subject which will convert your SMS into MMS (you can leave it blank btw).. And commence your group convo.
 
#2 mcm180, Apr 12, 2014
Not sure how many you're trying to group message, but I was group messaging today with 2 other folks and I had no problem.

Also on my Galaxy Nexus (my old phone) it didn't like my friend who had a newer phone - so hers would come up in it's own thread.
 
#3 saltyduck, Apr 12, 2014
How is the performance when sending group messages? On my GS4, I use a third party app, like Handcent, Chomp or Go SMS, in order to send group messages it seems and each one of them the performance is horrid. I takes a bit to convert it to MMS to send or even receiving it sometimes slows down the whole phone. I'm not sure if it's because the people I usually group message with are iPhone users, or what.

Is it any better on the GS5? I don't believe the GS4 had that group messaging option either.
 
#4 KupKrazy, Apr 13, 2014
I am not a huge fan of group messaging, but some folks insist on it. I was group (text) messaging with 2 other folks yesterday on the GS5 with no problems
 
#5 saltyduck, Apr 13, 2014
Hey guys,
So normally, in the GS5, you would be able to go to settings, Messages, MMS, and then you would have the option of clicking Group Messaging. Mine did not have one. I contacted t-mobile and they found it odd as well. They told me to contact samsung.
I contacted samsung and they told me to do a factory reset. Much to my surprise, IT WORKED!!
I went back to settings, and ta-da, there it was, the option to turn on or turn off group messages. I do not know why this happened, but I'm glad it's fixed now. And it's pretty fast (unlike the s3) .
 
#6 adrianh90, Apr 14, 2014
I just got a S5 last night and couldn't group text (couldn't find the feature as an optional setting under MMS, tried to factory reset the phone, etc). I contacted Samsung this morning and they told me that Samsung got rid of the group text feature on their S5.

Visitor: does the s5 no longer have the group messaging feature?
Visitor: because I know it works on the s3 and s4
Aiden: Yes, unfortunately the S5 does not have Group Messaging. However, you can use a third party app.
Aiden: We don't have information about third party apps as these apps are not tested on Samsung phones.
Visitor: so samsung got rid of the group messaging feature for their s5?
Aiden: You can contact PlayStore support at 1-855-836-3987 for information about third party apps.
 
#7 lilyoshi12, Apr 18, 2014

hey so whoever told that it doesn't exist anymore is big fat liar. i don't know exactly what the factory reset did for my phone but it works now. They even told me that I must have had a defective phone and to exchange it.
I've attached the screenshots of how you would normally active it(keep in mind that i didn't have this option before i reset the phone). Ive even attatched a screenshot of how the group convo looks in the S5(please excuse the conversation)
 
#8 adrianh90, Apr 18, 2014
i did the factor reset and it didnt work i dont know if i am doing the right or wrong thing can you please help
 
#9 mjuca410, Apr 25, 2014
Hi,

i actually just bought 2 phones from t-mobile. i did a factory reset on mine, to get the group messaging and it worked. i tried it on my moms and it didn't work. i wonder why that happened? :hmmmm:
 
#10 triana_r23, Apr 28, 2014
IMO, if you are going to group text, why not just use Facebook?

I prefer to keep ALL of my text messaging separate.
 
#11 AZgl1500, Apr 28, 2014
I did a factory reset on my phone and the options for group convos came up. BUT if I only get one person's messages in the same screen. The rest of the people come in separate messges.


AHHHHH SOMEONE PLEASE HELP
 
#12 tmhernan, Apr 29, 2014
deleted post...
 
#13 jmatteis, May 11, 2014
So, I thought I didn't have this option, and yet, there it was under multimedia, so I activated it, then sent a test message to my family. It went, and showed being sent as MMS, etc... that part worked, but every single reply I got was in it's own individual message. nothing came back in the original message I sent, like your 4th screen cap. Would it matter that they are all on iPhones... would it matter that I already had individual conversations with some of them going on, as that is where their reply went, into the original text we had shared earlier. Kind of disappointed, I was so excited when I realized that I had the setting already from your post, but I can't get it to replicate the way your message does. Thoughts?

I have been away from Android for 2 years, did it used to work fine on older models, or older versions of Android?
 
#14 jmatteis, May 12, 2014
I finally got this fixed after banging my head against the wall for days! Ok, check it out. My Note 4 (android 4.4.4) has been missing the group text check box and the option was not even there when you go to messages, settings, mms. The problem is not the app or the phone, it's the Sim card. Starting from the home screen, go to apps (bottom right corner ) look for the settings app and click it, now look around for anything that says "About Device" and click it, then click "Status", now scroll down until you see where it says "My Phone Number". If it says "unknown" under it. ..... BAM!! that's your problem. Call your mobile carrier and tell them you need to add your phone number to your Sim card. They can fix this with a couple of clicks. You power off your phone and power it back on and BOOM! The group messaging is working flawlessly, and the check box will be there.
If it still says "unknown" under where your phone number should be, don't worry. ... it may take an hour or so for your Sim card to update. Just restart your phone every hour until your Sim card diplays your phone number in the settings, about device, status, My phone number
 
#15 thornon80, Dec 26, 2014
Both mine and my son's phones are Samsung Galaxy S5 and both transferred from T-mobile to AT&T.
When he was on T-mobile, the group message was working fine (using the default Message app which came with T-mobile/Android). But once I transferred him to AT&T, the same app won't work. So you would think it is problem on AT&T. (I used the same default Message app but never need to do group texting.)
After poking around, I found,

Google Messenger -- could not "send" to group
Go SMS Pro -- works
AT&T Messages -- works

So it seems that the application software is the key. It may also have something to do with the service provider.

I dropped Go SMS Pro as it has annoying promo popups.

So the final solution (free)...

Samsung Galaxy S5 + T-mobile .... use the default Message app
Samsung Galaxy S5 + AT&T ... use the AT&T Messages app
 
#16 surfweballday, Dec 29, 2014
My daughter just received a new SIM and GS4 (under warranty replacement) from AT&T yesterday. She noticed that she wasn't getting Group texts properly. She had no 'Group messaging' option under her messaging settings.

I saw the above messages and checked her phone and saw that her phone number was also listed as 'Unknown' under the Device Status. I contacted AT&T and they fixed/updated her SIM profile. Now the phone number displays correctly and also she now has the option for 'Group Messaging' under her settings again.

Thanks!
 
#17 Charlie Crissman, Dec 31, 2014

I know this is from like a year ago but I am having the EXACT same problem as you (with my galaxy s6) - found group messaging, turned it on... sent group msg to iphones... they get it as single msgs and i get their replies in their single chats... Did you ever figure out why your phone was doing it? I checked under the whole "My phone number" section and my number is in there properly...this is killing me!
 
#18 alemdagr, Apr 23, 2015
This started 3 days ago receiving the error with SMS messages from an iphone6. I'd installed Textra (text app), tried it then switched back to the AT&T app. Just uninstalled Textra (even though the default was AT&T) and it's working normal now. I've never had any issue in a year until now.

Not big on posting, but created an account just now hoping this might help you.
 
#19 Chris J, Jun 15, 2015
I have a Samsung galaxy prevail LTE and one day I sent a group text message. I did not know that every message to those 4 people would keep even if from some one of those 4 would keep being exchanged with every one in that group. I now have some of those 4 people cussing me out telling me to never text them again ever not for anything. I have tried deleting the entire conservations with those four people but I see no way to turn this off. This Samsung Galaxy Prevail LTE is not a feature rich phone and is a big battery hog needing to be plugged into a charger almost constantly. Can anyone help with this group messaging thing. I am using the stock messaging app not hangouts. Also everything is google now. No more hiding from anyone or big brother. Each new smartphone upgrade has gotten worse. Please help.
 
#20 Z Z, Sep 9, 2015
Thank you!!!! Great directions.
 
#21 grebewatcher, Oct 1, 2015
PROBLEM SOLVED! I could find nothing on the internet that would fix the issue with group texts only arriving as download message (that would not download). This was driving me nuts. Spoke to my BIL who has a Samsung 5. He recommended that I download Google Messenger (not Hangouts which can have its own issues) and dump the Samsung Messenger. Problem solved - works perfectly now. FYI - All my texts from the Samsung Messenger moved over to Google Messenger just fine. :)
 
#22 Julie Durand, Dec 27, 2015