Samsung Galaxy S4 Forum

Tips GUIDE: How To Downgrade from Lollipop to Kitkat Version 4.4.2

I had a problem where my Samsung Galaxy S4 (SGH-I337M) was stuck in a boot loop because of the Lollipop 5.0.1 update. I tried everything from going into recovery mode and factory resetting it to doing the smack method on it. Then I found this way by flashing the Android Kitkat 4.4.2 ROM back into my phone via Odin. Here are the steps to downgrade to KitKat 4.4.2:

NOTE: I am not responsible for anything that happens to your phone. please proceed if you know what you are doing.

Before you start:
  • Turn on USB debugging by going to Settings>More>Developer Options. (If you don't have developer options, go to Settings>More>About device and press the build number 5-10 times and developer mode will be enabled)
  • Make sure battery is charged at least 50%
  • Backup everything if you can or make sure you have a backup already done.
  • Have your phone plugged into the computer
After you done those things, you ready to begin. Here is what to do:

1. Download Odin v3.09. You can download it by clicking the link.

2. Download the firmware for your phone. Go to (You will have to create a free account first) and look up your model. (For Example: you will search SGH-I337M if you have a Canadian Galaxy S4). The Model info should be behind the battery. If you don’t know or can’t find it, comment below and I will find it for you. Make sure you have the right carrier as well if it says so.

NOTE: Downloading the firmware may take a while if you have a slow internet connection. If you have a slow internet connection, make sure your computer doesn't sleep overnight while its downloading.

3. Extract both files to your computer.

4. Open Odin v3.09

5. On your Galaxy S4, Turn off your device. When its shut off, press the Power>Hone, and VOLUME DOWN key at the same time. You will see this pop up:[​IMG]
You will press volume up. Then you will see this.

[​IMG] both photos via Google images


5. Open Odin v3.09. Click the AP Button.

[​IMG] via

6. Look for the firmware you downloaded and click open. You will have to wait a bit until the firmware is in Odin. You will know when its finished when you see the file name in the AP box.

7. Click START. You will have to wait as the process takes 5-10 minutes. The phone will reboot once or twice. then the welcome screen should pop up. and you are DONE. You have successful downloaded Android KitKat 4.4.2.




#1 LukeTheTechGuy, May 21, 2015
I tried this and the welcome screen isn't popping up. My phone is stuck on a black screen that says SAMSUNG in white letters that flash blue. Any advice?
#2 alicia123, May 22, 2015
It sounds like you installed it wrong or got the wrong file. Can u tell me what your phone is, country u are in, and carrier plz?

#3 LukeTheTechGuy, May 22, 2015
how would I go about doing this for a Samsung galaxy s4 active? mod# Samsung-sgh-1537, US, AT&T. I hate lollipop it is slow, eats my battery life, and is ugly. plz help.
#4 Madness2189, May 27, 2015
hi i have the samsung galaxy s4 gt i9505 model. carrier is giffgaff which i think is o2 and im in the uk
#5 scottysoftlad, Jul 18, 2015
There is no specific firmware for GiffGaff and so you will need to download and flash the stock Samsung firmware for your model of phone and CSC code as per #1.2, #1.3 and #1.5 of 29 Galaxy S4 models - know yours?
#6 ironass, Jul 18, 2015
do you know or point me in the direction off stock firmware please
#7 scottysoftlad, Jul 18, 2015
They are all stock firmwares. Without your exact, "Version", details, as per my previous post, it is impossible to say which one is for your phone. ;)
#8 ironass, Jul 18, 2015
I know i'm a little late to the game here. And I have NO knowledge of this stuff. but I'm trying to root my phone. I have a SGH-1337 and when I try to find the firmware, it doesn't even have my phone as an option. Any advice?
#9 Lminogi85, Sep 28, 2015
I downloaded the correct firmware and the correct odin version but when I went to try and downgrade it, it failed right at the beginning. What should I do?
#10 champfodayztho, Oct 8, 2015
Back from the dead, but I just tried this (going from Lillipop down to Kitkat) and am at the same point as alicia123 on the black boot screen with the blue flashing SAMSUNG letters. I've got the S4 SGH-I337M, and on the SamMobile site there are 3 listings for my phone: "GALAXY S4 (SGH-I337M)", "GALAXY S4 (SGH-I337M)", and SGH-I337M (GALAXY S4)". I'm pretty sure I downloaded the first one on the list and it got me to where I am now.

Any thoughts on what I did wrong or how to fix it?
#11 Kingowe, Aug 1, 2016
Hello and welcome to Android Forums Kingowe :)

Providing you have downloaded and flashed the correct firmware for your model of phone and version details as per #1.5 of 29 Galaxy S4 models - know yours? then you could try wiping your phone's cache partition in Recovery Mode as per #1.3 of S4 Lollipop Update Problems - Dummies Guide to see if this allows you to boot up correctly.
#12 ironass, Aug 2, 2016
Thanks for the reply ironass! After it was stuck in the SAMSUNG glowing bootloop for about 4 hours, I unplugged my phone and pulled the battery for about minutes. Then I rebooted it and did a factory reset. I wasn't sure what was going to happen because Odin said 4.4.2 had flashed successfully but it didn't look like it was going to work.

Anyway, it ended up working! After I wiped it, I fired it up and it brought me to the factory 4.4.2 software/setting up my phone! Now I've got a stable version of Android (unlike that WORTHLESS Lollipop that would restart my phone at least 5-15 times a day, run it super hot and kill the battery!) and I know not to upgrade.

I hate that Samsung won't support S4 users experiencing problems with Lollipop nor will they push Marshmallow to the S4s, but I'm happy with Kitkat because I know it works!

Thanks again for your help!
#13 Kingowe, Aug 2, 2016