HTC Desire Forum

Root [Guide] S-OFF and ROOT HTC Desire with Revolutionary - Updated

Note: This is a copy of the original guide by Mattb81. I have made this copy purely so that it can be maintained, because Matt is not currently active in this forum. All credit for writing it belongs to Matt, so if you find it helps you please click on this link to the original thread and Thank Matt, not me.

Now over to Matt :):

As many people are saying there isn't a guide for this and I found it quite easy, I thought I'd write a simple one. At the moment I don't have the time to make it too pretty or repeat things which SURoot has already done in other guides, but over time I will edit and improve it.

Revolutionary is not the same as Unrevoked. Revolutionary is more like the successor to Alpharev than the successor to Unrevoked, as Unrevoked roots your phone, while Revolutionary will S-OFF your phone. You then have to root it by running a root zip file in recovery mode.

It's just another way of getting to the end goal of having more options of what you can do with your phone.

Revolutionary will not work for every Desire (currently), but it will work for certain HBoots and is the only way for people who have the "official" HTC Gingerbread Android. Froyo users can also S-OFF and root this way too if you have the right hboot (I did, because Unrevoked didn't work).

Almost everyone should be able to get rooted using either this guide or the Unrevoked guide.

I'm assuming the goal is to root your phone. If you just want to S-OFF and have already rooted, you can ignore most of the sections as you've probably already done them. You can probably just run the Revolutionary software and follow the prompts (Section 5).

For everyone else, follow this:



1) Firstly, sort out your drivers so your PC speaks with your phone: (note usb debugging should always be on). Skip this step if you are using Linux instead of Windows.

a) Download HTC Sync and uninstall (this leaves the drivers behind but not the program which can interfere with things, you can reinstall it after your rooted)
b) Download and install HBoot driver (see Unrevoked guide for the download link and guide)

2) Choose your recovery: (Updated 09/07/2012 - Hadron)

Revolutionary will, if you let it, install a custom recovery for you. However, our experience is that there are better (i.e. more stable) recoveries for the Desire.

The current recommendation in this forum is 4Ext Touch recovery. The normal way of installing this is through an app once you are S-Off and rooted, as described in that thread. However, the first post of the thread also includes direct download links for GSM and CDMA versions of the recovery (just look for the phrase "direct download" in that post). Choose the correct version for your phone, download to your computer, unzip the package and you will find a recovery .img file which you can flash in Step 6 below. There is also an md5 code so that you can check that you have a good download.

Once you have finished rooting you can install the 4Ext app to keep the recovery updated.

If have a GSM device and would prefer one of the older, non-touch recoveries, then you need to check what sort of device you have in order to determine which is compatible:

a) Find out your PVT version: Boot into HBoot (from off, hold vol-down and press power), make note of HBoot version. If PTV4, follow (b) to (d). If not, go to (e)
b) Download Terminal Emulator from the market and open it
c) Type "cat /proc/mtd" and press enter. It will return results of either 20000 or 40000
d) If 40,000 - download Amon-Ra 2.0.1 Recovery (see below section (e)) and store it in a easy to find and access place on your PC (ie C:/ )
e) if 20000 or not ptv4, download your choice of recovery below, either will work.
Amon-Ra 2.0.1 or ClockWorkMod

NOTE: Clockworkmod asks for a username and pw to download. This can be found in the Useful Downloads thread, usually near the last page.

3) Read the [FAQ] ADB and FASTBOOT for Windows

You don't have to necessarily understand it (I didn't until I used it), but just follow the set up instructions.

4) On the Revolutionary page read everything and download the following:

a) Revolutionary zip - save to PC. They will ask for info (currently) on your phone to get a beta key.
b) Root file - place this on your SD card. (there's an older version at: Downloads - Downloading The revolutionary site also has a link to this in their documentation.

I can't express how important it is that you understand what this program does and what you still need to do afterwards. Read everything on the site, especially the FAQ

Now you're ready to go.


5) Run Revolutionary (unzip and run) and follow prompts. Say no to installing their recovery.

Congratulations, you should be S-OFF now. You can check by booting to Hboot and seeing if you have a nice pink "Revolutionary" label above your HBoot info.


6) it's time to install your recovery file.

a) Boot into fastboot mode (from off, volume-up and power or volume-down and power then cycle to fastboot option)
b) Connect phone to PC through USB. You should see "FASTBOOT USB" on your phones screen.
c) Open CMD (Start > Run > type "cmd" and press enter)
d) Type "fastboot flash recovery c:\your recovery file name" where c:\your recovery file name is the exact location and name of the recovery file you downloaded.

You should now have a S-OFF phone with a custom recovery.
If you chose 4Ext (which is my preference), check the "Addendum" at the end of this guide. Do not format system even if it tells you to!


7) Now for rooting:

a) Boot into Hboot (from off, hold vol-down and power) and choose "Recovery" from the menu.

Optional: you may choose to take a backup while in recovery, before the next step. This is insurance - although the risk is low, if anything does go wrong with the next bit you can restore the backup from recovery and the phone is working again. Making a recovery backup ("nandroid") before flashing anything is a good habit to get into.

b) Choose "flash zip from SD card" or similar from Recovery menu (use trackpad to navigate)
c) Choose the Root file you downloaded to your SD card in step 4b.
d) Wait till it says it's done, then choose to reboot.

Congratulations, you're S-OFF and Rooted!


Sometimes a newly-installed 4Ext recovery gets confused and claims it can't read /system, and asks you to format system. Don't do this, as it will erase your ROM. Reboot recovery instead - that usually sorts it out.


#1 Hadron, Jul 9, 2012
Maybe lock the original and redirect users here?
#2 SUroot, Jul 9, 2012
The link in the ATR sticky has been redirected, so I expect that to happen naturally.

But you are right that I've linked to that thread here, so it's perhaps best we lock it anyway.
#3 Hadron, Jul 9, 2012
HELLO, in the original post from matt it says Root file - place this on your SD card but i dont know how to do that and am guessing its something to do with number 3 ? .....I have changed the whole line in variable path to C:\android-sdk-windows\tools and im not sure sure if i was supposed do that ....could you please enlighten me with your word of wisdom. thanks
#4 zimzee, Jul 13, 2012
The root file is to thing you download in part 4b. Just put it on your card as you need it later.
#5 Hadron, Jul 14, 2012
just plug phone into pc, set as disk drive and drag the root file into SD card, or just download the root file directly on your phone browser. You dont need adb for that part.
#6 shauny13, Jul 14, 2012
On the other bit:
You mean you replaced the variable path with that string, rather than add that to the end? If so then no, you definitely weren't supposed to do that, and it could stop a lot of stuff working. I'd advise searching for what should be there (or looking at it in another machine if you have one) - I'm not a Windows user so I can't just tell you what mine is.
#7 Hadron, Jul 14, 2012
guys your going to think im thick but i cant get the command to work it just keeps saying cannot load
#8 zimzee, Jul 14, 2012
still no luck :( i type in adb shell and get a dollar sign thing then switch phone off and go to fastboot usb and type in cmd

fastboot flash recovery C:\Documents and Settings\Gaz\Desktop\recovery-RA_2.0.1.img

but it just says cannot load ??
#9 zimzee, Jul 14, 2012
Any ideas guys ?
#10 zimzee, Jul 14, 2012
What happens if you type "fastboot devices"?
#11 Hadron, Jul 14, 2012
type that instead of flash boot recovery ?? it says SH07BPL02231 fastboot .......

how would i know if it has worked ??
#12 zimzee, Jul 14, 2012
Yes. Tests that fastboot is working correctly. Should return phone's serial number.
#13 Hadron, Jul 14, 2012
so does this mean recovery has worked as my serial number has came back ? ....if so when i go into recovery i just get a red triangle
#14 zimzee, Jul 14, 2012
No, just that fastboot is working. The question then is why it won't load the file (which it seems to find)?

What does your hboot screen say? In particular does it now say "revolutionary" and S-Off? If not you need to run revolutionary again.

Have to go offline now, sorry.
#15 Hadron, Jul 14, 2012
MI CROP-031d
RADIO-5. 11. 05. 27
Aug 10 2010, 17:52:18
#16 zimzee, Jul 14, 2012
OK, so you've got the updated hboot and should have the full set of fastboot commands. Fastboot is working correctly. So what's left is the file you are trying to flash.

The message "cannot load" sounds like it's found the file but can't load it, but I think it must actually mean that it can't find the file. So, we need to make sure the file is really in C:\Documents and Settings\Gaz\Desktop and is really called recovery-RA_2.0.1.img. One common booby trap in Windows is the "hide known file extensions" setting in Windows explorer. If you have that enabled, turn it off to check what the actual filename is, e.g. make sure it isn't called something like recovery-RA_2.0.1.img.img. That often happens if people have renamed a file.

Otherwise, try copying it to the directory the fastboot command is in (or the one you are issuing the command from) to avoid any possible problems with the file path. If you do this the command should just be "fastboot flash recovery recovery-RA_2.0.1.img".
#17 Hadron, Jul 15, 2012
Yes, this is what i always do. then shift and right click together to"open command prompt here" if you are a windows user. ;)
#18 shauny13, Jul 15, 2012
sorry guys but i must be having trouble understanding what to i follow step 3 up to mount /system then type in flash recovery etc etc or do i just open command with out doing any of tht while my phone is in fastboot and then type in the command. THANKS
#19 zimzee, Jul 15, 2012
Just boot into fastboot mode, connect the usb, then type the fastboot commands on your computer. Just like you did for the "fastboot devices" command.

The recent discussion was just about the naming and location of the recovery .img file on your computer, because my best guess is that your computer is not finding the file you are trying to flash.
#20 Hadron, Jul 15, 2012
so what i am doing now has nothing to do with step 3 feeling so dumb right now i have been at this for 3 days, its bumming me out man
#21 zimzee, Jul 15, 2012
What you're doing now is step 6. Step 3 was setting up your PC for this, step 6 is actually using it.
#22 Hadron, Jul 15, 2012
ok thanks for clearing that up and having patience with me. Could you please explain to me how to do this -

Otherwise, try copying it to the directory the fastboot command is in (or the one you are issuing the command from) to avoid any possible problems with the file path. If you do this the command should just be "fastboot flash recovery recovery-RA_2.0.1.img".

i know you might think it is explained but to me its complicated or im making it complicated lol :s
#23 zimzee, Jul 15, 2012
Actually I may have made that more complex than needed. If you followed step 3 exactly, including setting the path, you can run fastboot from any directory (folder in windows terminology - I'm not actually a Windows person). So this might be simpler:

From the command prompt (where you would run fastboot), try

cd C:\Documents and Settings\Gaz\Desktop
fastboot flash recovery recovery-RA_2.0.1.img

The first command sets your current directory to your desktop folder ("cd" = "change directory" in DOS speak). The second is the fastboot command, but because your current directory is now the one the recovery file is in, you don't need to spell out the whole path.

If that doesn't work, then type out the fastboot command partially:

fastboot flash recovery recovery

but then press the tab key rather than the enter key. That should complete the filename (I'm pretty sure this works on Windows too). If it does fill in the filename, then press enter.
#24 Hadron, Jul 15, 2012

Does this help? when i flashed CWM recovery for One X, notice the image file is in the fastboot folder on my c drive. Then i shift right click together and open a command window here and enter your fastboot commands.
#25 shauny13, Jul 15, 2012