LG Optimus L9 Forum

Root [[GUIDE]] Unbrick/Manual Update (UPDATED)

UPDATED: January 22nd

1) Download the v10dkdz or v10ekdz

2) Download LG mobile support tool and Install it. (It will open up when its done just CLOSE IT OFF) https://www.dropbox.com/s/1ckig41xdqoi2u1/B2CAppSetup.exe?dl=0

3) Download / R&D Test tool
https://www.dropbox.com/s/n5nndrdxowmq3yy/UpTestEX_mod2_marwin.exe?dl=0

Power off your phone, press Volume Up & and then plug in the usb cable (enter to a download mode/upgrade mode)

5) Run UpTestEX.exe

6) In R&D Test Tool window,
Select Type = 3GQCT (top left hand side)
PhoneMode = DIAG (top right hand side)
Select kdz file = click to select your LG stock rom *.kdz
Click "Normal web upgrade test" (bottom right hand side)
Then another window will pop up, click "Upgrade Start" button
wait a few seconds, another window "Select Country & Language" pop up,
=> Country=Republic of Korea
=> Language=English
you can click ok to proceed

7) All Done and wait for finish!

VIDEO tutorial:
https://www.youtube.com/watch?v=8muaV-mOrec&feature=youtube_gdata_player

If you changed the hosts file to use offline method previously, you'll have to open up the hosts file using notepad ran as administrator and delete the last two lines you added, save and restart your computer
 

Related:

#1 Swainsmith82, Nov 8, 2013
it worked
i think i bricked it when super su asked to delete stuff
and said yes
 
#2 bryson502, Nov 11, 2013
Be sure to hit thanks!! For the future if you want to root use this superuser by koush it's the only one I use.
https://play.google.com/store/apps/details?id=com.koushikdutta.superuser
 
#3 Swainsmith82, Nov 11, 2013
LG Mobile Support Tool says: Your device has the latest software available from the LG Mobile Support Tool. Please visit LG Support Website for further information on updates.

Phone screen says: S/W Upgrade. Please wait while upgrading....

So I guess my question would be...is something happening or not?
 
#4 droid newb, Nov 19, 2013
There's choice under the support tool options menu located at the top right for "upgrade recovery" select that..
 
#5 Swainsmith82, Nov 19, 2013
Now it's doing something...thanks!!!
 
#6 droid newb, Nov 19, 2013
Let me know how it works out
 
#7 Swainsmith82, Nov 19, 2013
I think it worked!!!

My phone is currently booted up & scanning the SD media. I haven't see even ONE LGSystemServer error message, and that used to happen constantly when I'd reboot my phone!!!

I can also see that the icons for my apps on the SD card are messed up, meaning I'm no longer rooted & no longer have access to them. So once I'm up & running I'll re-root & modify the build prop.

It doesn't appear I lost any data either!

I CAN'T THANK YOU ENOUGH FOR THIS!!!!!!!!!!!
 
#8 droid newb, Nov 19, 2013
Awesome!!
 
#9 Swainsmith82, Nov 19, 2013
I would encourage installing the recovery for stock locked and make a backup as soon as you install it. This way should anything ever go wrong again you can just restore it.

http://androidforums.com/optimus-l9-all-things-root/791293-guide-recovery-stock-l9-locked-bl.html
 
#10 Swainsmith82, Nov 19, 2013
Nice job on this tool! Really helps if anyone gets in a jam.

Thanks for sharing. :)
 
#11 Granite1, Nov 20, 2013
i downloaded the link but i can not get the app to work, when i click the icon a pop up says the uprgade s/w is already running
 
#12 mike7djent, Nov 26, 2013
Which icon? Don't connect the phone until you open the app on your pc.
 
#13 Swainsmith82, Nov 26, 2013
Ah! Swain to the rescue!!!
 
#14 Tokenpoke, Nov 26, 2013
seems like its stuck downloading software, i let it set like this for 30-40 minuets anyone got any ides ?

Ive tried upgrade recovery and upgrade options and its the same.
 
#15 stitan, Dec 1, 2013
Try restarting it. It could be your Internet connection
 
#16 Swainsmith82, Dec 1, 2013
Tried restarting program , PC ,phone
I uninstalled lg tool installed it back .
Could be my internet , should there be a status bar while downloading ? Does that screen look correct ?

I'm just trying to get back to stock do you have a cwm back up I can restore ?
 
#17 stitan, Dec 1, 2013
You can use the v10b backup from this site but it is rooted..

[V20E JB]Collection of NANDROID (CWM) BACKUPS for all Rooted L9 Variants - xda-developers
 
#18 Swainsmith82, Dec 1, 2013
As far as the update tool goes I'm not sure the only conclusion I can draw is your Internet is slow or acting up..
 
#19 Swainsmith82, Dec 1, 2013
Thanks , ill let it go for a bit and see what happens.
 
#20 stitan, Dec 1, 2013
I tried to unbrick but lg tool keeps freezing after I conect my phone and run the first download with the phone conected. so dose the phone. the screen stops moving indicating or implying that the phone is freezing. The lg tool does not say none responsive but it just stops doing anything and it stays at 15% of something. Is this normal? what should I do leave my phone alone and see if it will work after a min. or is there something I might have forgot to do or over looked? I know this is a little vague but I have very limited time with a computer because mine crashed. Sorry, but I can use a little help on this Im not the best at this stuff
.
 
#21 antdogac, Dec 2, 2013
What did you do to brick it? Try to hard reset your phone then try it again..
 
#22 Swainsmith82, Dec 2, 2013
I did that as soon as security error first came up. I tryed to flash a rom with out unlocking the bootloader. I thought I unlocked it but I didnt know I needed an internet conection for that.
 
#23 antdogac, Dec 2, 2013
Ill headreset then try it again. So the phone or the computer shouldnt freeze like that during the process?
 
#24 antdogac, Dec 2, 2013
No it shouldn't.
 
#25 Swainsmith82, Dec 2, 2013