Home Forum

Support Had to Go to the Doctor

The thread on Tweaks and fixes is closed. Thought I would post a summary here relevant to resurrecting a TP that wouldn't boot as someone else may be late to the party.

The TPs are excellent devices. Purchased a TP 16GB w/WiFi only model that was stuck on the white triangle www.palm.com/ROM screen.

I suspected I had to run WebOS Doctor because the file structure of the internal storage was probably corrupt.

1). I acquired WebOS Doctor from here (I downloaded the 3.0.5 .JAR file for my model)
WebOS Doctor Versions - WebOS Internals

2). I ran WebOS Doctor and used this for general reference:
How to use the webOS Doctor on the TouchPad - HP Support Forum - 2186473

3). I ran up against the restore process failing to proceed past 12%. I read up on the posts here and performed the command:
dosfsck -r /dev/mapper/store-media
inside of a Novaterm session.
WebOS Doctor - 12% Issue - Fixed!!! - webOS Nation Forums

4). I installed the Novacom drivers from information here, but also, I used this to install CM:
How to install Android 4.0 or later on the HP TouchPad (CyanogenMod) - Liliputing

Enjoy.
 

Related:

#1 stef7, Jan 14, 2014
Anyone contemplating running DR with a custom rom installed (CM7, 9, 10, 11, etc) should run AcmeUninstall first to remove the rom before running DR. It's possible that's what caused the failing at 12%.
 
#2 colchiro, Jan 14, 2014
You had to be able to boot to WebOS Recovery by holding the power + volume up to get the big white USB symbol to be able to run WebOS Doctor. Since you can boot to WebOS Recovery, you should always run ACMEUninstaller first as Colchiro suggests.
 
#3 Nevertells, Jan 14, 2014
Thanks. Oh, I guess I goofed then. :) Was just trying to lay down a few crumbs for someone else coming by here looking for help. It's bad when you give the wrong or incomplete advice.

My bad.

Hey, I was going to format the whole file system, but luckily there weren't too many errors... Would that have been dangerous?

I guess I didn't really know what to do first. I suppose that information is available here somewhere, but I couldn't find it. :thinking:
 
#4 stef7, Jan 15, 2014
Hey, between the three of us, it's all good. :)

Format the whole file system how? It could be dangerous depending on how you do it.

The fact that the TouchPad would not boot WebOS indicated the need for the Doctor. If the TP still had Android on it is probably why it failed at 12%.
 
#5 Nevertells, Jan 15, 2014