HTC Rezound Forum

Root how do i give an app super user premission?

so im trying to get 'ad-free' to work and super user keeps denying it premission.

i set super user to automatically allow permissions. webkey and all the other apps that need SU haven't been a problem. its only this one.

so, have you guys tried ad free? does it work? and how do i force super user to give an app permission?
 

Related:

#1 pirate943, Feb 16, 2012
so i assume your rooted and unlocked?
 
#2 trophynuts, Feb 17, 2012

yes sir. i only have a few apps that need root and unlock, and those had no problems getting super user permission. i was promoted with a window asking if i would like to grant permission or not...with ad free i didnt get a prompt
 
#3 pirate943, Feb 17, 2012
Yes, works fine.

If you block it on accident the first time, then it's blocked ever time after. Just go into the super user app and look through the list of apps asking for permission. You can allow there or clear that app.then turn on ad free again and you should get the root access request again.
 
#4 IzelTokatl, Feb 18, 2012
Moving thread to HTC Rezound All Things Root section.
Reason: Thread is a root specific topic. You'll get additional feedback in there.

Thanks for understanding. :)
 
#5 trophynuts, Feb 18, 2012

where can i allow it? i go into the superuser, and it has a list of apps that have permission, and a log of which apps were allowed and not allowed...i dont see an option to add an app to the allow list

also, i never blocked it. it was automatically denied for some reason
 
#6 pirate943, Feb 18, 2012
try uninstalling and reinstalling ad free.
 
#7 trophynuts, Feb 18, 2012

tried it. i also tried another blocker app...same results, automatically gets denied with out prompting me
 
#8 pirate943, Feb 19, 2012
hmmmm... maybe try contacting one of the devs of one of the apps?

sorry i'm not much help man but i'm drawing a blank.
 
#9 trophynuts, Feb 20, 2012
Clear the super user app data.
 
#10 pwned, Feb 20, 2012
Brilliant idea. I had a similar problem and this fixed it for me. Cheers.
 
#11 ou7shined, Jul 24, 2012