Home Forum

Support How do you explore internal memory android lollipop, cynanogenmod 12

Hi guys I have a bit of a dilemma on my hands...

... The incident is that when I wanted to move a zip file onto my SD card I put my SD card into my card reader and then my computer did not read it and so I tried to take it out of my card reader and it got jammed in the card reader so I did (stupidly...) Tried to force it out with my teeth and I tried a few times and it just snapped and I can't seem to access my cat pictures or my personal stuff and when I download a file using ADM it just said "sd-card blocked for write" so is their any way to use internal memory on my phone

P.S: do not suggest anything from google play because it force closes itself every time I install an app.
 

Related:

#1 mattwhite43432, Oct 6, 2015
I understood it up to your breaking the sd card, but the post went very unclear after that. Can you explain more clearly what you are trying to do, how you are trying to do it, what the state of the phone is and what model it is?

To give an example, ADM to me means "Android Device Manager", which isn't a way of downloading files.
 
#2 Hadron, Oct 7, 2015
I got an app to storage my contacts in the cloud.
 
#3 IRULUTechnology, Oct 7, 2015
ADM means advanced download manager

I can't even take screenshots or put .apk files on internal memory!!!!

My phone is a zte open C it was Firefox os but I installed cynanogenmod 12 on it and also I tried mkdir in terminal emulator but it said read-only file system and A parted off Google play (got it working again...)

(But its force closing again...

Woopee :-(

I hope I got as much detail as possible and I hope you find a fix...
 
#4 mattwhite43432, Oct 7, 2015
If the card is physically damaged e.g. "snapped" then there is no way to recover the contents. It's toast, sorry. I don't understand why the internal storage isn't being used when external isn't available; if no microSD card is detected it should default to internal.

That's nice, but it doesn't really solve the OP's problem.
 
#5 Slug, Oct 7, 2015
I don't know either ill just keep on searching on google and if I can't find a tutorial I'll just buy one for £6 at morrisons...
 
#6 mattwhite43432, Oct 7, 2015
So you can see files in the internal storage (/sdcard, the user-accessible bit that pretends to be an SD, also known as /storage/emulated/0 and several other synonyms besides), just can't write to it? It sounds like you've somehow got the device mounted read-only. I can't see how that would have anything to do with your broken removable card though, as it's a different filesystem. Did this problem only start when you removed the SD card, or did you have problems before then (e.g. not being able to install anything from the Play Store)?

Could you try typing the command "mount" (with no parameters, just that word) in a terminal emulator and posting any lines of the output that include "ro" in them? I'd suggest screenshots, but am assuming you can't save those right now.
 
#7 Hadron, Oct 7, 2015
I tried typing in on terminal emulator "mount -o rw,remount /mnt/sdcard" BUT it just shows me what the mount does.

I did not have a sdcard directory after my SD card snapped it seemed root browser wants to add a sdcard directory after this happened.
 
#8 mattwhite43432, Oct 7, 2015
Do you have it set up with some weird, non-standard file structure where /sdcard is the actual sd card (the sort of thing that was common in 2010, but disappeared shortly after that when manufacturers started putting more than a few hundred MB of storage in the phone)?
 
#9 Hadron, Oct 8, 2015
sorry for the extremely loooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooong reply i was busy with college, i just got a new 16GB sdcard for £15 ($19.39) so im happy now and i dont need this thread anymore
 
#10 mattwhite43432, Aug 12, 2017