Home Forum

How to clear missed call (1) notification on my phone icon?

I have "1" on my phone icon on the home screen. I know it stands for a missed call. I also know for what call it is displayed. But ever since I did view that call in the call log. i also answered back from that log. I also messaged that call but the missed call wouldn't go away from the phone icon.

please help.

 

Related:

#1 bondowen, Jul 3, 2012
go to call log and delete all history.
 
#2 blaxican25, Jul 3, 2012
I had the same problem with mine. I would constantly see the icon on the top left corner. It would go away, but come back every time I powered up my phone. I actually had to pull down the top panel and click on the notification. Simply going to my logs only temporarily solved the problem.
 
#3 CleanFlow, Jul 3, 2012
Tried that but it didnt work...
 
#4 bondowen, Jul 3, 2012
blaxican25....I tired what you suggested but to no avail.....
 
#5 bondowen, Jul 3, 2012
Anyone else think of something on this issue....
 
#6 bondowen, Jul 4, 2012
What launcher are you using? if it is GO launcher, this bug frequently happens...just restart your launcher will do...but if it is your stock launcher, you can reboot your phone...same reason: a bug...:)
 
#7 Ryuinferno, Jul 4, 2012
probably a bug. But maybe you nee to check for recorded messages too?
 
#8 Shinji01, Jul 4, 2012
Whats a recorded message?
 
#9 bondowen, Jul 5, 2012
Voicemail i think...
 
#10 Ryuinferno, Jul 5, 2012
Q: How do I clear my notification bar?
A: Pull down the notification bar using a top to bottom finger swipe (like a windows shade), then hit the clear notifications soft button.
 
#11 mhgn, Jul 5, 2012
I tried all the usual and obvious options.but no luck yet
 
#12 bondowen, Jul 6, 2012
What phone and launcher are you using?
 
#13 sdrawkcab25, Jul 6, 2012
Call your phone and leave a new voicemail. Then log in and delete it. Work?
 
#14 turbotrauma, Jul 6, 2012
Voice mail is not supported by the operator in my country and we don't use voice mail on phones.
 
#15 bondowen, Jul 8, 2012
I don't have any phone launchers installed. I user Samsung's default ICS launcher that came from the factory.
 
#16 bondowen, Jul 8, 2012
Worse comes to wrost...try to find the launcher system app detail in manage applications (inside settings)...then clear app data...your home screen settings will be reset though...
 
#17 Ryuinferno, Jul 8, 2012
That sucks.
 
#18 turbotrauma, Jul 9, 2012
bondowen same case goes with me and yes turbotrauma thats really sucks :p
 
#19 chrisluger2012, Jul 10, 2012
chrisluger2012, are you still facing this problem. My last resort is to do a factory boot but thats painful...
 
#20 bondowen, Jul 11, 2012
Go to Settings > Application Manager > All applications (on the top). Locate the "BadgeProvider" app, once in there select "clear data" then restart your phone
 
#21 oshoamy, Oct 3, 2012
Thanks oshoamy, I had the same notification problem quoted in this thread. Tried all the suggested solutions but without success. Followed yours and that seems to have done the job. Cheers!
 
#22 weephillie, Oct 4, 2012
Thank You. This solved my problem, I tried deleting my Call History but didn't work, but when I tried yours work fine.

Thanl You again.

SGS III 4.0.4
 
#23 abusraaj, Oct 30, 2012
Thank you, oshoamy! I love you, man! :)
 
#24 MPushevska, Nov 25, 2012
I have quite the opposite problem: the badge disappears when I enter Logs. Until then it is displayed in the notification bar but when entering logs it is automatically cleared from logs too. If I have several missed calls I cannot tell witch number had X missed calles because they are not shown.
I think that this is called by a 3rd party app. I have installed several dialers but now they are all uninstalled. In messages badge notification is displayed normally.
 
#25 abrash, Apr 17, 2013