Home Forum

How to clear "Voicemail Pending" icon in notification bar?

I have this annoying "voicemail pending" in my notification bar that will not go away. When I pull down the notification bar it says "Voicemail Pending. Tap ehere to call Voicemail. Sat, July 24, 2010."

I tap it, it calls my voicemail, but it says I have no voicemail. The notification doesn't go away.

Is there a way to "force" this notification to go away?

I have a Sprint HTC Hero.

THanks,
-v

 

Related:

#1 Vesbon, Sep 2, 2010
when you pull down your notification bar down, do you not have a 'clear' button on the top right?
 
#2 EmoTonyB, Sep 3, 2010
I've not seen the clear get rid of the notification w/ MotoDroid, I have to call in to get the message & if I forget to delete it before hanging up, the notification stays until I go back play the voicemail again the hit "7" to delete it. That's the only way to get rid of them for Verizon.
 
#3 cyn, Sep 3, 2010
Were you able to clear the annoying alert? I am having the same issue and cannot clear it.
 
#4 shlackey, Feb 6, 2011
i had that too on my phone the other day. I use google voice as my voicemail so I just uninstalled the sprint voicemail app with Titanium backup. Got rid of the notification
 
#5 karnoff, Feb 6, 2011
This worked for me (on Sprint):

Call yourself and leave a message (or have someone call you). Listen to the message via the "pending voicemail" link. The icon will disappear (it takes a few minutes after the deletion, but it's gone!).

Julia
 
#6 jmflint, Feb 7, 2011
THIS 100% WORKS!! and its completly easy. (HTC Hero)
Go to your settings, then go to applications, then go to manage applications, then scroll all the way down to voicmail, tap voicemail, then scroll down to force stop. Then tap force stop, and the icon goes away. It temporaraly stops your voicemail, but once you tap on the voicmail app, it starts again without the icon. :) www.olivia-knowstechnology.blogspot.com
 
#7 iOlivia10, Feb 13, 2011
Thanks iOlivia10! - Your suggestion was the one that finally worked. ;)
 
#8 CatCrazy, Jul 19, 2011
Thanks Olivia...on point!:)

 
#9 ramruth, Aug 4, 2011
YESSSSSSSS!! Thank you iOlivia10 this worked!
THIS 100% WORKS!! and its completly easy. (HTC Hero)
Go to your settings, then go to applications, then go to manage applications, then scroll all the way down to voicmail, tap voicemail, then scroll down to force stop. Then tap force stop, and the icon goes away. It temporaraly stops your voicemail, but once you tap on the voicmail app, it starts again without the icon. :) www.olivia-knowstechnology.blogspot.com
 
#10 shirljennings, Aug 15, 2011
You can clear that notification more easily and without stopping the service:

- Settings
- Call
- Clear voicemail notification
 
#11 Tangent, Aug 15, 2011
Thanks Olivia, that worked!
 
#12 Zenkai76, Mar 16, 2012
Tangent, that option is not on my CM7 phone, so that may not work for everyone.

I'm going to provide another option for those that don't have a "Voicemail" app in their "All" app list (like me on my custom CM7 rom). Plus there's an extra bonus for those running ICS. This is more of a direct fix, anyways.

Check out Visual Voicemail Plus by PhoneFusion. I found a setting in the app under "Notifications and Sound", called "Ignore carrier voicemail". Also, you can disable "SDCard not found" notifications and enable a "Disable space warning" option, for those who hate the ICS "storage space low" warnings.

The "Plus" version is free to use, but it does require registration. Just use a secondary email for ads. You don't need to purchase. I believe you can even uninstall the app after changing these settings. I think they access hidden, built-in Android settings that the Settings app sometimes isn't configured to show. But I could be wrong.

Also, it doesn't require root.
 
#13 Drakonas, Feb 20, 2013