Home Forum

Root How to manually update to KITKAT on the Boost Max and keep root and custom recovery

All credit goes to SuperR(for the deodexed rom and partition zip), and cooldudezach(for philztouch recovery port) who did the work, i just tested for SuperR. Do not flash this unless you own the ZTE Boost Max!!!

First, if you are on the ICS software for the Boost max, make sure you are rooted. I used root master for this.(http://www.mgyun.com/en/getvroot) People have said that kingo works for them, do a google search.

Second, Once rooted you will want to head to the play store to get an app called flashify (https://play.google.com/store/apps/details?id=com.cgollner.flashify&hl=en), then head over here (http://d-h.st/I6A) to get philz touch recovery. I take no credit for this. Use flashify to flash the recovery image, you will have to unzip the zip file to get it (to do this, get a file explorer like es file explorer (https://play.google.com/store/apps/details?id=com.estrongs.android.pop&hl=en), open the zip file with it, long press the recovery image and click extract), and then click flash more. You will not be flashing anything else through this app, but you need time to get some more files.

Third, go here (https://s.basketbuild.com/filedl/devs?dev=SuperR&dl=SuperR/ZTE/Max/stormer_stock_B06_deodexed_1b.zip) and grab the kitkat update that is been deodexed by SuperR and put it on your sd card. Next go here (https://s.basketbuild.com/filedl/de...rR/ZTE/Max/stormer_stock_B06_partitions_2.zip) and get the new partition script, also put on your sd card.

SuperR said-"I won't have time to create the new thread until later, but here is the deodexed ROM and the partition updater for those who have not updated to 4.4.2 yet. Flash the ROM first, then the partition updater.

If you have already updated to 4.4.2, you only need to flash the ROM.


Almost done now. So to go from the quote above, Shut down your phone. Now hold volume down and power at the same time till your screen comes on, when it does let go of the power button, but keep holding volume down till your recovery loads. Once into recovery, you can either use your volume keys to go up or down and the camera button to select, or just touch the option, but you need to select backup/restore. Then select backup to sd card1. this is your external sd card. Let it finish backing up before you do anything else. Now press go back till you are on the first screen. Select wipe data/factory reset, then clean to install a new rom, then yes. this will take a few minutes to complete, but it will finish. Now select install zip, then choose zip from storage/sdcard1. Select the deodexed rom first, then click yes, let it finish flashing, then choose the same path as before(choose zip from storage/sdcard1) and flash the partition zip file. You should now be okay to click go back and reboot to system. You should now be on the kitkat update for the Boost Max.

Please do not blame me if this makes your phone explode(<---this is a joke, your phone should not explode), this is just basic instruction to help you update and keep root. If SuperR wants to correct me on anything listen to what he has to say, i only did this to try and save him time.
 

Related:

#1 theminor19, Jan 14, 2015 Last edited: Jan 17, 2015
I will eventually make a thread for the stock roms, but thanks for posting this in the meantime :)
 
#2 SuperR, Jan 14, 2015
Thanks for the tutorial. Ill try this on the weekend. I was worried seems trying to root after kitkat update unrooted is a hassle. Hope this process goes smoothly because i just bought my boost max the day after Christmas and rooted than partitioned sd card using link2SD than overclocked and deleted bloatware, etc etc. So it almost seems all the work ive done on 4.1.2 was for nothing.

But one thing im still up in the air about is rooting on 4.4.2. Kitkat or going with the superrom v2.7 route that has 4.4 features. What do you suggest
 
#3 MustangLife, Jan 15, 2015
The superRom is still based off of 4.1.2, the actual update has more of the features I think. I don't know if the superRom will prompt you to update to KitKat or not.
 
#4 theminor19, Jan 15, 2015
I used the method listed in the original post to update my phone. The update worked, I still have root and am running 4.4.2. My only problem is that I cannot open the security settings. Everything else works well, but when I try to open settings -> security I get the message "Unfortunately settings has stopped." So far I have tried wiping the cache in recovery, wiping the dalvick cache, re-flashing using the same directions, and fixing permissions using root toolbox. I have also booted into safe mode and security force closes settings there as well. Any ideas on how to fix this?
 
#5 deadhead25313, Jan 15, 2015
Guys, a couple questions before i do this. I have a partitioned sd card and running link2sd. Do i need to unlink all apps saved on external sd card ? Also do i need to remove/copy everything else saved on external sd card before i go this route? I cant pull the trigger til someone tells me what i need to do with link2sd stuff. With the apps that are linked internal data is still on internal memory and everything else is on my sdcard. I am backed up with titanium with the backup on the external sd also. Is that backup even helpful when flashing a new rom?
 
#6 MustangLife, Jan 15, 2015
Did you flash the partition updater? Another user said they got an error when flashing it. That may be the problem.
 
#7 SuperR, Jan 16, 2015
Quick question when I click to download the two zips the website automatically starts a download amd shows the download in the same web browser window. But is it automatically saving to the external sd since the zips need to be on the external sd. I went ahead and canceled the download to wait on a answer. Or do I need to download from a pc and just copy the zips to my external sd card. I'm fixing to pull the trigger now that I found out with link2sd I can remount links, etc after a rom update
 
#8 MustangLife, Jan 16, 2015
Yes, I did flash the partition editor. I received this error message.

assert failed: apply_patch_check("EMMC:/dev/block/platform/msm_sdcc.1/by-name/boot: xxxxxxxxx)
E: Error in /storage/sdcard1/stormer_stock_B06_partitions.zip
(Status 7)
Installation aborted

The x's in the error are a very long string of numbers and letters. After the first attempt with this result I tried to redownload the file thinking there might have been an issue with my download the first time, but the next try gave me the same results.
 
#9 deadhead25313, Jan 16, 2015
I'm not able to get Philz Recovery to come up. I installed it with Flashify and after powering off the phone. I hold buttons volume down and power. When the image pops up I let go of Power. But the android recovery is what pops up. Not the Philz recovery. Also when installing the philz recovery with flashify it gives you two options CWM or TWRP or Philz. Just 2 options but I thought Philz was a modded CWM so doesn't make sense TWRP is thrown into the same option as Philz.

Android recovery doesn't give an option to backup/restore. Just the other options but I didn't want to do the wipe data/factory reset option before the backup.

Any help is appreciated.

To add in Flashify under recent zip files it reads .... philztouch6.19.2-stormer.zip /sdcard/download

After I using flashify clicking on philz it says flash complete and I choose flash more. Under the command queue in flashify there is a white box reading ...

install
philztouch6.19.2-stormer.zip


the only options I have in the recovery mode are
reboot system now
apply update from adb
wipe data/factory reset
wipe cache partition
apply update from external storage
apply update from cache
md5 check

I just don't wanna lose my root updating to kitkat. Please help
 
#10 MustangLife, Jan 16, 2015 Last edited: Jan 16, 2015
For those of you who dont care for root(LOL) if you are all stock and no root but want the update and havent recieved it yet, here it is for download: Dropbox- https://www.dropbox.com/s/b6x4qtfsk...20_KKV1.0.0B10_GOTA_JB_B14_TO_KK_B10.zip?dl=0
And for back up in case the first one goes down: Mediafire- https://www.mediafire.com/?i849l45bmmzuf7q
This is gonna be a quick setup guide for the virtual machine called virtual box. Here is the download link for Virtual box: http://dlc-cdn.sun.com/virtualbox/4.3.20/VirtualBox-4.3.20-96997-Win.exe
The unbrick tool: https://www.androidfilehost.com/?fid=23329332407579714
Here is the adb driver i used in this set up because windows needs to see the device as adb able: http://www.koushikdutta.com/post/universal-adb-driver
Superuser: https://s.basketbuild.com/filedl/devs?dev=SuperR&dl=SuperR/ZTE/warp4G/UPDATE-SuperSU-v2.16.zip
And finally philz recover: http://d-h.st/I6A (make sure you click the bottom download link on this page, the top one sends you to an ad)

After you download the virtualbox.exe , go ahead and install it, i left all the settings alone. Start up virtual machine.PNG
This is what it should look like after you install it. Next you will want to click new.
New machine set up.PNG
I named the machine Unbrick tool for the sake of this guide. Choose linux as the top option and oracle 32 as the bottom. Again after setting those 2 options i left all the other settings alone for setting this up so just keep clicking next and you should be fine. Note- This is what worked for me. You should wind up with it looking like this now.
New machine up.PNG
Now click start and you will get a new window pop up.
New pop up.PNG
You will want to click the folder option i highlighted in the picture above. this opens a file finder, now just go to your unbrick tool download location and select the iso. it should now look like this.
Selected unbrick tool.PNG
Now click start.You will get an option screen, just choose the top one by pressing enter. On the computer i was using i got a popup for sound, it is not needed for this but for the programs sake just choose either one.
soundcard.PNG
Your virtual machine should now be booted and look like this.
booted.PNG
Click open the folder with the lable my documents, go to the folder in that called ZTE unbrick tool, inside that folder right click the partions folder and left click the open in terminal. terminal.PNG
Type the following in the terminal:
adb reboot bootloader (Here you may have to right click on the little usb icon and selected the zte option)
usb icon.PNG
(you will need to accept something on the device at this point or it will say the device is unauthorized)- thius will be a usb debugging athorization window, click always allow and then accept.

Once you are in bootloader type:
fastboot boot stormer_mmcblk0p16_recovery.img (again after you type this you will have to right click the usb icon i showed above and choose the zte option or you phone will just hang in the black screen (ie. the boot loader) waiting for a command)
(this will boot your device into PhilZ recovery. It will not install it, just boot to it. You will have the ability to use it as normal until you reboot)
Now i assume you will all know how to use recovery, flash your recover.zip (if you are following this guide it will be the philz recovery) and flash the superuser.zip. This will give you recovery and root back after you have used the ota update to upgrade your phone. Hope this helps anyone having trouble with the usb/cd live option. I take no responsibility for any harm this may cause you (ie. explding phone syndrom, catching your house on fire, and any freak acts of nature) Enjoy :)
 
#11 theminor19, Jan 16, 2015 Last edited: Jan 16, 2015
Since I wasn't able to fix the issue that I was having with the security settings, I flashed the 4.1.2 stock rom without root and the stock recovery. I then did the OTA update to 4.4.2. I can now access the security settings without any issues.
 
#12 deadhead25313, Jan 16, 2015
Alright you should be able to follow the guide here to root
 
#13 theminor19, Jan 16, 2015
I found the problem with the partition updater. It is fixed now. Here is a link to the new on.

stormer_stock_B06_partitions_2.zip
 
#14 SuperR, Jan 16, 2015
"theminor19"

Your setup guide is only with ota update or can i still use this guide and super's deoxed rom and partition updater and go that route. Cause for the life of me i cant get Philz recovery to work flashify
 
#15 MustangLife, Jan 16, 2015
The top guide would be before ota update. The one with pictures would be after, though you could use it to get recovery before you updated too. Just follow the directions, and once you get recovery to boot with fastboot, you would need to flash recovery so it would stay permanently.
 
#16 theminor19, Jan 16, 2015
Also before you go about doing the guide, I want to make sure I was clear on something, do not try flashing the zip file through flashify. You want to grab the recovery image from within that file and flash only the recovery file with flashify. By that I mean get a file browser like es file manager, extract the files, then use flashify option flash recovery image, manually locate the location where you extracted the file. Not sure I was clear in the first post, so just want to make sure your not having an issue because I wasn't clear
 
#17 theminor19, Jan 16, 2015
Oh ok. Thanks for clearing that up. I was dumbfounded when i tried it. So to clear things up. So if we are on 4.1.2 and rooted we could use both techniques to update and keep root. Because both techniques boot into philz recovery, correct. Im not worried about keeping the recovery anywhere near as much as i am of loosing root since rooting kitkat seems like a task of all tasks.

Flashify free version only allows you 3 flashes every 24s or every 2 days. So im still waiting. Ive never used es file explorer. Does it unzip/extract files? Can you post the actual recovery image i need to flash with flashify? And in the top guide it says its for using the downloaded rom and partition from superr but a few posts above you say its for OTA update. Im making sure in case i have to update OTA so i wont have to re root that crazy way.

I got phone to boot into Philz Recovery finally. But one question in your original post. You say back up to SD Card1. But in Philz Recovery you have the option to backup to external sd card or backup to storage/sdcard1 . So which one is it or does it not matter and what is the difference. I'm backing up right now to storage/sdcard1 since you did say choose sdcard1 and not backup to external sd card. That's a little confusing
 
#18 MustangLife, Jan 17, 2015 Last edited: Jan 17, 2015
I was able to get 4.4.2 installed using the original method and SuperR's deodexed and debloated rom and partition updater and keep root but there is a problem. Security settings crashes???? I used the newer updated zip that SuperR posted. Aside from that issue I wanna thank all parties involved. There is no other technical help for these phones unless in general android help. Thanks for the development and tutorials. Now lets get my security settings back.
 
#19 MustangLife, Jan 17, 2015
what i meant was that the top guide was to be used before you did the update, because none of the 1-click root methods work after the update to 4.4.2. The bottom guide with the pictures is meant for after the update, because since none of the 1-click root methods work, it will be the only way to get root and recovery back unless you flashed the rom and partition update before you got the ota update. I hope this clears things up.
 
#20 theminor19, Jan 17, 2015
And to answer the other question that i over looked about the recovery, when i clicked external sd in the backup option in philz recovery it backuped to theinternal memery, so i did sdcard1, and thats what put it on my external sd card, so i dont know why it does that, or even if its just my phone that does it, but thats what worked for me.
 
#21 theminor19, Jan 17, 2015
For me this did not fix the problem. I still cannot download the stormer_stock_B06_partitions_2.zip file at all. When I attempt to download the file I get the following error:

Forbidden
You don't have permission to access /uploads/devs/SuperR/ZTE/Max/stormer_stock_B06_partitions_2.zip on this server.

Apache/2.2.15 (CentOS) Server at s.basketbuild.com

Can you, or anyone else, please make a mirror link for this file? I have no issue downloading any of your other files on the same server.
Cannot wait to get KitKat working, Boost still hasn't pushed the OTA update to my area yet, but I am so close I can taste it thanks to you guys.

It is all of the phones for some reason the phone itself has internal and external sdcard options and the actual removable sd card is called sdcard1.

Thanks in advance SuperR, and friends, for being the only ones to share your work on the updates with the Stormer!
 
#22 Oresu, Jan 17, 2015 Last edited: Jan 17, 2015
Here is another mirror for the partition updater
stormer_stock_B06_partitions_2.zip
 
#23 SuperR, Jan 17, 2015
What do I do since security settings force closes. If I try to clear any app data the phone automatically reboots. Yes I did flash the partition updater.SuperR ? Theminor19?
 
#24 MustangLife, Jan 17, 2015 Last edited: Jan 17, 2015
I hope the security in settings and the ability to uninstall apps gets fixed in the Kit Kat root version. I returned to 4.1.2 Jelly Bean and the funny thing is its not telling me there is an update anymore like it did before I flashed the rom and SD partition. I wonder why theres no notification alerting me anymore of a system update?
 
#25 himynameizrob, Jan 17, 2015