Home Forum

Root How to Root Any Android Device Manually

This is not my tutorial and i have not tested this on my phone so please dont ask me for troubleshooting
the link of the original poster is given at the end of the post and all credit goes to him. I am just posting here so that fellow members can make use of this tutorial

Requirements and rooting process

  • Your pitiable unrooted Android device
  • ADB drivers for your device installed on your pc (I used WinXP. You may use Win 7/Vista or the Linux distro of your choice)
  • su, busybox, Superuser.apk
  • A working linux distro with Nautilus (I used a live usb stick of Ubuntu 11.04)
  • Strength, courage and whatever makes you a man according to Emerson.

Rooting Process

To start, you must have adb installed on the OS of your choice.
I used my trusty WinXP system.

To confirm your device is properly detected, in the command prompt, run
adb devices
Now copy busybox, su, superuser.apk to /data/local/tmp/ using adb.

adb push busybox /data/local/tmp adb push su /data/local/tmp adb push Superuser.apk /data/local/tmp

Now run adb shell

adb shell
Note that you see a "$" sign in the command prompt. That means you are not rooted.
Next run the following commands in the shell to change permissions and get some limited privileges for the Superuser files:

chmod 6755 /data/local/tmp/su chmod 755 /data/local/tmp/busybox chmod 644 /data/local/tmp/Superuser.apk
Note that the names of the files are case sensitive.


Turn off your Android device using the power button.

Now you need to reboot your system into a Linux distro which has Nautilus.
Android and Linux, having a similar heritage, makes it possible for us to get root access over the Android phone if you are running with root privileges within Linux. I used an Ubuntu 11.04 Live USB disk to save the hassle of installing another os.

When you have booted into Linux, open up terminal and type:
sudo nautilus
This would open up the Nautilus file browser with root privileges.

Now put your Android device into Download mode.
For Spice MI-410/Huawei Ideos X6/CherryMobile Magnum HD/Wellcom A99 the method is to hold down the Volume up button and simultaneously turn on the phone using the power on switch.

Once in download mode, connect the Android device using the microusb cable to the computer.
Now using the open Nautilus window, navigate to /UserData/local/tmp/ folder and verify that you have the files you sent to the device viz. su, busybox and Superuser.apk

Move/cut-paste su and busybox to /system/bin/ using Nautilus.
Move/cut-paste Superuser.apk to /system/app/ using Nautilus.

Now pull out the battery from your Android device.
I swear, this was the most tedious part on my MI-410 which has such a crappy back cover.

Now simply turn on your device.
You must now have root.

Verify by running:
adb shell su
You'll note that the "$" prompt will turn into a "#" and you'll be prompted by a Superuser permission notification on your


You have now completed your initiation brethren.
Welcome to the root club.


For all purposes, consider that your warranty will be void if you follow these steps

I am not responsible for any loss, monetary or otherwise arising as a result of this article.
If you don't feel up to it, quit now and close this web page.

I must assert that although I am aware of no reason why this should not work on *any* Android device, phone or tablet, I have only tested this on my Spice MI-410 crossflashed with the leaked CherryMobile MagnumHD Gingerbread 2.3.4 firmware.

I have tried to explain it in the easiest way I can, but I must state here that this is by no means an easy task and you must persevere. If you can't follow the steps to the letter, its better you don't follow them at all and wait for a single click app for this or a custom rooted firmware.
He conquers who endures.

Source: Article : How to Root Any Android Device Manually


#1 kartikoli, Jul 21, 2012
I don't think this method work on MTK/MMX device because there is no way to put device in Download or Fastboot mode...if u find a way to put the device in download mode then bingo...try the method so u can get idea if it works or not.
Try getting a CWM recovery from any of clone device of A52 or get me a boot.img of A52 so I can mod it,enabling u to use UnlockRoot or SuperOneClick to root ur beloved A52...
#2 mastermind1024, Jul 23, 2012
superoneclick didnt worked and the above method is too complex for me to try [i am not comfortable with commands]

let me know how to to extract boot.img for the phone i will try to extract it with the little knowledge i have
#3 kartikoli, Jul 23, 2012
Wait till evening, i will give u another method to root mtk device.its also command method but i will give u a bat file so u don't hv to enter command manually.just run it, enter, enter n see if u got rooted..wait for my reply, i m at hospital right nw so u will hv to wait.
#4 mastermind1024, Jul 24, 2012
Try this method to back up ur current rom as a failsafe if anything goes wrong.if u succeed then send me boot.img
#5 mastermind1024, Jul 24, 2012
Ok, I have got another method to try with...u just have to extract the files, attach device to pc in usb debugging mode, run MastermindRoot_A52.bat file...
Process is in 3 steps...after each step wait for the device to reboot completely n then hit enter...if everything goes well u will get rooted after 3rd steps...remember to wait for device to reboot completely before u hit enter each time...
Here is the link for MastermindRoor_A52.zip....

See, there is no garranty that this method work, u havet to try n let me know as I don't own the device.N as with the every case of rooting or development, i m not responsible for any damage that may occur to the device or data, use at ur own risk.
#6 mastermind1024, Jul 24, 2012
i will surely try it on sunday as i dont have a backup mobile so cant risk it in working days ... u know if something goes wrong
#7 kartikoli, Jul 24, 2012
Take ur time...n try to back up rom 1st, i hv posted a link...n u might also be interested in a thread in A73 forum where user shahabazas successfully backed up A73 rom.
#8 mastermind1024, Jul 25, 2012
couldnt root it here is the error message


Uploaded with ImageShack.us
#9 kartikoli, Jul 28, 2012
when i run the bat file window tried to instal drivers but failed ... could this be a possible reason

I am on Window 7 ultimate 64 Bit
#10 kartikoli, Jul 28, 2012
I am also on 64bit win7...u need to press F8 after bootscreen n then select "Disable Driver Signature Enforcement" then only the driver will be installed on 64 bit...n get the drivers first from A75 forum, they will work for u too...
#11 mastermind1024, Jul 28, 2012
Here is another method for root MT6573 device.Please have drivers installed first.

#12 mastermind1024, Jul 28, 2012
installed the drivers and still didnt worked

didnt worked as well
#13 kartikoli, Jul 29, 2012
Hmmmm...now only hope is if u smhw get romdump then we can modify boot.img and/or system.img to get u rooted...
Btw, can tell me what error u got with both of these methods after installing drivers??
#14 mastermind1024, Jul 29, 2012
first window installed MT65xx drivers then i got the same error as posted above and for second method i got the following error


Uploaded with ImageShack.us
#15 kartikoli, Jul 29, 2012
Guys I am found a clone of this phone.
#16 arnabghosh, Aug 14, 2012
Guys I am find the clone phone of this mmx a52.plz help me how to root

#17 arnabghosh, Aug 14, 2012
#18 kartikoli, Aug 14, 2012

so plz help me how to root :eek:
#19 arnabghosh, Aug 21, 2012
a member on XDA is claiming to root his MMX A80 through droid root tool so can some one test the tool on A52

xda-developers - View Single Post - Micromax A80 root
droid root tool
[TOOL][ROOT/UnROOT][Razr] EternityProject EasyRootICS [Win/Linux] - xda-developers
#20 kartikoli, Aug 28, 2012
tried the eternity project tool on A52 >> its not working
#21 AddyRage, Aug 29, 2012
some one please try it on linux PC

xda-developers - View Single Post - Is there any way to root MIcromax A52 ????
#22 kartikoli, Aug 29, 2012

boot.img of fly235
#23 arnabghosh, Sep 1, 2012
by the way its mtk 6575 not 6573
#24 arnabghosh, Sep 1, 2012
can we use this method to root A52

Root Micromax A87 Ninja 4 - Working Solution ! - xda-developers
#25 kartikoli, Sep 25, 2012