Samsung Galaxy S4 Forum

Root How to root Verizon Galaxy S4 with Lollipop (5.0.1)

I just upgraded. My information is as follows.

Model: Samsung Galaxy S4
Carrier: Verizon
Android version: 5.0.1
Build number: LRX22C.I545VRUG0C1
Model number: SCH-I545

It took a bunch of work to make the upgrade succeed, but I finally did it :).

Now I'd like to root the device. It appears that this isn't possible yet (at least not without a long, risky process of rewinding the OS to an earlier version, rooting it, and re-upgrading everything to its current state... it's not clear to me that even that would work at this point).

Does anyone know how this can be done? If not, does anyone know if there are any ETAs on this from apps/tools such as towelroot?

Thanks,
Barry

 

Related:

#1 barry.holroyd, May 1, 2015
I know of one way but it looks incredibly complex and I don't want to go through Odin downgrades again. http://www.droidviews.com/install-lollipop-on-verizon-galaxy-s4-and-keep-root/
 
#2 Stompy, May 3, 2015
Hey -- thanks for the link. I hadn't run into that one yet. Unfortunately, from VM's post it appears that once you've installed the standard OTA firmware, there's still no known way to get it rooted. Specifically, you (apparently) can't downgrade Lollipop to an earlier version (e.g., KitKat), which would be required for rooting and unrooted phone; the main discussion is around retaining root during the upgrade to Lollipop, which would have been great if I'd known about the issue in advance (but is too late now) :)).

Barry
 
#3 barry.holroyd, May 5, 2015
I am having the same exact problem. I have the Verizon Galaxy S4 SCH-I545 anf I recently was forced to upgrade to Lollipop, which I absolutely HATE!!!!!!!!!!!!!!!!!! I need to root this phone badly! I've tried Odin, OneClickRoot, TowelRoot, nothing works!!! They all say that my device is not supported. Help.........
 
#4 lmiller001, May 8, 2015
I am also having this problem. I tried rooting before the Lollipop "upgrade," and it ended up soft bricking (trying the Odin flash method). Had to do a factory reset, and it blocked my WiFi access after the reset until I downloaded Lollipop (thanks, Knox). The installation wiped my SD card, so I lost a bunch of stuff and am kinda really extremely angry.
How to root a 5.0.1 S4 SCH-1545?
 
#5 RJswanee, May 10, 2015
I upgraded to lollipop on a Verizon SCH-I545 and it was a disaster. Would randomly delete contacts plus no rooting. I called Verizon and complain that I was having software issues caused by the new upgrade. Since there are to many problems going on with lollipop and my phone was still under warranty (if you rooted beware your knox) they sent me a new phone with kit-kat running NG6. I just downgraded to NC5 and will never go near lollipop again. Just say new upgraded is causing majors errors on phone and since you can't downgrade and if you still have warranty they will send you new phone.
Try it. Only takes a day or 2 to get it.
 
#6 mlips821, May 14, 2015
Anyone tried cf-root? it trips knox but who cares?
 
#7 Curtis1973, May 14, 2015
I called Verizon, and they were more than happy to send a replacement S4, but it would've come with Lollipop already installed (as of 5/9/15). They were unable to offer a replacement S4 that was still running Kit-Kat. So I'm just dealing with it for now. I've found this thread on XDA-Developers about a possible way to root, but it's untested as of yet. I'm not willing to completely wipe the phone to go back to Kit-Kat (I'm just a frickin noob and have no idea what I'm doing), so I'm waiting for something a little less complex to come along.
 
#8 RJswanee, May 14, 2015
RJswanee, They were lieing. Told me the same thing. The phone I received was still on 4.4.2. Of course the volume buttons were damaged and had to send that one back,waiting on next one.
 
#9 Seadooman, May 19, 2015
Perfect received another S4 everything in good condition and still on NC5!
 
#10 Seadooman, May 23, 2015
The title of this topic is BOGUS as it does not describe how to root a i545 with lollipop installed. The OP should change it from a statement and make the title a question!
 
#11 phil0sophic, Jun 21, 2015
I just rooted using KingRoot and rooted in like 2 minutes after I updated. Very pleased. I don't know why this isn't easier to find. I registered just to share this: http://androidxda.com/download-kingroot-application
 
#12 CrazyMC, Jul 16, 2015
This worked perfectly for me -- THANK YOU!!!
Barry

 
#13 barry.holroyd, Jul 17, 2015
This was awesome. Never ever thought I could root phone and clean it out to basically pure android in 10 minutes total. Phone way more responsive. Amazing app and thanks for posting link
 
#14 JuniorSamGlxyLvr, Jul 21, 2015
This works perfect. Now I love my s4 again! Lollipop is great NOW
 
#15 JuniorSamGlxyLvr, Jul 21, 2015
I'm new to this and unsure what exactly I'm doing.

Just to be clear - My phone: Galaxy S4 SCH-1545, Carrier: Verizon, Android version: 5.0.1, Build number: LRX22CI545VRUG0C1. Following instructions here will root device? Can I undo the root process? How can knox interfere with this? Thank you.
 
#16 jog267, Jul 24, 2015 Last edited: Jul 30, 2015
THANK YOU CRAZYMC!!
 
#17 mtbierkan, Jul 30, 2015
I AM u sing apk I have exact samr phone but when I run app it restarts phone and then fails help pls
 
#18 Hunter717B, Jul 31, 2015
Root attempt failed for phone: Galaxy S4 SCH-1545, Carrier: Verizon, Android version: 5.0.1, Build number: LRX22CI545VRUG0C1, Configuration version J12.SAM.SCHI545.0, Knox version 2.3.
 
#19 jog267, Jul 31, 2015
Yup
 
#20 Hunter717B, Aug 1, 2015
Root failure notification recommended rooting via different method, one involving a pc - anyone know if this method will this work on this phone: Galaxy S4 SCH-1545, Carrier: Verizon, Android version: 5.0.1, Build number: LRX22CI545VRUG0C1, Configuration version J12.SAM.SCHI545.0, Knox version 2.3?
 
#21 jog267, Aug 1, 2015
Root failure with the app happened for me, then the PC version worked. After factory reset, lost root, and the app did not work until several reboots later for some reason.

Anyone know if it's possible to use a custom recovery and install cm12 or similar? TWRP says that without Loki exploit, device will not work with TWRP - tried using CWM recovery, but cannot get it to work.
 
#22 navydrgn, Aug 1, 2015
Các bạn có ai cần root Android 5.0 không! Mình found been công cụ nhổ gốc it and mình vừa root thành công and nhẹ nhàng con S4 SCH I545 5.0.1 Lollipop of mình.Xin chia sẽ cùng các bạn:
Các bạn chỉ việc dowload Kingroot at this address 'về máy tính: http://www.kingroot.net. Then chỉ việc root thôi. Tiếp theo tải về kiểm tra gốc từ CH play for kiểm tra lại thế là xong. If you do not the thích SU of Kingroot vì ngôn ngữ tiếng Hoa thì we vào CH play tải Kingroot Suppersu về nữa thế là hoàn chỉnh. Chúc các bạn thành công!
 
#23 Thanh Tan, Aug 6, 2015
KINGROOT Apk did not work but PC version did. www.kingroot.net I now have a rooted SCH-I545 running Lollipop
 
#24 cat3rn, Aug 6, 2015
Omg thank you soooooo much it worked I've been searching everywhere to root my phone thanks a million
 
#25 Yung712Mani, Aug 6, 2015