HTC One M8 Forum

General Mail has stopped unexpectedly - HTC

Hi all,

Recently had issue with my phone's built-in mail app. Any account that was attached to it would crash anytime I tried to reply to an email. I would get the following message: "Mail has stopped unexpectedly. Would you like to send an error eport to HTC? This will help us improve our products." I ran the gamut with this thing. I removed the accounts and then re-added. You can't uninstall the mail app as it it part of the operating system. Got on with T-Mobile and they suggested backing up and doing a factory reset. Did that, same problem after reset. Got on with HTC, they said I needed to reinstall the operating system. Did that, problem with email still present. Finally found a post that said an update was to blame for the whole thing. Click on the Play Store App, go to My Apps and Games, then look for an update called Android System WebView. Uninstall the update. As soon as I did that, mail worked normally again.

Hope that helps anyone so you don't have to wipe a phone twice like I did.

 

Related:

#1 Dred Llama, Feb 11, 2016
HTC needs to get on the ball and update their email app.
 
#2 Crashdamage, Feb 11, 2016
I think I have the same problem on my M8. A temporary solution is to un-install "Android System WebView". I believe the bug is with that App.

I have been trying to hunt this down with Google and/or HTC and not getting very far. Here is a link to a bug report thread on the Chromium tracking page:

https://code.google.com/p/chromium/issues/detail?id=570404
 
#3 jpt19, Feb 11, 2016
BRILLIANT Thanks.... just happened to my M7.... turned on wifi and some updates loaded. Mine only crashed when I tried to reply to a email. (thats all I noticed) Also, my blinkfeed went blank too.

Thanks again!
 
#4 rlanelkn, Feb 11, 2016
Haven't noticed any issues on my end. I don't use the native email app in sense, so I can't really comment.

Has anyone tried to uninstall, then reinstall?

Another route is to check and see if you have the app the proper permissions if you've updated to Marshmallow.
 
#5 Granite1, Feb 12, 2016
Thank you so much. I had the same problem and came across your post and figured I give it a shot and it worked. Thank you once again.
 
#6 ICamp11236, Feb 16, 2016
Thank youuuuuu soo much!!! Worked like a charm on my M7... I was already contemplating on getting a new device... You da maaaaan you just made my day! Cheers!:cool:
 
#7 Ivanko, Feb 19, 2016
Thank you so much! Found today I couldn't reply to emails using HTC mail app. I uninstalled the updates to the webview so it reverted to the factory version - immediately the problem went away. Great info!
 
#8 David_UK, Feb 19, 2016
Yes! That worked perfectly. Thank you so much.
 
#9 mikejrexec, Feb 20, 2016
Dred Llama... OMG, thank uuu, thank uuu, thank uuu... I had the exact same issue verbatim w my HTC M7.. and uuu my dear are a lifesaver!!!! I had the mail trouble as u described for several days - searching here for suggestions w/no avail until ur post. Don't take this the wrong way but I could just hug uuu - Thanx a million !!!

My M7 just recently started lagging w/texts, any advice... Should I delete some?
 
#10 CTLaurie, Feb 21, 2016 Last edited: Feb 21, 2016
Hi Dred,

Thanks a lot for going through all that trouble, helping us!

I had the same problem on my M8s, which sent me through the roof!

It is also very disturbing it was Google that created the problem by an update. Do they not TEST at Google, or HTC?!
(Are you awake over there? Please read this. And please send Android 6, HTC. And please make that update process not so stupid, allow us to directly update from Google!)

I followed your advice and the problem went away.

What made it extra frustrating was that I installed Outlook as a workaround, but did not manage to get that working either. I experienced it as very user unfriendly to get it to work with an (even already existing) IMAP account.
 
#11 AndroidBertje, Feb 23, 2016
Thank you so much for this! Completely stuffed me up yesterday when I was trying to respond to important work emails and I couldn't work around the issue. Pathetic by Android to not test first!
 
#12 Clare, Feb 23, 2016 Last edited: Feb 23, 2016
This is a HTC problem not a Google problem. It's not Google's responsibility to test HTC's proprietary software. HTC is provided updates on advance for testing. If HTC fails to provide updates to fix problems that's on them.

Outlook is well known to be a bug-infested mess.
 
#13 Crashdamage, Feb 23, 2016
Vielen Dank!!!

I wasted three hours today at two different Vodafone stores. After waiting 20 minutes at the 1st one (Rösrath), I explained the problem, showed him the error and, He said keine Ahnung (no idea) and handed the phone back. I asked him what I should do and he again said, no idea.
So I went to another Vodafone store (Troisdorf) and waited again. This time the person was much more helpful. He said: "It's a technical problem. Come back Monday when the technical guy is here."

I probably would have tried all the things you did and still not fix it.

You probably save me days to get it working again.

Since it worked fine for a year and then didn't, I sort of reasoned that it had to to with some update to something. A good reason to have automatic app updates turned off.

At first, there did not seem any clear way to figure out if it was an HTC issue or some other vendor issue. Glad I found your post and still kicking myself for not first just researching the problem myself.



Thank you
 
#14 iim1rmg, Feb 26, 2016 Last edited: Feb 26, 2016
Wicked Mate! It worked
 
#15 Ketan007, Feb 26, 2016
Good morning, Same issue, Uninstalled "Android System WebView" as mentioned above.
No more "email stopped working".
Thanks for the solution....
 
#16 TT1080i, Feb 27, 2016
That fix was just what the doctor ordered. HTC One M9 with Sprint and I was just about to go to a Sprint store until I read this post. THANK YOU very much.
 
#17 Turrbine, Feb 27, 2016
Kudos, Dred Llama!! Your fix was spot on! My HTC One M8's mail kept shutting down when I tried to reply to or forward messages. This happened all of a sudden yesterday morning. Rebooting and restarting the phone didn't work. I discovered this discussion thread and tried Dred Llama's fix, but accessed the app via my Settings> App Manager>Android System WebView.
UNINSTALLing (disabling alone did not work) Android System WebView corrected the problem IMMEDIATELY!! What a relief! Thanks!!
 
#18 mxh4, Feb 28, 2016
A follow-up to this issue: all was well when I had uninstalled Android System WebView. Then I got on the plane and had to shut down my phone...when I turned it back on, my Mail had the same shut down when I tried to reply to a message. When I checked my Apps, Android System WebView had been installed again! Uninstalling fixed it, again, but does anyone know how to prevent the phone from installing it??
 
#19 mxh4, Feb 28, 2016
Dred , you are a top man. I have been struggling with this for a few days and just did what you said and bingo success, brilliant,
Thanks
 
#20 Simmo27, Feb 29, 2016
Thanks! This solved the issue for me!!!
 
#21 Gregory Hill, Mar 1, 2016
Just wanted to let you know, this post saved me what you went thru Dred. Also I later found that HTC is aware of the issue now and offer up this same fix. http://www.htc.com/us/contact/chat/
 
#22 Alan_bittle, Mar 1, 2016
You have to go into Google playstore - settings- turn off auto updating
 
#23 Alan_bittle, Mar 1, 2016
After making this fix I now find that the text of my emails disappears as I open them. It only appears to happen on emails with text then images or an attachment and the text is clearly visible if I read the email on the laptop. Any help greatly appreciated.
 
#24 Simmo27, Mar 2, 2016
Again I say, this is a HTC problem, not Android's. The best fix is to use a better email app one that can move with you from device To device. T4y Maildroid, K-9 or my favorite AquaMail,.
 
#25 Crashdamage, Mar 2, 2016 Last edited: Mar 2, 2016