Home Forum

MMS settings for metropcs with tmobile network

I have a new phone on the tmobile network through metropcs. I can't find the MMS settings that work. I tried tmobile settings and they don't work. Metropcs setting don't work because I am on the other network.

Does anyone have the tmo metropcs MMS settings? I am trying to use a different sms app and it will not send or receive pivs or other mms.

 

Related:

#1 ccordell, Aug 15, 2014
What phone do you have? Where did you buy it? Metro or Tmo SIM? Have you rooted the phone or put a ROM on it?
 
#2 confed, Aug 15, 2014
APN Settings:

Name:*
MetroPCS
APN:*
fast.metropcs.com
Proxy:*
Not set
Port:
Not set
User Name:*
Not set
Password:*
Not set
Server:*
Not set
MMSC:*
http://metropcs.mmsmvno.com/mms/wapenc
MMS Proxy:
Not set
MMS Port:*
Not set
MCC:*
310
MNC:*
260
Authentication type:*
None
APN type:*
default,mms,supl
APN protocol:*
IPv4
APN roaming protocol:*
IPv4
Enable/disable APN:*
APN enabled
Bearer:*
Unspecified
 
#3 jgarcia88, Aug 16, 2014
I have been unable to send or receive pictures thru messaging. Ive switched from Chomp tp Hangouts with no luck. I have not altered any settings from when the phone was allowing pics to be sent/received. Is there a Metro/TMO issue?
 
#4 smg1062, Aug 21, 2014
This is happening with me also.

I have used T mobile and Metro APN settings.

I have called Metro and im sure we all know how that was.
They couldn't get me off the phone quick enough.

I have an LG G2 T-Mobile on Metro.

I used these settings and nothing works.

settings for me dont work
APN fast.metropcs.com
MMSC h**p://metropcs.mmsmvno.com/mms/wapenc

APN fast.t-mobile.com
MMSC h**p://mms.msg.eng.t-mobile.com/mms/wapenc
 
#5 BRIAN5337, Aug 21, 2014
Try using T-Mobile's APN. http://apn-settings.com/t-mobile-apn-settings-step-by-step-configuration/
 
#6 jgarcia88, Aug 24, 2014
I'm on a T-Mobile version LG G2 on the Metro PCS service. I just fixed this problem.

I used the APN from Metro and the MMSC from T-Mobile. Combining them in that way allows me to send and receive MMS and use LTE data.

Hope that helps.
 
#7 Megiddo, Oct 13, 2014
Thank you for this! I just switched from Tmo to Metro today. This was the only thing that I had an issue with. I didn't even bother calling their CS. This solution worked for me. Got tired of paying 20-30 bucks just for data only. I do a lot of streaming on my Note 4 so I was drawn to the unlimited data. Hope it's the real deal!
 
#8 mainevent3405, Dec 10, 2014
I've never been throttle . Hope you enjoy!
 
#9 confed, Dec 11, 2014
Thank you that sounds good to me... but please can you show the setting or the MMSC you use with your G2 ? Thank you
 
#10 Solo Fish, Dec 28, 2014
Where and how do I change these settings? I have a t-mobile zte zmax on metro and can't send MMS (pics). No one at metro can fix this.
 
#11 saludabowers, May 9, 2015
Is that pretty close to a stock android experience? If so, you should just go to settings, then Mobile Network settings and then Access Point Names. It should be similar. Let us know if it is different or you do not see this.
 
#12 confed, May 11, 2015
Change it but that didn't fix the issue. Its taking hours for picture message to send.
 
#13 saludabowers, May 11, 2015
Thx jgarcia88

The above entries were all that were required for a Lumia 920 Windoz Phone to successfully access MetroPCS MMS on the T-Mobile network.

BTW, thx to the Android community for such excellent trouble shooting posts as these. I may be back to an Android device (I am after all a *nix guy) if one of the vendors produces a phone with such excellent shake reduction technology at a reasonable price. This Lumia 920 has made it a little easier for someone with essential tremor.
 
#14 marawuti, Jun 8, 2015
I used this combination on my ZTE Z970 (zmax) and my mms works great. This is the ONLY APN setting that actually works for me. Now, if I can only get band 12 in Central Florida. :D

Note: I am on a Family Mobile / T-Mobile phone with MetroPCS BYOP sim.

APN: fast.metropcs.com
MMSC: http://mms.msg.eng.t-mobile.com/mms
APN Type: default,supl,mms

All other settings were left alone.
 
#15 Hurricaine, Jul 1, 2015 Last edited: Jul 1, 2015
Thank you for this amazing information and I VERY much wish to implement it into my phone but the MCC and MNC fields are greyed out and cannot be altered. When I go to save these settings I receive a message "Attention MCC field must be 3 digits." I cannot modify these fields. I am running an M7VZW which I hasve just changed over to MetroPCS with one of their SIMM cards. Have been fighting with this issue since day 1 and any assistance would be greatly appreciated. Thank you in advance!
 
#16 GRASSINATOR, Jul 14, 2015
Sorry for the double-post all. Mod, could you please delete one. Thanks!
 
#17 GRASSINATOR, Jul 14, 2015
If stuff is greyed out it sounds like you need to create a new APN. You can do it by hitting the plus sign. A lot of fields can be left similar to default but use Metro APN with tmobile mmsc combination.
 
#18 Hurricaine, Jul 15, 2015
I have been trying to create a new APN all the while. Have even go e to the extent of deleting telephony.db, rebooting then creating one again. There was only one time after performing this task when I was to modify the MCC and MNC fields and even after doing so I STILL had issues. ANY light that could be shed on this will be GREATLY appreciated. Thanks in advance!
 
#19 GRASSINATOR, Jul 15, 2015
Tried your suggested settings as well Hurricaine, yet I still receive this same error. "MCC field must be 3 digits". And I am unable to edit this field.
 
#20 GRASSINATOR, Jul 15, 2015
You need to create a new APN with all the specs
 
#21 Krlypumaa, Jul 15, 2015
I must not be doing it correctly then. Please advise.
 
#22 GRASSINATOR, Jul 15, 2015
You need to check which mnc area are you in it could be MCC-310 but the mnc_200,210,220,230,240...etc
 
#23 Krlypumaa, Jul 16, 2015
I appreciate all of this information but how would one edit these fields, they are greyed out. I guess just search for these settings on the MetroPCS network based upon my location? Thanks!
 
#24 GRASSINATOR, Jul 16, 2015
I have browsed this URL previously and discovered this information:
https://en.wikipedia.org/wiki/List_of_mobile_network_codes_in_the_United_States
660 Metro PCS LTE network, shared between T-Mobile USA and MetroPCS customers
So MCC for Metro PCS and MNC for T-Mobile?
What a pain in the neck this has become.... :-\
And how might one go about inputting this information?
 
#25 GRASSINATOR, Jul 16, 2015