Home Forum

My phone won't connect to my laptop but still charges?

So as you can see in the title, I have an issue. And I would really like a solution cause I can't get Jellybean considering my phone won't connect. I remember it used to connect fine and my mass storage would come on and everything (Oh I have a Galaxy S2 Skyrocket through At&t) but now it only charges. I don't have a sd card in my phone and I never have so I can't manually turn on the mass storage. I don't even remember that last time the mass storage actually worked. Anyways, any solutions I can try? I'd love for it to connect so I can try and get Jellybean. Thanks.
 

Related:

#1 TheMartian17, Apr 22, 2013
Hey martian.

Mass storage was removed with the update to Ice Cream Sandwich on the S2 (and other phones too[?]).

But anyways, have you tried a different USB cable and/or a different USB port on your laptop?
If that doesn't work, have you turned on USB Debugging in settings -> developer options? I'm not entirely sure if that would be the problem, but it's worth a try.
Also, do you have the appropriate drivers for your phone installed? They can be found here under the "downloads" tab:
http://www.samsung.com/us/support/owners/product/SGH-I727MSAATT

If you have any more questions or concerns regarding your device, check out this sub-forum.
Samsung Galaxy S2 Skyrocket - Android Forums
 
#2 iTzKPanda, Apr 22, 2013
Yeah I only have 2 USB ports and neither of them worked. I only have one cord but I could try using my brothers and I'll let you know if that works. And yeah I have USB Debugging. The driver is all up to date and what not. Even today the phone started to connect but the device didn't install correctly or whatever that is? So I'm kind of confused as to why it just flat out won't connect anymore.
 
#3 TheMartian17, Apr 23, 2013
Do you have another computer you can try?
 
#4 iTzKPanda, Apr 23, 2013
Hey sorry it took so long to reply. I was just sitting here at my laptop not long after I sent that second message and my phone connected and I was able to switch to Jellybean. Idk how or why it did it? Quite random if you ask me but I'm not complaining lol thanks for the advice though :)
 
#5 TheMartian17, Apr 28, 2013
I'm not at al able to connect I tried something al what shall I do now???
 
#6 sneha g, Dec 6, 2016
What phone do you have?
 
#7 lvt, Dec 6, 2016
Micromax Q450
 
#8 sneha g, Dec 7, 2016
Try to find if there is a specific USB driver for your device. Not all devices are automatically recognized as mass storage by Windows.
 
#9 lvt, Dec 7, 2016
I tried in al USB port no use. how to find driver?
 
#10 sneha g, Dec 7, 2016
Before looking for drivers, please make sure that you have tried with a data cable that actually works for someone else's phone. Some cables somehow only charge and no data transfer at all.
 
#11 lvt, Dec 7, 2016
I use to use this cable before and now it's not working I tried with another cable no use
 
#12 sneha g, Dec 7, 2016
When you plug your phone to your computer, what happens? Any Windows message or warning sound?
 
#13 lvt, Dec 7, 2016
nothing is coming phon Is charging but in phon charging notifications Are not coming
 
#14 sneha g, Dec 11, 2016
Hey, I just got a new phone Gionee P8w and I've been trying to connect it to my laptop it's not working. I installed a USB drive setup and still it's still the same I also tried different ports on my Laptop.... My laptop is charging it but not connecting to it. What should I do?
 
#15 onifavzzy, May 27, 2017
If you say you have a new phone you can go to the shop where your bought it or the service centre. Or just try to install the drivers needed for your mobile and try again
 
#16 Leon Marco, May 27, 2017