Kyocera Hydro Forum

Root New Root Method No Pc - Credit to MyFormIsCrack over on the rise forums

Sorry for the duplicate post I can't change the Title in the other post "New Firmware update - root problems" , So I am starting a new thread.

After trying several methods.. I was able to Root using POOT. Bin4ry's root method did not work for me (I Tried V2, v17, V18) And seeing as I rooted the Hydro over 10 times successfully prior to the Update I thought this would help others.

more info here:
http://androidforums.com/rise-all-things-root/686996-new-root-method-no-pc.html

Credit goes to MyFormIsCrack over on the rise forums.

[​IMG] New Root Method No Pc

Prior even posting how can I make this my own thread instead of being sticked especially when I'm the only one so far who has this?

On my initial/first reply was solely asking to have this as a seperate thread and not being moved by a mod into the sticky.Basically you do the following:

1)Enable usb debugging in dev ops

2)Download poot: http://db.tt/0HqxEURT

3)Download minstro 2 from store

4)Download superuser from store

5)Run poot

6)Pushes su to xbin

7)Go into superuser and update binary (I skipped this step for some reason I lose root after doing this)

8)If done right you now have root

9)For testing on already rooted phones use temp unroot through superuser and repeat

this worked for the rise, and for me for the hydro. Bin4ry's root I could not get to work (after the "Kyocera Update Tool" downloaded and installed new formware ) hope this helps someone here.

If I helped you hit the thanks button!
 

Related:

#1 Mike525, Feb 12, 2013
Works great! I had to install superuser update fixer to complete the root using poot.
However I was able to root another rise using Bin4ry V3. Thanks!
 
#2 Jeremiah1977, Feb 12, 2013
This didn't work for me. Kept getting 'a demon has appeared' error. V2 worked perfectly tho :)
 
#3 Lordvincent 90, Feb 16, 2013
Ok, I've been trying to root my Hydro for a few days and then I stumbled upon one of the guides here on this board. I couldn't get it to work with Bin4ry's method (none of his scripts worked for me) so I was sent here by maikal82 to try this one.

This one worked for me, but the guide above is lacking a few helpful bits of info. First, the POOT file has to be put on your phone (you can't run it from the computer, which is what I thought you had to do). I plugged my phone into my PC and dragged/dropped POOT into the Download folder. Once it was there I just clicked it and it ran and installed itself.

Now I don't know what version of SU the OP used, but the SU app I have doesn't have any options in the settings to update the binary. I'm totally new to all of this so I don't even know what SU is or what it does, but there must be different SU apps out there. The first one I downloaded from the store had an icon with a blue cape on it. This one I have now is the android bot with a patch over his eye. I haven't been able to locate the other one yet.

Anyway, I now have root, so I'm happy.
 
#4 desktop, Feb 16, 2013
@ the honorable LV90...

Have you done the firmware upgrade already? (Kyocera update tool) because V2 always worked for me until I updated :mad:
 
#5 Mike525, Feb 16, 2013
Yea, she (my roommate) updated while I was on the road.

I tried poot, which told me a demon surfaced, but when I ran it a second time without rebooting, it said that su binary was installed, I checked for root access with root checker... it failed. I went into superuser and selected the update binary option. It ran successfully (even prompted for su permission) :thinking: but still didn't give me root access

So I tried su update fixer... it couldn't get root... so then I went and tried v2 and it worked first shot
 
#6 Lordvincent 90, Feb 16, 2013
Does anyone have any idea how to fix this "demon" (Error code: 222)? It seems to be the only thing preventing me from rooting with POOT. Bin4nry hasn't worked. I've tried v2, v15, and v18. Program starts then after I hit restore, nothing... I'd appreciate ANY suggestions.
 
#7 DBauzer, Feb 16, 2013
Yea, that's why I mentioned it Don't update binary... I lose root after binary update not sure why.
 
#8 Mike525, Feb 17, 2013
Yes, but if you read my post, I didn't have it before i attempted to update the binary either...
 
#9 Lordvincent 90, Feb 17, 2013
Yea sorry I did see that and I had the phone lagging bad on the first couple of attempts , eventually it did work for me.
 
#10 Mike525, Feb 17, 2013
I still haven't been able to get my phone rooted with either method, so I don't know... :/
 
#11 Slayer72, Feb 17, 2013
Downloaded and installed ministro2 after firmware update,then ran poot. Ignore the demon then dl'd And ran superuser (eyepatch ) all good
 
#12 kaelusa, Feb 22, 2013
I tried that had root for a day then mysteriously lost root, so yeah this phone is so damn annoying, I'm getting a Samsung Galaxy SII tomorrow, so I won't have to deal with this annoying POS much longer... :p
 
#13 Slayer72, Feb 23, 2013
I guess the key to rooting this phone without pc is to have the needed library files present before running poot. That way, if any further files are needed, they will update upon running poot. Ministro 2 updated itself, as did superuser. I still have root and was able to install and run flash player 11 today. Or, I'm just lucky, lol
 
#14 kaelusa, Feb 23, 2013
It worked perfect for me. Update binaries and everything. You have to make sure you actually run poot after it downloads the things it needs. Then should work like a charm
 
#15 alphonsecorbet, Feb 24, 2013
So all the hydro users know I made a easyer guide for this well I think at least lol and I tryed to make it for noobs as best as I could
Ps its on the rise fourms
 
#16 PattyBear9210, Mar 3, 2013
so I used root checker to see if I was rooted and it said yes but superuser binary won't update...does that matter ?

Sent from my C5170 using Tapatalk 2
 
#17 tehnoob, Mar 20, 2013
Updating Superuser does not matter, as long as you have root and are being prompted for permissions for apps requiring root you should be all set...
 
#18 Slayer72, Mar 20, 2013
For those that have acquired root do you know if your phone has the latest update pushed from Boost?? I'm trying to figure out why mine still won't take at this point...
 
#19 Slayer72, Mar 20, 2013
FYI, updating the SU binaries will break root. sounds strange, but using poot to root the Hydro, i've had to reroot twice after updating the binaries.

Slayer, I have the update to 4.0.4. though i rooted after the OTA update.
 
#20 Midnight_Moon, Mar 21, 2013
Worked perfect, Thank you Mike525
 
#21 vipervma1, May 2, 2013
Given poot is initially only native to the elite you cant fix forementioned.The whole point of poot is to push su binary into xbin and nothing else afterwards you go into superuser swipw completely to the left bottom update.Also from inception make sure to enable usb debug in dev ops
 
#22 MyFormIsCrack, May 23, 2013
I rooted my hydro thanks to you guys and I did that with the hopes that it will help me with the freezing and laging and of course with the battery.

Now I'm not sure what to do. I installed Greenify for the battery. But for some reason it only allowed me to hibernate Tango. All the other I get I message that says "Failed to put 'NAME OF APP' in hibernation.?? They are placed as pending. I also have App Quarantine but won't quarantined an app.

I also downloaded System Turner but it was to complicated for me so I uninstall it.

I have RAM Manager Free but I don't think is working cause my phone keeps freezing.

I also have Root App/Delete with helped me disabled and/or uninstall some apps.

The freezing is a pain. Please help
 
#23 Josh2090, Jul 6, 2013
i know im gonna sound stupid but V2 of what? or where do i get it???
 
#24 codester0869, Jul 13, 2013
I was referring to bin4ary's tool

instructions found in this thread:
http://androidforums.com/showthread.php?t=649902

However many have had success using this method (poot)
 
#25 Lordvincent 90, Jul 13, 2013