Nexus 4 Forum

General Nexus 4 red light

Hey, my Nexus 4 can´t boot up correctly :(
When i plug my charger in, a red light lights up, and goes away, but i can´t turn my phone on.
I tried to turn my phone via holding power button + volume down, but when GOOGLE shows up, it goes out again.

I have tried to take battery out and take it n again, but still nothing.

Sometimes when my phone is down, it plug my charger in, and after 10 minutes charging sign comes up, but when i have charged it for a hour or more, it doesn`t turn on. :(

There is sometimes, when the phone turns on, but after few seconds of working, it shuts down again.

WHATS HAPPENING WITH MY NEXUS?
 

Related:

#1 iggy23, Apr 22, 2015
now when i have tried the combination of volume down + power button my phone trying to boot directly on. i cant choose soe of the commands from there
 
#2 iggy23, Apr 22, 2015
pls help me :)
 
#3 iggy23, Apr 22, 2015
Have you done any hardware work on the phone, other than taking it apart to remove and replace the battery? Replaced the screen, etc?

Does the battery look swollen?

I actually had a coworker just hand me his Nexus 4 with the exact same symptoms the other day, so I've been looking into it. Sign suggest a problem with the battery, so you may want to try replacing that if you can.

Otherwise, I can sometimes get his to boot by doing the following:
  1. Press and hold Volume-Up + Power for about 60 seconds.
  2. Press and hold Volume-Down + Power while you plug the phone up to the charger. Release once it boots to the bootloader.
  3. Press the Power button to Start Android.
  4. Cross your fingers (and toes, for good measure).
Some folks say that the problem goes away for a while if you can get the phone to boot once, but I seem to have to do this just about every time I want to boot it. I'm going to try swapping in the battery from my own Nexus 4 to see if it helps.

Alternatively, I found a ton of resources by searching Google for "nexus 4 flashing red light". Maybe one of those can help out as well. Let me know if you learn anything!

Good luck!
 
#4 codesplice, Apr 22, 2015
after i plug charger into the phone, the menu with android shows up, and without i do something, it starts to power on, and dies again. Cant do somethihng on the menu.
 
#5 iggy23, Apr 22, 2015
...and after google shows up, red light blinks and phone goes off again
 
#6 iggy23, Apr 22, 2015
HEY

My nexus 4 got a problem [​IMG]

When i try to turn it on, it doesnt turn on.

Then i try to plug my charger in. A red light blinks once, and its gone again.

Then i did volume down + power button method, plugging charger while holding, but when i click start, a red light blinks again, and its dead again. [​IMG]

I tried also volume up + power button, still without i got it to work.

Sometimes, when i hold volume up + power button and plugging charger, the charging sign pops up, but after about 10 secs. i dies again

WHAT COULD HAVE HAPPENED FOR MY NEXUS ? CAN I STILL FIX IT WITHOUT BUYING NEW BATTERY ?

PLS HELP [​IMG]
 
#7 iggy23, Apr 24, 2015
Sounds like a dead battery to me.

Here's a guide on replacing it http://www.makeuseof.com/tag/how-to-replace-the-nexus-4-battery-it-can-be-done-android/
 
#8 Omar Days, Apr 24, 2015
^ What Omar said. More testing with that device I'm trying to fix is really suggesting that it's a battery issue - it booted fine when I installed the battery from my working N4.

PS: @iggy23 I merged your threads. No sense in having two threads for the same issue. ;)
 
#9 codesplice, Apr 24, 2015