Nexus 4 Forum

Support Nexus 4: stuck in endless loop of "installing system update"

Hello, last night i downloaded the new update and tried to install it.

When process bar reached to end, after a few moment it turns off it self and does it same thing over and

over.I tried to wait and left it like that for 4hours and still not ending. I tried to do factory reset by going into

recovery mode but the "sick android" screen doesn't apppear, it just reboots and going back into updating.

Btw I rooted the device. Also when i connect my phone to PC, it doesn't recongize since it in update mode?

Am I screwed? :/
 

Related:

#1 Jaepark1991, Nov 26, 2014
It seems like a lot of rooted users are experiencing problems with the OTA. You are most likely going to have to install the factory image. You can find the files and the instructions you need here: https://developers.google.com/android/nexus/images

Read through the instructions and we'll be happy to walk you through it. You will be wiping your phone, so I hope you have everything backed up.
 
#2 lunatic59, Nov 26, 2014
thank you for the reply, I was looking at the link you posted but looked very confusing.

So i was looking for video tutorial on youtube and wondering if this tutorial would solve my problem.



thanks again!
 
#3 Jaepark1991, Nov 26, 2014
That's pretty much the process, except to get into bootloader mode you'll need to use the power/vol down key combination rather than the adb command since your phone won't boot. And, to check if your device is connected, you won't be able to use adb command, you'll need to type "fastboot devices" and you should then see the device serial number.
 
#4 lunatic59, Nov 26, 2014
this is kind of weird, i was charging my phone and left it on the endless loop, hoping for nothing, but then it completed the update and phone is back to working. thank you for the help Lunatic59!
 
#5 Jaepark1991, Nov 26, 2014
Hey, that's great news. It might have been your phone was too low on battery to complete but in the middle of the update it couldn't let you know ... or it could be evil spirits ;) We may never know.
 
#6 lunatic59, Nov 26, 2014
I faced the same issue. The only option was to flash the phone and try installing the factory image. I waited for 2 days to do this and in the meantime lollipop got installed. 30+ hours and my patience paid :)
 
#7 kvmhere, Nov 30, 2014