Home Forum

Support Nexus 6 is stuck in a boot loop HELP

I have recently bought a Nexus 6 from motorola, it asked me to do a software update (think it was to marshmallow) and after it finished it said 'optimising all # of # but when it finishes it restarts and does it again. Help! Thanks!


#1 Nexus 6 stuck in bootloop, Dec 22, 2015
Try holding power button down and see if it will turn off and turn back on and see if it will boot up.
And see if you can get into recovery mode if the above doesn't work,While in recovery mode,Clear cache/Data and then see if it will boot up.
#2 AMOCO, Dec 22, 2015
I have restarted it manually and it didn't fix. I also have done both factory reset and cleared the cache and it still happens. It happened after during an upgrade to 5.1.1
#3 ZakCoulson, Dec 23, 2015
Co worker brought me a Nexus 7 tab stuck in boot loop Monday. I had never fooled with Nexus devices before. Found this thread, downloaded Nexus Root Tool Kit, followed instructions and had it working in less than a hour. Hope it helps.

#4 Jfalls63, Dec 23, 2015
Do I need to enable USB debugging? Because I can't get onto the OS to turn the option on :/
#5 ZakCoulson, Dec 23, 2015
No, had same situation with tab. Did everything in fastboot. Program is automated and very simple to use. Only being familiar with Samsung devices, fastboot and adb kinda freaks me out but this tool kit rocks for a beginner.
#6 Jfalls63, Dec 23, 2015
Thank you so much! i took all the steps and it worked fine no problems. It is up and running, You're such a life saver!
#7 ZakCoulson, Dec 23, 2015
Glad it worked for ya. All the credit goes to Scary Alien in the link I posted.
#8 Jfalls63, Dec 23, 2015