Home Forum

Root Nexus 7 Caught in Bootloop

Hi All:

I have a Nexus 7 (not sure if 2012 or 2013) caught in a boot loop.

It all started when I began to get the 'process android.process.media has stopped' message. I went onto the forums and they recommended that I clear the Media Cache. The only thing was that when I went to settings > apps, I would get the 'Google Settings has Stopped' error. The 'processs android.process.media has stopped' message started to pop up frequently so I decided to opt for a factory reset. That's what started the boot loop.

When it started to boot loop, I once again consulted the forums and used the Power + Volume Down to get the recovery screen. Here is the data contained therein:

FASTBOOT MODE
PRODUCT NAME - TILAPIA
MW VERSION - PR
BOOTLOADER VERSION - 4.23
BASEBAND VERSION - 1231_0.18.0_0409
SERIAL NUMBER - 015D2EA4A42800002
SIGNING - NOT DEFINED YET
LOCK STATE - LOCKED

When I choose Recovery Mode, I get the prone android with the red exclamation point and 'No Command' below.

By hitting power + volume up, I get the Android System Recovery <3e> screen. When I select wipe data/ factory reset, I get the 'Erasing..." screen and then I'm bounced back to the Android System Recovery screen. When I then select 'reboot system now', I get the Google Logo and the bouncing balls boot loop again.

The weird thing is that I've been turning it on and off again, hitting a random set of buttons and it has come back to the factory reset state. I've deleted caches and uploaded the essential programs and thought I'd turn it off and on again to check it and, you guessed it: infinite bouncing ball boot loop.

I purchased this devices from a friend and don't have any tech support. I had been using it with no problems since February 2014. I have downloaded and installed the Skipsoft Toolkit on my PC but am unsure if this is the right tool for the job.

What can I do?

PS I started getting the 'process android.process.media has stopped' message when I started using an imation usb drive to watch movies on my tablet. I have the usb stick, if that's another piece to this puzzle.
 

Related:

#1 MarkMacG, Dec 28, 2014
I read something about taking the back off and unplugging the battery for 30 seconds or so. I'm now giving that a try.

Edit: nope.
 
#2 MarkMacG, Dec 28, 2014 Last edited: Dec 28, 2014
Hey Mark, sorry to hear about your troubles with your N7 :( [but welcome to our AndroidForums].

It looks like you've got a 3G 1st generation Nexus 7 (tilapia)...

Doing a factory reset should have gotten you going again so I hope you don't actually have an underlying hardware problem.

The thing I would do if I were you would be to try flashing your device with a factory image. The will indeed wipe out any and everything on your device with the latest version of Android for the N7 (but it sounds like you've already done the wipe thing anyway).

The easiest way for you to do this would be to use an automated (and highly recommended) tool like WugFresh's Nexus Root Toolkit--never mind that you don't need root for this issue, it will do the factory image installation for you.

His toolkit automates the functions needed to do this installation (driver install, factory image downloading, unlocking the bootloader, flashing back to stock).

I've not actually run his utility before since I do these steps manually, but it looks like you'd need to do these steps (and follow the instructions given to you by the utility, of course):

- select your model type (Nexus 7 (Mobile Tablet))
- go ahead and do the download for TWRP (you probably won't need it)
- Unlock (to unlock your bootloader)
- Back to Stock and selecting "Soft-Bricked/Bootloop"

Lots of folks have successfully used this very nice utility, so barring any hardware issues, I have high hopes it will help you out.

Also, I'm going to go-ahead and move your thread to the Nexus 7 (2012/1st gen) all-things-root area for you so that others might assist if needed (never mind that your not necessarily rooted or rooting, but recovery/restoring and flashing operations are often done by the folks that frequent this area).

Best of luck!
 
#3 scary alien, Dec 28, 2014
I wanted to wait to see if problems recurred with my Nexus before reporting back and, after a week of heavy use, I can happily say that the procedure you had laid out above was successful! I will be going about fine tuning the apps and then flashing the image to my computer should this or other problems recur.

Thank you very much for helping me with this. Have a pleasant and prosperous New Year!
 
#4 MarkMacG, Jan 3, 2015
Hello all!

I'm just posting because I had the same issue as the OP happening to me this weekend (Nexus 7 1st gen going into a bootloop) and first of all I wanted to say thank you very much scary alien for your post and your instructions and your help on this!!

I'm a total noob when it comes to this sort of stuff and your post helped immensely!! I was able to get my tablet to boot again! \o/

Just in case more people as novice as me on this come here for help (and for completion sake) I just wanted to point out something in the process that is not mentioned in scary alien's post and that I had to figure out:

1) after installing Nexus Root Toolkit (NRT), besides the device it also asks you to selected your build from a dropdown box. Now, the way I found out about what build I had was to start the tablet into bootloader mode and going into the Android System Recovery screen (as explained in the OP). In that screen near the top left in red letters you have a bunch of letters as numbers which is your build reference. I just matched that reference with the options on the build selection box from NRT that I mentioned above to find out which build option to pick.

2) after installing NRT and before you do the "Unlock" step you have to install drivers for the program to be able to communicate with your tablet. By reading all the pop-ups with info from NRT I learned that if you are in bootloader mode (which is the only mode you can get since your tablet doesn't boot...) you don't need the USB debugger feature turned on. You just need to install the drivers and plug in the tablet. So what I did was:
a) with the tablet still unplugged from the PC I went into bootloader mode (as pointed out in the OP).
b) with the tablet still unplugged from the PC I selected "install drivers" button in NRT (it's the wide button at the top) and went into step 3. From that screen I went with "Google Drivers" which was the recommended option. Then simply waited for the drivers to install.
c) plugged in the tablet into the PC and waited for windows to setup the drivers installed in the above step for the tablet.

3) after the above steps I proceeded with scary alien's steps with no problem at all! The only thing I noticed was that, when the process ended and when the tablet was supposed to boot after the flash, it went into bootloader mode instead with an image of the android guy with a red triangle. I pressed Power + Volume Up to get into the Android System Recovery screen (as explained in the OP) and noticed there was an error from an update, something about a "radio-something.zip" not being found... Anyway, I had read in NRT info pop-ups that it was recommended to do a factory reset after the flashing process so I selected the "wipe data/factory reset" option and after that "reboot now" and the tablet was able to boot without a problem!!! \o/


I hope this info proves useful for people running into the same issue as me and the OP.

Once again thanks scary alien for all the help and Mark for making the OP in the first place :)

Happy New Year to you!!
 
#5 Sueisfine, Jan 5, 2015
Thank you for that very nice note and information, Sue!

Welcome to our AndroidForums :).
 
#6 scary alien, Jan 5, 2015

Nexus 7 (data) became almost unusable after Google recently suggested update to Lollipop 5.01. Further update a couple days later 5.02, changed little. Very slow, UI hangs and process error messages.
Some progress now! While on charge I was running Battery Doctor app and over 2-3 hrs it identified 259 app auto restarts that were slowing the Nexus and draining battery. The worst were Nero Kwik (95), Fongo (58), Picasa Tool (59), Evernote widget (31). I uninstalled the first 3, and also CNN (7), UC Browser (6), Free WiFi Spot (6), and Crackle. Initial start-up still is slow, but most UI hangs and all process errors have disappeared.
I have also now updated all apps. I did not do a factory reset as some recommended, and which has led to problems for some.
Can find absolutely no comment or advice from Google.
 
#7 terrirers, Feb 9, 2015
A factory reset would have probably led you with less problems. As far as using a third party program that "tells you whats killing your battery" I would approach with extreme caution. Most of these types of apps have been proven to be ineffective and at worse are as my buddy would put it Snake Oil. Personally I do a fresh install when it comes to a New Version. I view it like this I would not change the engine in my car and use the old oil that I had. Updating an Operating System is very much the same If you have stuff that's no longer compatible it will cause issues.
 
#8 argedion, Feb 10, 2015
^^^so much this!!
 
#9 funkylogik, Feb 19, 2015
PLEASE HELP. Hi, I imagine that you guys get these types of posts a lot, but I really need help. I am trying to root my new (as in just bought, not version (it's the 2012 if that makes any difference)) Nexus 7. First I tried using the Nexus Root Toolkit, but that seemed to complicated so I went for a one-click root thing. I then tried to use kingroot which failed. After that I tried kingo-root which failed and reset my phone. After those two attempts I went for one that worked on my old phone, the kingroot app. This app successfully rooted my tablet (confirmed by the app itself and root checker). However when I restarted the device I got stuck on the loading screen (the one with the swirling colorful circles). I booted into recovery mode, cleared the cache (I could not find the Dalvik cache), then reset and restarted the tablet. But after all of that, the tablet was still stuck on the swirling loading screen. Please help me fix this, I just dropped $100 on that tablet (I'm a teenager with very little $) and I don't want that to go to waste.
 
#10 fr3d_fr3dr1ck50n, Jan 18, 2017
I replied to you in the other thread :).

NRT is your best option / advice--I've got a 2012 Nexus 7 and from what you've posted, the Nexus Root Toolkit would be spot-on for you.
 
#11 scary alien, Jan 19, 2017
I followed your guide but NRT doesn't find my Nexus in bootloader?

I have Nexus 7 2013 Android 6.0.1 - Build: MOB30X

 
#12 Nexus72nd, Feb 12, 2017